jun

DSM 6.2 Loader

Recommended Posts

5 hours ago, Xeno said:

Thanks, yeah I'm on 1.04b 918+ and couldn't get the hw transcoding and my mellanox 10GbE nic to work.

 

Thanks, hopefully Jun will figure out a new loader soon so that non-Synology drivers work :(

 

 

Share this post


Link to post
Share on other sites

So quick question - with 1.03b and the 3617xs 6.2 image, will mellanox and LSI cards work without the driver extension pack?  It seems that the driver pack is only for 918 images at this time if I’m reading correctly. 

 

With my hardware setup, would I need to go with 6.1.7 and the driver extension pack for that?

Edited by cferra
Spelling

Share this post


Link to post
Share on other sites

hi

i am building a new nas for replacement of the old 5.2. i have mb j4205 and downloaded jun loaeder 1.04. replaced mac adress, pin and vid for usb and lan card.

must the serialnummber replaced with ?

 

xpenologyserial generator has only serial for 3615, 3617 and 916+

 

or can i use the serial number mentioned in grub

 

thanks eric

 

 

Share this post


Link to post
Share on other sites

@xp_1409 You may use the serial provided, or you can just alter it a bit, both things will work (as long as you have only 1 NAS in you LAN using*that* serial).

Share this post


Link to post
Share on other sites

Is it possible to increase the amount of hdds which can be installed at ds918+?

i got 7*4tb and 2*3in a baremetal ds3617 with 1.02b and Want to upgrade to 918+ with 1.04. i want to reconfigure my actuall raid during setup therefore i Need more than the normal 4 drives

 

 

Share this post


Link to post
Share on other sites

HI Mahssel

I installed today my setup with a ASROCK H370m-itx ( 6 x SATA / 2 x m2 ) and a Dell PERC H310 IT Mode Controller ( 8 x SATA )

DS 918+ and Laoder 1.04b

All drive are shown correctly at Storage Manager ( 16 Drives )
I used for testing 2 SSDs connected to Mainboard and 8 x HDD connected on PERC Controller. Everything was working without errors or any special configuration. Out of the Box :)

 

Alex

Share this post


Link to post
Share on other sites

I

On 12/2/2018 at 8:40 PM, baratta930 said:

 

Thanks, hopefully Jun will figure out a new loader soon so that non-Synology drivers work :(

 

 

Yeah, I'm going to downgrade since I can't get my mellanox to work.

Share this post


Link to post
Share on other sites
18 часов назад, Lexizilla сказал:

HI Mahssel

I installed today my setup with a ASROCK H370m-itx ( 6 x SATA / 2 x m2 ) and a Dell PERC H310 IT Mode Controller ( 8 x SATA )

DS 918+ and Laoder 1.04b

All drive are shown correctly at Storage Manager ( 16 Drives )
I used for testing 2 SSDs connected to Mainboard and 8 x HDD connected on PERC Controller. Everything was working without errors or any special configuration. Out of the Box :)

 

Alex

Checking reviews of this board and see only one m.2 slot, there are pro4 version with one LAN port and two m.2.Does it works with pcie SSDs?Newer loader should accept m.2 ngff, as synology released expansion slot for those this year.Old loaders/DSMs supported just m.2 SATA spec SSDs.Using cache feature on few production systems.BTW cheap ASM1061 dual m.2 slot sata expansion boards works fine (50$),same as QNAP expansion board dual m.2 SATA (110$) but in has addinional cooling (yep, they are hot when used as cache 50-75C).

Degraded by smart wear level for 30% past 12 month.Consumer grade SSDs (any way its mirrored and capped by SATA spec speed limit, 400MBps +/-)

Off topic ,but maybe someone will find it useful.

 

Share this post


Link to post
Share on other sites

HI,

if you remove the WiFi card, then you get the second M2 Port..

If they are working, I don´t kow. I never tried it. Don´t have a M2 SSD....

 

Share this post


Link to post
Share on other sites

Hello all!

Because I do not read on time what's happen if the DSM 6.1.7 updates to 6.2, my running 3615xs system has been bricked up!

 

The 1.02b loader don't work anymore, so I wait till the Jun makes some research and give us a new bootloader able to work with DSM 6.2 (Thank YOU, Jun, for your great work!)

At this point, I think, is not so important what kind of HW do I have, because:

 - I use the same barebone Intel based HW as when the DSM 6.1.7 runs on a 3615xs system;

 - I use the same USB stick (having the same VID & PID) as in the past;

 - The LAN connection is the same; the MAC address and reserved IP address given by my DHCP router are the same;

 

Nevertheless, using the Jun's bootloader v1.03b for DSM 6.2 (created on 07.08.2018) and editing the SN, MAC, VID and PID in the grub.cfg (as I said, using the same values as for v1.02b), the Synology_Assistant could not find any server on the LAN. Not even to be able to make a fresh install using the proper PAT file.

The server's screen shows the thing with "...Happy..." - you know what I am talking... and that's it!

 

I wonder: why is that? Anybody?

Why, bootloader v1.02b worked in the past, and using the same HW, LAN setting, USB stick but with v1.03b bootloader, I am not able even to see my HW?!

(Sorry, if it will be requested, I could provide all my HW specs, but I don't want to make the post to complicated when -if you ask me- the logic says there is no need of HW specs if with the same HW it worked flawless in the past!)

 

Thank you in advance, guys! Please help! ...Or suggest...

Share this post


Link to post
Share on other sites

I think it´s helpful or necessary to describe your hardware set because the version of juns loader, cpu, motherboard, nic,...depends on each other.

 

Or have a look at this forum and search for your combination to find your best solution that works.

 

I for myself changed some weeks ago with my hardware combination I didn´t switch and juns new loader 1.04b from 3615xs to 918+. I had luck - it works. But it was risky.

 

greetings

Edited by sunshine

Share this post


Link to post
Share on other sites

Hi there,

in a few days i will set up my NAS for first time. i am using a j5005-board with 8GB Ram.

So loader 1.04b with DSM 6.2.1 for 918+ will be a good choice or better go with loader 1.03b and DSM 6.1.7/6.2 for 3615 (does this work at j5005 Boards?)?

 

When choosing 6.2.1 for 918+ which serial should i use since the generator supports only 916+ and 3615/17?

 

Thanks in advance for your reply.

 

Best wishes Phil

Edited by Thorlaf
edit

Share this post


Link to post
Share on other sites

Checked the server today and all the drives that are connected to LSI 9211-8I crashed or failed. The reaming derives that are connected to on board sata are all ok.

Drives hocked up to LSI crashes after a period of time usually withing 24 to 48 hours.

 

Snapshot.jpg

Share this post


Link to post
Share on other sites
3 hours ago, sunshine said:

I think it´s helpful or necessary to describe your hardware set because the version of juns loader, cpu, motherboard, nic,...depends on each other.

 

 

Sorry for this long post, but my HW specs has been requested... I promise the next one will be short one..

 

So, my DSM 6.1.7 server (DS3615xs with v1.2b Jun's bootloader) has been installed (and works until I validate the upgrade to 6.2.x -I don't remember well) on the following HW:

 

MB: 

    Gygabyte GA-C1037UN-EU (rev. 1.0)

 

CPU:    

  Built in with an Intel® Dual-core Celeron® 1037U processor (1.8 GHz)

  2 MB L3 cache

 

Chipset    

  Intel® NM70 Chipset

 

Memory:    
  2 x 1.5V DDR3 DIMM sockets supporting up to 16 GB of system memory;
  2 x 1GB DDR3 / 1333 MHz memory modules installed in Dual channel memory architecture;

 

Onboard Graphics    Integrated Graphics Processor:
  1 x D-Sub port
  1 x HDMI port, supporting a maximum resolution of 1920x1200
  * Support for HDMI 1.4 version.
  Maximum shared memory of 1 GB

 

Audio:
  Realtek® ALC887 codec
  High Definition Audio
  2/4/5.1/7.1-channel

 

LAN:
  2 x Realtek® GbE LAN chips (10/100/1000 Mbit)

 

Expansion Slots:    
  1 x PCI slot

 

Storage Interface    Chipset:
  1 x SATA 6Gb/s connector (SATA3 0)
  2 x SATA 3Gb/s connectors (SATA2 1~2)
  1 x eSATA 3Gb/s connector on the back panel
  JMicron JMB368 chip:
  1 x IDE connector supporting ATA-133/100/66/33 and up to 2 IDE devices

 

USB    Chipset:
  8 x USB 2.0/1.1 ports (4 ports on the back panel, 4 ports available through the internal USB headers)

 

As I said, logically speaking, this HW worked from DSM 6.1.2 till 6.1.7 ( I validate all proposed updates! - bad idea!) very well using Jun's bootloader v1.02b for ds3615xs.
Now, using the same HW (the same LAN connection, the same USB stick) but with Jun's bootloader v1.03b from August 2018 (having grub.cfg modified accordingly), 
I am not able to detect anything on LAN, using Synology Assistant (v6.2-23733) (UEFI and Standard has been tested also at boot time). No BIOS modifications!

 

If I boot from a Linux live stick with PartitionMagic, I could see my LAN (I ping successfully my router at 192.168.1.1; my HW having 192.168.1.2 as fixed address given by router's DHCP)     
Also I could see the server's disk (one SATA disk connected on SATA3 port, having 3GB) with some raid partitions (DSM specific) and one big partition ext4, with all my files and directory structure on it.
But when I boot from the bootloader v1.03b, nothing happen, as I said...

 

Any suggestions, please?!

Thank you, guys!

 

Edited by roadx

Share this post


Link to post
Share on other sites
9 hours ago, Lexizilla said:

HI,

if you remove the WiFi card, then you get the second M2 Port..

If they are working, I don´t kow. I never tried it. Don´t have a M2 SSD....

 

The second M.2 port (if you remove the wifi) is not valid for SSD (is key E, I told you before), and is limited to certain things -wifi, gsm cards, sata chipsets... just google it!!

Share this post


Link to post
Share on other sites

I'm trying out the v1.04b loader and in my virtual enviroment it isn't pulling an IP address? VMWare Workstation Pro 14

 

I forgot my password for the VM running v1.03b and tried the 'reinstall' option on bootup and it just takes me to the login page :(

Share this post


Link to post
Share on other sites

Hello guys!

 

As I said, at  this moment, my formerly server ( a ds3615xs with DSM 6.1.7, using BL v1.02a), which has been bricked out by myself when I validate (wrong choice!) the upgrade action from 6.1.7 to 6.2 is unusable. Waiting for BL v1.03b, now, I proceed to make my server working again, but...

 

Doing all as I previously done (VID/PID/MAC/SN modified on 'grub.cfg' file as I've done for BL v1.02b), now, I have a failure, because my server (using BL v1.03b this time)  is not found on LAN by the Synology Assistant, nor by pinging his static internal IP address (192.168.1.2 - which is given by my router's DHCP according the used MAC)

 

😟 

 

Reading around here, it seems the cause of my server malfunction is the Realtek NIC (it's a built-in one, but successfully used before with BL v1.02b) which is not supported by the BL v1.03b and DSM 6.2 (as I understand by reading this topic...)

(the HW is showed in the signature!)

 

Is that right?

Should I re-install DSM 6.1.7 and using the "old" BL v1.02b and stop update/upgrade for the future?!

 

Any suggestion is welcomed!

Thank you!

 

Edited by roadx

Share this post


Link to post
Share on other sites

@roadx : as you have found out, your Realtek nic is not compatible with DSM 6.2.1, and bl 1.03.

Some Realtek nic's will work with bl 1.04 if the rest of the hw is compatible with the DS918+

With your current hw, and bl 1.03, the newest DSM you can run, (as DS3615/3617), would be 6.2 update2, but it will fail if you update higher (6.2.1).

 

btw: you should really read the warnings and some of the "horror-stories" posted, before doing ANY update.

 

 

Edited by bearcat
typo

Share this post


Link to post
Share on other sites

Verified again this morning all drives attached to sas keep crashing. 

So if you have mellanox  nic and SAS9211-8i I would recommend not to use 1.04b at this time.

Opera Snapshot_2018-12-06_084633_192.168.1.128.jpg

Share this post


Link to post
Share on other sites

@bearcat: Thank you for the answer! Still, about my HW, you said: 

 

2 hours ago, bearcat said:

With your current hw, and bl 1.03, the newest DSM you can run, (as DS3615/3617), would be 6.2 update2, but it will fail if you update higher (6.2.1).

 

... but NOT with the Realtek NIC, right?!

 

I should install an Intel NIC if I found one half-sized. Anyway, the DSM 6.1.7 (ds3615xs) with BL v1.02b is all I need: file -server, media-server, sharing place. So, I will try to see if I could revert back to what it was before 6.2 update/upgrade

 

Keepin' touch!

Meanwhile, if you, guys, have any other suggestion(s), I'll appreciate!

 

Thx!

Share this post


Link to post
Share on other sites
Hi there,
in a few days i will set up my NAS for first time. i am using a j5005-board with 8GB Ram.
So loader 1.04b with DSM 6.2.1 for 918+ will be a good choice or better go with loader 1.03b and DSM 6.1.7/6.2 for 3615 (does this work at j5005 Boards?)?
 
When choosing 6.2.1 for 918+ which serial should i use since the generator supports only 916+ and 3615/17?
 
Thanks in advance for your reply.
 
Best wishes Phil
Noone can give me a good advice, which loader/dsm setup will be the best (most stable / compatible) for my chosen hardware setup?

Greetings

Gesendet von meinem ONEPLUS A3003 mit Tapatalk

Share this post


Link to post
Share on other sites
1 hour ago, Thorlaf said:

Noone can give me a good advice, which loader/dsm setup will be the best (most stable / compatible) for my chosen hardware setup?

Greetings

Gesendet von meinem ONEPLUS A3003 mit Tapatalk
 

I would suggest to setup a test setup, run different loaders and see what works best on your hardware.

 

Share this post


Link to post
Share on other sites

When trying to mount Jun's Loader v1.03b DS3615xs with OSFMount, I'm not getting the popup where I can select partition 0. It does work with Jun's Loader v1.03b DS3617xs. Anything wrong with the 3615xs one?

Share this post


Link to post
Share on other sites
2 hours ago, roadx said:

@bearcat: Thank you for the answer! Still, about my HW, you said: 

...snip...

... but NOT with the Realtek NIC, right?!

...

 

Well, as you may know, Realtek makes more than 1 model of nic's, and without knowing exactly what your model is, I can only "read the tarot-cards" ;-) or guess.

 

In one of my test-setups, using Asrock Q1900-ITX, the nic is a RTL8111GR, this works both with :

bootloader 1.03 DS3617, DSM up to, and including 6.2 update2, but not 6.2.1

bootloader 1.04 918+, DSM 6.2.1-23824 - Update 1 with no problem.

 

If you try to make a new fresh install, based on 1.03 3615/3617,

make sure to download the 6.2 pat file and install it manually and do not update to 6.2.1 then maybe it will work for you.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.