Polanskiman

Tutorial: Install/Migrate DSM 5.2 to 6.1.x (Jun's loader)

Recommended Posts

Hello,

I've made the Update 5.2 to 6.17 on HP Gen Baremetal, 1.02b.

 

On 5.2 I had: 250GB / 1 TB / 1 TB / 2 TB , SHR/ext4 - and the speed was about 100-109 MBit/s

On 6.17 I have: 1 TB / 1 TB / 2 TB / 4 TB, SHR/btrfs - and the speed is max. 80, most times about 60 MBit/s

 

A complete Backup took with 5.2 18-20 hours.

Now I've tried a Backup: after 22 hours it was at 49% and I cancelled it. The speed was only a few kB.

 

What can I do? Back to ext4?

Share this post


Link to post
Share on other sites

BTRFS CPU requirements are somewhat higher.  Synology released BTRFS support on the Atom chips (DS412+/1512+/1812+) and performance was measurably worse.  It's not as dramatic with faster CPU's.

 

 I'd hazard that something isn't right.  What CPU?  What disk controller?

 

10 hours ago, TVJunky said:

Hello,

I've made the Update 5.2 to 6.17 on HP Gen Baremetal, 1.02b.

 

On 5.2 I had: 250GB / 1 TB / 1 TB / 2 TB , SHR/ext4 - and the speed was about 100-109 MBit/s

On 6.17 I have: 1 TB / 1 TB / 2 TB / 4 TB, SHR/btrfs - and the speed is max. 80, most times about 60 MBit/s

 

A complete Backup took with 5.2 18-20 hours.

Now I've tried a Backup: after 22 hours it was at 49% and I cancelled it. The speed was only a few kB.

 

What can I do? Back to ext4?

 

Share this post


Link to post
Share on other sites

I bought a HP Proliant Microserver G1610T. I never changed the Hardware.

 

CPU Intel Celeron G1610T 2x 2,3GHz - I never saw a load over 50%. Normally about 10-20%

 

How can I find the type of Disk Controller? Or do you mean AHCI or so?

 

The picture shows running Hyper Backup. It lasts 3 times longer than before

 

 

grafik.thumb.png.9d9c61047d3109a25264fccff08399e4.png

Share this post


Link to post
Share on other sites

The processor is adequate.  I'm not sure of source/destination of the backup, but your resource graph is showing very little network activity.

How many volumes do you have?  If you have four volumes, the lower left graph is indicating 100% disk utilization.

 

I'm not a fan of Hyperbackup.  When I did use it it was temperamental.  Did you port the existing setup over or create a new one using the 6.1.7 Hyperbackup binaries?

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you for this guide. Just finished Installing on my TerraMaster F4-220 as I could not stand the factory Terra-OS. For anyone interested in purchasing this NAS it has 5 sata ports, but only 4 front slots. I used the 5th port for an SSD and plan to use it as an SSD cache. 

 

 

IMG_20190101_044959.jpg

 

 

IMG_20190101_0450131.jpg

Edited by Diesel0991

Share this post


Link to post
Share on other sites
Posted (edited)

Hi guys. Synology assistant can't find my storage. Also I tried to find it via website. PC booted up from USB but still can't find anything. (no firewall)

Any ideas?

 

Edited by Konfl1kt

Share this post


Link to post
Share on other sites
Posted (edited)

I did 3 things.

1. Turn off Audio Controller

2. Change priority to onboard graphics.

3. Turnoff bluetooth controller.

 

Now it works. Thank you! :)

Edited by Konfl1kt

Share this post


Link to post
Share on other sites
Posted (edited)

Installed DS3617xs on Dell T3500 and it worked from first try. Thanks. 

Edited by LFC-

Share this post


Link to post
Share on other sites

 

I am trying install  DSM 6.2 Jun's Loader v1.04b DS918+ synoboot-ds918.zip , but didn't boot .

I was change :

set vid=change
set pid=change
set sn=change
set mac1=change

 USB is not boot. I was tried DSM 6.1 3617 it is  booting ok. and tried DSM 6.2 3617 it is not boot.

where is problem?

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Hello,
 
i follow the steps and i get 
invalid cluster 35171
What is this?



Hello again.

I finally make it works.

I have some questions.

Can I update to latest DSM and how?

Can I login with QuickConnect?

In HP can I put on ODD an SSD?


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
Share on other sites

First. Thanks for the guide. 

 

Well I was gonna to install this on my laptop, its an Hp Elitebook 6930p. 

During install Synology told me about something with an old file, that I need a newer or something (I think I downloaded the wrong on there server from the start).

I added a new one but it never worked. Some error. 

 

So the installation failed and now I got a bit of a headache. 

 

My laptop aint starting. It brings up the like loading menu as it did when I started the bootloader. 

Then it seems to try to connect to something (shows my MAC and some more info). 

Then BAM, "Non system or disk error". "replace and strike any key when ready. 

 

Now I tried starting up with a new usbloader, one with OpenMediaVault on it and then I tried with an SD card with a installer for LibroELEC on it. 

I tell the computer to boot from the usb/SDcard but it seems like it aint following my command. 

 

It just starts up that loading menu and then shows "Non system disk error" message. 

 

Any ideas? ATM the computer is busted and my balls to when the girlfriend finds out.

 

Would really, really appreciate some help here. Im so stuck and got no idea how to solve this! 

 

[Deleted a pic. Maybe shouldnt share My macadress.

 

IMG_20190212_234815.jpg

Edited by OhGodWhatDidIDo
Attached pics.

Share this post


Link to post
Share on other sites
On 12/30/2018 at 5:09 AM, TVJunky said:

Hello,

I've made the Update 5.2 to 6.17 on HP Gen Baremetal, 1.02b.

 

On 5.2 I had: 250GB / 1 TB / 1 TB / 2 TB , SHR/ext4 - and the speed was about 100-109 MBit/s

On 6.17 I have: 1 TB / 1 TB / 2 TB / 4 TB, SHR/btrfs - and the speed is max. 80, most times about 60 MBit/s

 

A complete Backup took with 5.2 18-20 hours.

Now I've tried a Backup: after 22 hours it was at 49% and I cancelled it. The speed was only a few kB.

 

What can I do? Back to ext4?

 

 

 

 

Sorry to jump into an old topic.  I am in a similar boat, updating an old 6.0.2.

Regarding SHR, my understanding is:

  1. Synology basically deprecated it?
  2. It can be re-enabled manually in dsm 6.x by uncommenting

I am considering using btrfs Raid1 > Raid5 (starting with 2 disks then gradually increasing and converting).  I understand Synology has made stability improvements so it is actually OK running btrfs in raid5.  Is this correct?  Is it possible @TVJunky is having difficulty because of SHR - or is SHR still recommended - even though it is deprecated?  

Share this post


Link to post
Share on other sites
5 hours ago, rl77 said:

Sorry to jump into an old topic.  I am in a similar boat, updating an old 6.0.2.

Regarding SHR, my understanding is:

  1. Synology basically deprecated it?
  2. It can be re-enabled manually in dsm 6.x by uncommenting

I am considering using btrfs Raid1 > Raid5 (starting with 2 disks then gradually increasing and converting).  I understand Synology has made stability improvements so it is actually OK running btrfs in raid5.  Is this correct?  Is it possible @TVJunky is having difficulty because of SHR - or is SHR still recommended - even though it is deprecated?  

 

SHR is not deprecated, it is not a sales factor in the upper-end of their line and there is additional complexity and slight performance impact for using it.  So in 6.x, until 6.2, it was disabled by default on the 3615/3617 image, but enabled on the 916 image.  An imported SHR volume will work fine.  In 6.2.x, you essentially have the option of using LVM when you create your Storage Pool ("fast" vs "flexible") which is how SHR is implemented.

 

To your RAID5 btrfs question, Synology does not using btrfs native RAID at all.  BTRFS only sees a single volume which is the output of MDRAID (without SHR) or LVM (with SHR).  So you can safely use any RAID approach you wish with BTRFS on Synology.

Share this post


Link to post
Share on other sites
7 hours ago, flyride said:

 

SHR is not deprecated, it is not a sales factor in the upper-end of their line and there is additional complexity and slight performance impact for using it.  So in 6.x, until 6.2, it was disabled by default on the 3615/3617 image, but enabled on the 916 image.  An imported SHR volume will work fine.  In 6.2.x, you essentially have the option of using LVM when you create your Storage Pool ("fast" vs "flexible") which is how SHR is implemented.

 

To your RAID5 btrfs question, Synology does not using btrfs native RAID at all.  BTRFS only sees a single volume which is the output of MDRAID (without SHR) or LVM (with SHR).  So you can safely use any RAID approach you wish with BTRFS on Synology

4

 

@flyride Thanks for your clarifications! Good to know SHR is still an option.  I will uncomment it then in 6.1.7.  

Share this post


Link to post
Share on other sites

Thank you If you want try install new DSM (6..2 ex) and keep your previous DSM but both with the same MAC ADDRESS :

 

VMware Workstation 15 Pro

DSM 6.2

 

To change mac address

just type  C at begin boot to go to grub prompt

 

grub>mac1 0011322CXXXX

grub>exit

 

That's all

 

Share this post


Link to post
Share on other sites
Posted (edited)

So here is what happened to me.

 

Created usb-stick with Jun's official v1.02b loader on my HP N54l. Switched on server, synology assistant found the system and I started the migration process. I choose "keep my data and settings" but THEN i did not give him the correct "DSM_DS3615xs_15217.pat" file (there was a manual button which I did not click). Instead the synology assistant downloaded the newest version from the internet I guess and now the system won't boot up. What can I do now?

Edited by flitschbirne

Share this post


Link to post
Share on other sites
On 3/7/2019 at 10:25 PM, flitschbirne said:

So here is what happened to me.

 

Created usb-stick with Jun's official v1.02b loader on my HP N54l. Switched on server, synology assistant found the system and I started the migration process. I choose "keep my data and settings" but THEN i did not give him the correct "DSM_DS3615xs_15217.pat" file (there was a manual button which I did not click). Instead the synology assistant downloaded the newest version from the internet I guess and now the system won't boot up. What can I do now?

 

FYI: Managed to role back to 6.1.7-15284...

Share this post


Link to post
Share on other sites

 

Hello, is this tutorial also possible directly for DSM 6.2 with the right loader for D3615XS? Or is there more to be done? I would like to migrate directly from DSM 5.2 to DMS 6.2.x.

 

Thank you.

Share this post


Link to post
Share on other sites

Could someone help me with the installation on Proxmox 5.2 ? I'm in a boot loop, after the timer counts down from 10 minutes I am redirected to the recovery screen. Using the serial connection I see DiskStation installing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.