jun

DSM 6.2 Loader

Recommended Posts

Hello, 

 

I'm using DSM 6.2-23739 Update 2 (DS3617xs) with no problems. Installed on a Microserver Gen8 with Core i3-3240.

Share this post


Link to post
Share on other sites

And this is the latest DSM Version, at the moment, for install?

 

Version: 6.2.1-23824 brick my NAS, right?

Edited by CrazyCreator

Share this post


Link to post
Share on other sites

I have 2 questions, guys.

1. After i mounted (by OSF mount) to adjust SN, MAC, VID, PID in grub file, I burnt the img into a USB drive by Rufus. Finally, I found out I keyed in a typo my MAC. I wanted to correct it in grub file but I couldn't see my USB drive anymore when I hook it up to my Windows 10 desktop. I could see my USB drive in Disk Management thou. Please help.

2. My baremetal Nas has 12 HDDs, should I leave SataPortMap=1 (as default) or change to 12 in grub?

Thanks for your prompt replies. I appreciate it.

Share this post


Link to post
Share on other sites
13 minutes ago, Elpee said:

I have 2 questions, guys.

1. After i mounted (by OSF mount) to adjust SN, MAC, VID, PID in grub file, I burnt the img into a USB drive by Rufus. Finally, I found out I keyed in a typo my MAC. I wanted to correct it in grub file but I couldn't see my USB drive anymore when I hook it up to my Windows 10 desktop. I could see my USB drive in Disk Management thou. Please help.

2. My baremetal Nas has 12 HDDs, should I leave SataPortMap=1 (as default) or change to 12 in grub?

Thanks for your prompt replies. I appreciate it.

Question 1:
You probably have to do it all over again. To see your USB drive you need to do a clean and format.
This is done by using diskpart in cmd.


Open cmd (Command line)
Type -diskpart-
then -list disk-
then select the USB disk. Example. -select disk 1
Then -clean-
Then -create partition primary-
Now you can see the USB drive and format as usual in windows by right clicking and selectin -Format-

Edited by GizmoPower

Share this post


Link to post
Share on other sites
On 9/18/2018 at 7:41 PM, JMRR said:


Try another nic adapter on esxi


Sent from my iPhone using Tapatalk

 

Bought an intel pro 1000 pt, same thing, no ip after restart. Tried with DSM 6.1 image for 916+, all is working as it should with hardware transcoding. Tried esxi, but I get an error 22 there.

 

Share this post


Link to post
Share on other sites
13 hours ago, GizmoPower said:

Question 1:
You probably have to do it all over again. To see your USB drive you need to do a clean and format.
This is done by using diskpart in cmd.


Open cmd (Command line)
Type -diskpart-
then -list disk-
then select the USB disk. Example. -select disk 1
Then -clean-
Then -create partition primary-
Now you can see the USB drive and format as usual in windows by right clicking and selectin -Format-

Thanks.

How about question 2?

Should I leave SataPortMap=1 (as default) or change to 12 in grub for 12 HDDs?

Share this post


Link to post
Share on other sites
On 9/23/2018 at 7:05 PM, GizmoPower said:

I get: No hard disk found.
What to do?


- Loader version and model: Jun's Loader v1.03b - DS3615xs
- Installation type: Baremetal Intel S5500HCV

 

No solution yet?

Share this post


Link to post
Share on other sites
 
No solution yet?
You install 6.2 or 6.2.1?
For 6.2 you can create extra.lzma with drivers you need.

For 6.2.1 no solution yet.

Wysłane z mojego SM-G930F przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
3 minutes ago, luchuma said:

You install 6.2 or 6.2.1?
For 6.2 you can create extra.lzma with drivers you need.

For 6.2.1 no solution yet.

Wysłane z mojego SM-G930F przy użyciu Tapatalka
 


Thank you, but I dont know how to compile drivers.. :/ 
I am on 6.1.6-15266 with 1.02b
Should I just wait?

Share this post


Link to post
Share on other sites
6 hours ago, luchuma said:

You install 6.2 or 6.2.1?
For 6.2 you can create extra.lzma with drivers you need.

For 6.2.1 no solution yet.

Wysłane z mojego SM-G930F przy użyciu Tapatalka
 

For 6.2 you can create extra.lzma with drivers you need, really ? 

Where is it ? Because they still have not made on yet for DS3617 or DS3615 .

They only have it for the DS918+

So we must wait...

Edited by painkiller895

Share this post


Link to post
Share on other sites

- Outcome of the clean install: FAIL

- DSM version prior update: none

- Loader version and model: Jun's Loader v1.03b - DS3617xs

- Using custom extra.lzma: NO

- Installation type: Clean install

- Hardware: HP Microserver Gen8, RAM: 16GB HP, CPU E3-1230 V2 @ 3.3GHz, NIC: HP QLogic 82XX dual 10GB SFP+, HDD 4 * Samsung HD204UI. SSD: Samsung SSD 840 EVO 120GB

- Additional comments : After install it fails to get an ip address on any network card, if i take out the HP QLogic card before install it works, as soon as i put it back in, the machine endlessly writes below during boot

Quote

usb 3-1: USB disconnect, device number XX

 

EDIT: after further investigation it seems the qlcnic driver is broken, when the card is in i cant even do ifconfig/lspci command via serial console without the system freezing/halting.

 

Kind Regards,

LThasenhod

Edited by lthasenhod

Share this post


Link to post
Share on other sites
For 6.2 you can create extra.lzma with drivers you need, really ? 
Where is it ? Because they still have not made on yet for DS3617 or DS3615 .
They only have it for the DS918+
So we must wait...
Realy you can create not download ;)
There is released Source for 6.2

Wysłane z mojego SM-G930F przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
On 8/1/2018 at 11:00 AM, jun said:

Hi, everyone,

 

Thanks for you patience.

 

I've uploaded a beta version of 3615/3617 loader to mega, please test and give your feedback.

 

https://mega.nz/#F!ZlkHQTTb!keje3RK017OjTp3vuWb-Cw

 

note:

uefi boot still has issue, it will be fixed when I have more time.

 

 

---Beginning of addition by polanskiman---

  For reference (Reveal hidden contents)

 

---End of addition by polanskiman---

I have J5005 , this motherboard only have uefi boot . but uefi doesn't work with this loader . can not find the disk.

Share this post


Link to post
Share on other sites

Can anyone rebuild last loader version (for 3617) with MBR Partition table? Please!😢

Edited by Rezdbic

Share this post


Link to post
Share on other sites

I've just installed my first XPEnology with this. :)

 

Used the bootloader from this Mega repo (Jun's v1.03a2 DS918), did a bare metal install and just installed from the web (so didn't use the pat. I downloaded the wrong one and it was faster to try directly), worked like a charM. After that I could update without any problems to the latest version, DSM 6.2-23739. Oh, and UEFI boot.

 

ASRock J4105-ITX (Intel Celeron J4105), 16GB RAM, 2xSATA3 WD30EZRX

Edited by Rowdy

Share this post


Link to post
Share on other sites

- Outcome of the update: SUCCESSFUL

- DSM version prior update: DSM 6.1.7 - 15284

- Loader version and model: JUN'S LOADER v1.03b - DS3615xs

- Using custom extra.lzma: NO

- Installation type: TerraMaster F4-220

- Additional comments: CHANGED BIOS TO LEGACY AND CHANGED BOOT ORDER

 

 Everything works...as mentioned I had to change the bios from UEFI and Legacy to Legacy ONLY and change the boot order to boot from the USB first

Terramaster.jpg

  • Like 1

Share this post


Link to post
Share on other sites

- Outcome of the update: SUCCESSFUL
- DSM version prior update: DSM 6.1.6-15266
- Loader version and model: Jun's Loader v1.03b - DS3617xs

- Using custom extra.lzma:  NO
- Installation type: Baremetal Intel S5500HCV
- Additional comments: Changed storage controller to AHCI  in bios

I first had the -No hard disk found-
Then changed storage controller in bios to AHCI

Share this post


Link to post
Share on other sites
8 hours ago, yozz said:

Hey!

How i can convert .img loader to .iso? Need for installing xpenology to proxmox.

Check out some tutorials in the installation section.

 

 

Share this post


Link to post
Share on other sites
1 час назад, marigo сказал:

Check out some tutorials in the installation section.

 

 

 

TY!

 

guys! anyone have worked dms services? quickconnect and same? or this features don't work on xpenology?

Edited by yozz

Share this post


Link to post
Share on other sites
On 9/25/2018 at 5:32 PM, luchuma said:

Realy you can create not download ;)
There is released Source for 6.2

Wysłane z mojego SM-G930F przy użyciu Tapatalka
 

I have been able to compile for 6.2 but the drivers would only work while you havent installed the .pat, as soon as it reboots and the driver is used, network card or hba card ask for driver, it would crash. I think the sources avaliable for the 3615 abd 3617 may not be the latest or have the correct config. 

Share this post


Link to post
Share on other sites

Intel BS1200BTS + E3-1230v2 + 16G DDR3

 

1. Boot with USB ( modified usb flash vid )

2. Find device with Synology Assistant

3. Install 6.2 or 6.2.1

4. Reboot

5. Can NOT find device to continue final step ( write config and done )

 

do not know why

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.