Polanskiman

Tutorial: Install/Migrate DSM 5.2 to 6.1.x (Jun's loader)

Recommended Posts

Hello,

 

I have a simple question for my environment.

 

Current config:

- DSM 5.2

- Works now on HyperV as Virtual Machine.
Disks:

- VM Disk: Synology
- Ide Controller CD/Rom disk iso loaded: XPEnoboot_DS3615xs_5.2-5644.5.iso

- 2x Physical Disks for all of my Data (Formatted in Synology as Raid) yes, it works great!!

 

Questions:

1. So just i want to update to 6.1.3 without losing any data on that Physical Disks What are the best scenarios for me?

2. On the first page of the tutorial which ISO or Image should i to use in my situation? (i have HyperV)

 

Share this post


Link to post
Share on other sites

Hello all of you. I am completely new to this, I got my hands on an old pc (Fujitsu Celsius M470) that I would like to use as a NAS because I really need the Moments app by Synology, for creating shared photo albums with face recognition. I also have 4 spare HDD's that are ready to be used. So, I want to do a clean install, but I have no clue where to start. I found some old tutorials (between 2012 and 2015), but most times the links don't work anymore. Can anyone point me to a tutorial for a clean install with working links?

Share this post


Link to post
Share on other sites

I'm trying to run this on a Optiplex 3020 (i3-4130)
when I boot up Synoboot it says "go to http://find.synology.com/ and continue"
I go to that website but it doesn't find a Diskstation in my network.


Any ideas? 

 

Share this post


Link to post
Share on other sites

@Joep If you read post no.1 in this very thread, you will find

"If you are doing a fresh install of DSM 6.1 then carry on with the tutorial and omit references to DSM 5.2."

So, just follow that, any of the files you need to download you find here and the tools you need, you may find here.

 

@nex86 I have an idea, unless you are trying to do an update, ,make a new thread where you ask for help, 

and specify what loader you are booting from. And try to find some info about the network card you are using, as you are missing a driver.

Share this post


Link to post
Share on other sites

same system as you try to use, maybe ask him about any specials?

 

 

Share this post


Link to post
Share on other sites

So one more upgrade question.

I have the following setup

  • DS3615xs (INTEL Core i3-4130)
  • DSM 5.2-5967 Update 9

  • 1 volume of SHR-2 20TB (8x4TB WD Red)

at the following hardware setup

I can use this guide to make the jump to 6.1 for DS3615xs?

 

I don't care that much about the current DSM settings (but if i can keep them its great) and the data at the SHR2 are available elsewhere too (cloud & other backups).

 

I will keep the 5.2 USB drive and i will create a new one for the 6.1, can i boot from the 6.1 USB with a test drive (or with no drive) to check that everything is booting OK and then plug again all the drives to do the proper migration of 5.2 -> 6.1?

 

Thanx!

Share this post


Link to post
Share on other sites
3 hours ago, md1032 said:

will create a new one for the 6.1, can i boot from the 6.1 USB with a test drive (or with no drive) to check that everything is booting OK and then plug again all the drives to do the proper migration of 5.2 -> 6.1?

yes, i'd suggest to install first to a single empty disk to make sure everything is working

after this you can disconnect the disk and use the same usb with out old disks, it will suggest to migrate

if you want you can also test loader 1.04b and 918+ with a single disk, 918+ has kernel 4.4.59 as base

 

for your board:

nic is realtek (r8169), sata should work as ahci (at least with the right bios settings)

 

  • Thanks 1

Share this post


Link to post
Share on other sites
10 hours ago, IG-88 said:

yes, i'd suggest to install first to a single empty disk to make sure everything is working

after this you can disconnect the disk and use the same usb with out old disks, it will suggest to migrate

if you want you can also test loader 1.04b and 918+ with a single disk, 918+ has kernel 4.4.59 as base

 

for your board:

nic is realtek (r8169), sata should work as ahci (at least with the right bios settings)

 

 

 

Thanx for your reply!

What are the advantages of 918+? I have read at the forum that the specific synology can be used mostly for plex transcoding, is there anything else i am missing?

Also, the SHR2 will be recognised immediately or do i have to do anything extra (i read at the FAQ that i need to change a line at a config)?

Edited by md1032

Share this post


Link to post
Share on other sites
10 hours ago, md1032 said:

What are the advantages of 918+? I have read at the forum that the specific synology can be used mostly for plex transcoding, is there anything else i am missing?

newer kernel means newer and more driver, longer support (3615/17 might not get 7.0? next year), native nvme support (but for now no one found out how use it in xpenology)

 

11 hours ago, md1032 said:

Also, the SHR2 will be recognised immediately or do i have to do anything extra (i read at the FAQ that i need to change a line at a config)?

shr will also be recognised on 3615/17 but you can't create a new shr without the change from the faq, so no worry's when updating

 

Share this post


Link to post
Share on other sites

Hello everyone,

 

Im trying to install Xpenology on Dell optiplex 7XX series. (Dual core 2.0Ghz+, 2GB RAM, 1HDD with AHCI Sata suportt and Serial's enabled)

I'm using "Quicknick’s Loaders DSM 6.1.X", downloaded from https://xpenology.club/downloads/

Unfortunatly in both cases (XPEnology_DSM_6.1.x-quicknick-3.0.zip and ds3615xs_DSM_6.1.x-quicknick-3.0.zip), I'm getting error message during OS install from a file (previously downloaded from synology site) - something about fille corruption.

My question is, what I'm doing wrong?

 

Thanks for any replies,

Greetings

Share this post


Link to post
Share on other sites

Just an update, i managed to make the jump to 6.1 for DS3615xs and the custom extra.lzma ramdisk with no issues!

 

Now what's the latest update i can use with this configuration?

 

Thank you again for your help!

Share this post


Link to post
Share on other sites
On 11/21/2019 at 4:55 AM, polik said:

I'm using "Quicknick’s Loaders DSM 6.1.X", downloaded from https://xpenology.club/downloads/

Unfortunatly in both cases (XPEnology_DSM_6.1.x-quicknick-3.0.zip and ds3615xs_DSM_6.1.x-quicknick-3.0.zip), I'm getting error message during OS install from a file (previously downloaded from synology site) - something about fille corruption.

My question is, what I'm doing wrong?

 

Quicknick's loader is not supported, and not supported here.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.