Tutorial: Install/Migrate DSM 5.2 to 6.0.2 (Jun's loader)


Recommended Posts

Sorry for being noob, I just installed new USB stick with latest Jun Loader to upgrade to 6.1. When I boot with new bootlader stick NAS tells me that I need to upgrade.

 

Do I have to boot my nas with previous Jun's 1.01 boot loader, do the upgrade straight from nas GUI to latest 6.1 and after that reboot the nas but now with new 1.02a USB stick?

Personally I think this is the way but I would just like to ask if this approach is correct.

 

Thanks.

 

By the looks of your experience I recommend you stay a bit longer with 1.01. The latest 1.02 is an alpha version. Come back in 2/3 weeks once more feedback has come through and that I update the tutorial.

 

Just to answer your question. You need to update the loader first then do the DSM upgrade and not the other way around.

Link to post
Share on other sites
Sorry, the page you are looking for is not found.

 

After 2 days, now i have this message.

A restart doesn't get login page.

Tried also different network, same thing.

 

Sorry but you can't expect the community to help with so little information. Be a bit more thorough.

Link to post
Share on other sites

 

Just to answer your question. You need to update the loader first then do the DSM upgrade and not the other way around.

 

But if you update the loader the NAS won't boot if the NAS is stil on DSM 6.0.2-8451 Update 9 so I asked if you update DSM 6.0.2-8451 Update 9 to 6.1 and you replace the USB stick with new loader is that the correct way? Sure I will wait a little longer.

Link to post
Share on other sites

 

Just to answer your question. You need to update the loader first then do the DSM upgrade and not the other way around.

 

But if you update the loader the NAS won't boot if the NAS is stil on DSM 6.0.2-8451 Update 9 so I asked if you update DSM 6.0.2-8451 Update 9 to 6.1 and you replace the USB stick with new loader is that the correct way? Sure I will wait a little longer.

 

Disclaimer: I have not done the migration myself, just take below a grain of salt.

 

Imagine you own a physical 3615xs, like a real one not xpenology. Imagine it was on DSM 6 but died and you just received a replacement from the seller and it was pre-installed with DSM 6.1

 

So what you would do is just unplug all your HDDs from the old and slot them all into the new unit. Now DSM 6.1 is flashed in the DOM of the new unit (just like your new loader 1.02a) but all the system partition in your HDDs are on DSM 6. First boot up the new unit should prompt you to migrate your system partition to DSM 6.1, which then would allow you to use the NAS as you would before but now with DSM 6.1

 

This should be the same logic as getting xpenology DSM 6.1 work with migration from DSM 6

Link to post
Share on other sites

Hello!

At me the new loader 6.1 for 3617 on MB ASRock E3C226D2I from i210 refuses to be loaded again.

In a networked environment NAS doesn't appear.

On GA-N3150N-D3V 6.1 for both pieces of iron normally booted (as before).

Last time to me Polanskiman advised to make these changes.

Then everything earned.

And what it is possible to make now?

Link to post
Share on other sites

Hi there!

 

At first, thank a lot to Polankskiman, I am trying to follow your guides to resolve my problems.

 

My DSM Baremetal hardware:

Asus Eee 1008HA

NIC: Atheros AR8132 - Fast Ethernet 10/100 Mbps

CPU: Intel Atom N280 (x86)

 

I have already install older version of DSM (4.xx) on my Asus Eee. But now I am trying to install DSM 6.1 on that old computer. I don't want to upgrade, I have already formated

whole computer and now I am trying to install it as Baremetal with no luck.

 

I followed all the instructions but my computer is not visible in my LAN for Synology Assitant.

 

Is there a possibility that my NIC is not supported?

 

Thanks

Link to post
Share on other sites
Kitaro said:
Hello!

At me the new loader 6.1 for 3617 on MB ASRock E3C226D2I from i210 refuses to be loaded again.

In a networked environment NAS doesn't appear.

On GA-N3150N-D3V 6.1 for both pieces of iron normally booted (as before).

Last time to me Polanskiman advised to make these changes.

Then everything earned.

And what it is possible to make now?

 

For now please post your questions and comment about DSM 6.1 on Jun's thread. Jun's loader v1.02a doesn't seem stable so I am not answering questions about it here. I see several people are encountering issues so unless you are merely testing the loader on a test machine I suggest you stay away from it.

Link to post
Share on other sites
For now please post your questions and comment about DSM 6.1 on Jun's thread. Jun's loader v1.02a doesn't seem stable so I am not answering questions about it here. I see several people are encountering issues so unless you are merely testing the loader ok a test machine I suggest you stay away from it.

I see! Thanks a lot!

By the test machine (GA-N3150N-D3V) 6.1 3615 and 3617 it was launched regularly. But migrations at me for some reason didn't pass to load, or I not rather patient and couldn't wait for a disposable load after installation, but waited long. Several times it was successfully set from scratch while tried to win against QC. Alas, it is launched, checked and switched off therefore I can't check period of operation so far, and also operability of packets and remaining, can I will launch later. But in it even QC earned.

By the main machine (ASRock E3C226D2I with i210) - 6.1 3617 it isn't found on a network, and 3615 didn't try. And considering that you wrote, so far and I won't be.

I put everything on bare iron.

There are chances that 3617on ASRock E3C226D2I from i210 will once earn?

Link to post
Share on other sites

Good afternoon. Decided to make a server with a large capacity. Has iron on HP DL160 G5 with an installed RAID controller Adaptec asr 6405 for best performance, but the loader does not see the hard drive. Who faced with such? Tell us how to solve the problem. Or it is possible as that to organize connection of the drivers in the loader that he began to see the drives. here is the driver https://storage.microsemi.com/en-us/sup ... /sas-6405/ how to boot in bootloader I do not know. Help who than can.

Link to post
Share on other sites
Good afternoon. Decided to make a server with a large capacity. Has iron on HP DL160 G5 with an installed RAID controller Adaptec asr 6405 for best performance, but the loader does not see the hard drive. Who faced with such? Tell us how to solve the problem. Or it is possible as that to organize connection of the drivers in the loader that he began to see the drives. here is the driver https://storage.microsemi.com/en-us/sup ... /sas-6405/ how to boot in bootloader I do not know. Help who than can.

To try it is correct to register the SataPortMap parameter in the loader?

Link to post
Share on other sites

Hallo

 

I use the 6.0.2 Jun's Mod V1.01 loader with DSM DSM 6.0.2-8451 Update 9.

 

Can i Upgrade the Bootloader to DS3615xs 6.1 Jun's Mod V1.02-alpha and DSM Version: 6.1-15047-1 or is dis not Possible? or ist this bootloader not Stapel, and the Machines can Crash?

 

I have a HPE Microserver G8 i3 4130 and 2 GB ram.

 

Thanks for Information :grin:

Link to post
Share on other sites

Hi everyone,

 

Running DSM just fine on my N3150 board. Now I'm looking into adding more disks but only have 2 onboard sata interfaces. I can add a sata raid controller using my PCI x1 interface but I'm wondering which hardware is supported on this 6.0 firmware. Does the compatible hardware list on the main site still apply here? All suggestions more then welcome!

 

Edit: running with Jun 1.01

 

Thanks

Link to post
Share on other sites
Hallo

 

I use the 6.0.2 Jun's Mod V1.01 loader with DSM DSM 6.0.2-8451 Update 9.

 

Can i Upgrade the Bootloader to DS3615xs 6.1 Jun's Mod V1.02-alpha and DSM Version: 6.1-15047-1 or is dis not Possible? or ist this bootloader not Stapel, and the Machines can Crash?

 

I have a HPE Microserver G8 i3 4130 and 2 GB ram.

 

Thanks for Information :grin:

It's an alpha version. OK for testing but I wouldn't trust my data with it yet.

Link to post
Share on other sites
Hallo

 

I use the 6.0.2 Jun's Mod V1.01 loader with DSM DSM 6.0.2-8451 Update 9.

 

Can i Upgrade the Bootloader to DS3615xs 6.1 Jun's Mod V1.02-alpha and DSM Version: 6.1-15047-1 or is dis not Possible? or ist this bootloader not Stapel, and the Machines can Crash?

 

I have a HPE Microserver G8 i3 4130 and 2 GB ram.

 

Thanks for Information :grin:

 

Keep away from it. Test the new loader with a test machine ONLY if you like but do not use it with your current working machine. If you test v1.02a you can report your findings on the main thread, not here. The loader is not stable and most people are reporting issues.

Link to post
Share on other sites

I am the test server which is long launched didn't hold, and last night decided to leave and here that it showed me through approximately half of days of operation 6.1.

At first booted, but began to show errors different and it:

2559383

And then showed it:

2559380

Total:

GA-N3150N-D3V - 6.1 was got and how many and that works hours.

ASRock E3C226D2I - 6.1 - isn't got absolutely (network interface cards, and it is possible and controllers aren't loaded).

Link to post
Share on other sites

I have an intel server and I have install the version 5 on a CF card that was attached to the IDE drive. I want to update to the DSM 6 but after reading the tutorial I am not sure if it will work since my install is done on a local IDE disk drive (my data is on SATA drives). I don't have VID/PID. Do you think I will get the error 13?

 

Thanks for your help

Link to post
Share on other sites
I am the test server which is long launched didn't hold, and last night decided to leave and here that it showed me through approximately half of days of operation 6.1.

At first booted, but began to show errors different and it:

2559383

And then showed it:

2559380

Total:

GA-N3150N-D3V - 6.1 was got and how many and that works hours.

ASRock E3C226D2I - 6.1 - isn't got absolutely (network interface cards, and it is possible and controllers aren't loaded).

 

As I said in my previous post, please post anything related to 6.1 and jun v1.02a loader on the main thread.

Link to post
Share on other sites

Help. I have a HP Gen8 Microserver that has been running 5.2 for a while now. I though 6.x was stable enough to finally bite the bullet and upgrade. The machine is fully loaded, with two pairs of two hard drives, configured as two pairs of Synology RAID units.

 

I followed all the steps outlined in the first post to install 1.01 (Or so I thought). All seemed to go ok, and it allowed me to migrate my settings. However, on final reboot it came back as 'recoverable' in Synology Assistant, with a dynamic IP address. SA shows it as being on Version 6.0.2-8451 currently.

 

Selecting 'recover' just causes a reboot and no change, as people have mentioned on other threads. Can anybody suggest a way that I can either:

 

- Get 6.x to work from my current situation, maintaining my settings and data

- Downgrade back to 5.2 (I have the original boot USB stick untouched)

- Get 6.x to work as a clean install but not losing any data? I will happily reinstall my apps if I need to, but would rather not lose data if at all possible.

 

Any other options? I assume I can't just switch back to my original boot USB and reinstall..... maybe? Haven't tried that as didn't want to risk breaking it further.

 

Thanks in advance, any help is much appreciated.

 

Andy.

Link to post
Share on other sites

I was in 5.0, and i upgraded to 6.02 in november.

I had SHR volume (6x2TB) in ext4. If i should retry, i will create a new volume, with new system BTRFS. I don't know if it's very stable to keep the same volume for data after many upgrade...

Link to post
Share on other sites
andyf said:
Help. I have a HP Gen8 Microserver that has been running 5.2 for a while now. I though 6.x was stable enough to finally bite the bullet and upgrade. The machine is fully loaded, with two pairs of two hard drives, configured as two pairs of Synology RAID units.

 

I followed all the steps outlined in the first post to install 1.01 (Or so I thought). All seemed to go ok, and it allowed me to migrate my settings. However, on final reboot it came back as 'recoverable' in Synology Assistant, with a dynamic IP address. SA shows it as being on Version 6.0.2-8451 currently.

 

Selecting 'recover' just causes a reboot and no change, as people have mentioned on other threads. Can anybody suggest a way that I can either:

 

- Get 6.x to work from my current situation, maintaining my settings and data

- Downgrade back to 5.2 (I have the original boot USB stick untouched)

- Get 6.x to work as a clean install but not losing any data? I will happily reinstall my apps if I need to, but would rather not lose data if at all possible.

 

Any other options? I assume I can't just switch back to my original boot USB and reinstall..... maybe? Haven't tried that as didn't want to risk breaking it further.

 

Thanks in advance, any help is much appreciated.

 

Andy.

 

Data is normally untouched since it is always on a different partition. Since DSM installed without any problem it seems to me that the issue could come from the configuration of DSM and that means in order to change any configuration setting you would need to mount the partitions using a live CD of Ubuntu for example.

 

You can try a Force Install or Reinstall before anything else. Then you can try to wipe the DSM partition and do a fresh install so that you start brand new. That seems a bit hardcore as a first advise but considering the little information I know about your configuration and hardware that would probably be the most effective solution. Yes you would need to re-install all apps and re-configure DSM.

 

If you don't feel shy about linux and command lines here is how to access the partitions through a Live Ubuntu CD: https://xpenology.com/forum/topic/7507-tutorial-installmigrate-dsm-52-to-602-juns-loader/?do=findComment&comment=60202 - These 5 command lines will at least give you access to the content of the System and Data partitions in case you want to make a backup. You can ignore the comments I made about 'VERSION file' in that link. Just stick to the process on how to access the partitions.

 

What is your hardware? Network controller? Motherboard? The more info you give the more the community can help.

Link to post
Share on other sites

 

What is your hardware? Network controller? Motherboard? The more info you give the more the community can help.

 

Thanks. I thought I had mentioned but I must have forgotten in my panic... HI, It's a completely standard HP Gen8 G1610T Celeron Microserver, all standard hardware.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.