Jump to content
XPEnology Community

RedPill - the new loader for 6.2.4 - Discussion


Recommended Posts

2 hours ago, pigr8 said:

edit: @haydibe mm is there a problem with 0.11?

You might address this question to the whole community - as everyone uses it 

 

@everyone: is there a problem with 0.11 and the default provided build configurations?

 

Please share the build config you used to get that error - as something must be missing or wrong configured in it.

Also: have you tested the behavior of a freshly extracted 0.11 without any modifications? 

 

 

 

Edited by haydibe
Link to comment
Share on other sites

30 minutes ago, haydibe said:

You might address this question to the whole community - as everyone uses it 

 

@everyone: is there a problem with 0.11 and the default provided build configurations?

 

Please share the build config you used to get that error - as something must be missing or wrong configured in it.

Also: have you tested the behavior of a freshly extracted 0.11 without any modifications? 

 

 

 

[#] Extension orpheegt.virtio index is already up to date
[#] Updating orpheegt.virtio extension... [OK]
[#] Checking runtime for required tools... [OK]
[#] Updating ds918p_42218 platforms extensions... 
[-] The extension orpheegt.virtio was found. However, the extension index has no recipe for ds918p_42218 platform. It may not be
[-] supported on that platform, or author didn't updated it for that platform yet. You can try running
[-] "ext-manager.sh update" to refresh indexes for all extensions manually. Below are the currently known information about
[-] the extension stored locally:
[#] ========================================== orpheegt.virtio ==========================================
[#] Extension name: VirtIO
[#] Description: Adds VirtIO support for fast network/PCI/SCSI/network/console paravirtualization under QEmu (Proxmox, VirtualBox, virsh, and similar)
[#] To get help visit: <todo>
[#] Extension preparer/packer: https://github.com/OrpheeGT/redpill-virtio
[#] Software author: https://www.linux-kvm.org/page/Virtio
[#] Update URL: https://raw.githubusercontent.com/OrpheeGT/redpill-virtio/master/rpext-index.json
[#] Platforms supported: ds918p_41890 ds3615xs_42218 ds3615xs_25556 ds3615xs_41222 ds918p_25556 
[#] =======================================================================================


[-] Failed to update recipe for orpheegt.virtio extension for platform ds918p_42218. The script will terminate as you do not
[-] have previously downloaded recipe which can be used if download fails. Try again later. If problem
[-] persists contact the extension packer for support (displayed below)
[#] ========================================== orpheegt.virtio ==========================================
[#] Extension name: VirtIO
[#] Description: Adds VirtIO support for fast network/PCI/SCSI/network/console paravirtualization under QEmu (Proxmox, VirtualBox, virsh, and similar)
[#] To get help visit: <todo>
[#] Extension preparer/packer: https://github.com/OrpheeGT/redpill-virtio
[#] Software author: https://www.linux-kvm.org/page/Virtio
[#] Update URL: https://raw.githubusercontent.com/OrpheeGT/redpill-virtio/master/rpext-index.json
[#] Platforms supported: ds918p_41890 ds3615xs_42218 ds3615xs_25556 ds3615xs_41222 ds918p_25556 
[#] =======================================================================================

[!] Cannot continue due to previous errors (see above)

*** Process will exit ***
[!] Failed to update all extensions for ds918p_42218 platform - see errors above

*** Process will exit ***
make: *** [Makefile:33: build_redpill_load] Error 1
Error: Process completed with exit code 2.

 

when i build ds918p 42218 image

the virtIO driver does not support ds918p 42218,41890 is ok.

Edited by imdgg
Link to comment
Share on other sites

@imdgg: you manged to ignore two important things of my post:

 

1. the error is not related to the tool chain builder at all

2. the error is caused by a configuration that is NOT provided by  default

 

You  can see a difference of the type of error pigr8 posted and the one you posted, don't you?

 

 

 

 

Edited by haydibe
Link to comment
Share on other sites

1 hour ago, cqranjiian said:

annot change built-in SATA to eSATA by modifying synoinfo.conf! 918+ 7.0.1

As I understand it you shouldn't be modifying synoinfo.conf as it gets overwritten when you upgrade.

 

Read the documentation and you'll see that any changes you want to be make to synoinfo.conf should be put into the synoinfo stanza in <platform_user_config.json before you build your image. This way your changes are also kept outside of the target system and are easier to reuse in the future.

Link to comment
Share on other sites

9 minutes ago, WiteWulf said:

 

 42218 is not a supported version at present, don't expect extension repos to have everything necessary for it to build


 

I would second this.  It’s relatively easy to get a 918 build working if you understand json and can read compiler errors.  That being said if you can’t, just stop trying and be patient. @Orphée - your 918 repo needed the model changed to 918p and to be pointed at the virtIO build for 4.4.180plus if you care.  

  • Like 2
Link to comment
Share on other sites

HI

is it necessary to change things when building a image to use Virtio Drivers?

 

as i understand the virtio drivers are allready bundled with redpill-load.

 

i build a 918 image and was able to use Virtio-Network without issues, and Virtio-SCSI - but limited to 1 Disk.

 

br

Chris

Link to comment
Share on other sites

5 hours ago, jumkey said:

@jumkey Would It be better to not have anything on the bundled extensions and instead add extensions on demand ? for instance, In my case where i need to build baremetal and vmware loaders, i dont need virtio

Edited by pocopico
Link to comment
Share on other sites

8 hours ago, haydibe said:

You might address this question to the whole community - as everyone uses it 

 

@everyone: is there a problem with 0.11 and the default provided build configurations?

 

Please share the build config you used to get that error - as something must be missing or wrong configured in it.

Also: have you tested the behavior of a freshly extracted 0.11 without any modifications? 

 

 

 

 

it's the same config as usual, stock debian vm fresh install snapshot, docker, fresh extracted redpill-tool-chain_x86_64_v0.11, in the bromolow_user_config just added sn and mac, then launched build gives that error, meh.. does not apply on the 7.0 build, those work fine.

 

2 hours ago, WiteWulf said:

 

I just built bromolow-6.2.4-25556 with a freshly unzip'd redpill-tool-chain_x86_64_v0.11 and had no errors

 

PEBKAC :D

 

teach me master! :D

 

Link to comment
Share on other sites

1 hour ago, pigr8 said:

 

it's the same config as usual, stock debian vm fresh install snapshot, docker, fresh extracted redpill-tool-chain_x86_64_v0.11, in the bromolow_user_config just added sn and mac, then launched build gives that error, meh.. does not apply on the 7.0 build, those work fine.

 

 

teach me master! :D

 

I had an error with v0.11 when the folder (where I extracted the tool-chain files to) had a "blank" in the name (like: v011 42218). Without blank it worked ok (v011_42218). But I think that is an other error. 

Edited by paro44
Link to comment
Share on other sites

33 minutes ago, paro44 said:

I had an error with v0.11 when the folder (where I extracted the tool-chain files to) had a "blank" in the name (like: v011 42218). Without blank it worked ok (v011_42218). But I think that is an other error. 

Indeed, variabels that require paths needed double quoting. When I saw an unquoted variable, I wrapped it in quotes ... but I am not sure if I cought all of them.

Indeed it is another error.

 

pigr8: do you mind beeing more precise and less ambigous? 

Link to comment
Share on other sites

I just did a test with DS918-7.0.1-42218 using the virtio drivers and couldn't get the transfer speed above a gigabit per second, so 100MB/s (I have a 2.5gb LAN).

 

When I recompiled the loader with the vmxnet3 drivers and changed the nics in Proxmox to vmxnet3, transfers went up to 250MB/s

 

It seems, despite virtio being speed-independent, DSM does cap it at 1000mb/s max.

 

Maybe a tip for those out there using >gigabit nics.

Link to comment
Share on other sites

Seems not to be a problem with virtio drivers on DS918 + DSM7.0-41890 

 

VM on same host:

Quote

haydibe@dsm:~$ iperf3 -c 192.168.100.121
Connecting to host 192.168.100.121, port 5201
[  5] local 192.168.100.118 port 59336 connected to 192.168.100.121 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  2.75 GBytes  23.6 Gbits/sec    0   3.08 MBytes
[  5]   1.00-2.00   sec  2.43 GBytes  20.8 Gbits/sec    0   3.08 MBytes
[  5]   2.00-3.00   sec  2.47 GBytes  21.2 Gbits/sec    0   3.08 MBytes
[  5]   3.00-4.00   sec  2.39 GBytes  20.5 Gbits/sec    0   3.08 MBytes
[  5]   4.00-5.00   sec  2.39 GBytes  20.5 Gbits/sec    0   3.08 MBytes
[  5]   5.00-6.00   sec  2.58 GBytes  22.2 Gbits/sec    0   3.08 MBytes
[  5]   6.00-7.00   sec  2.54 GBytes  21.8 Gbits/sec    0   3.08 MBytes
[  5]   7.00-8.00   sec  2.48 GBytes  21.3 Gbits/sec    0   3.08 MBytes
[  5]   8.00-9.00   sec  2.51 GBytes  21.5 Gbits/sec    0   3.08 MBytes
[  5]   9.00-10.00  sec  2.47 GBytes  21.3 Gbits/sec    0   3.08 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  25.0 GBytes  21.5 Gbits/sec    0             sender
[  5]   0.00-10.00  sec  25.0 GBytes  21.5 Gbits/sec                  receiver
 

 

Other host:

Quote

haydibe@dsm:~$ iperf3 -c 192.168.100.122
Connecting to host 192.168.100.122, port 5201
[  5] local 192.168.100.118 port 42262 connected to 192.168.100.122 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  1.04 GBytes  8.97 Gbits/sec  13296    710 KBytes
[  5]   1.00-2.00   sec  1.08 GBytes  9.30 Gbits/sec  1705    810 KBytes
[  5]   2.00-3.00   sec  1.09 GBytes  9.32 Gbits/sec  5034    799 KBytes
[  5]   3.00-4.00   sec  1.08 GBytes  9.27 Gbits/sec  4011    846 KBytes
[  5]   4.00-5.00   sec  1.08 GBytes  9.31 Gbits/sec  5355    881 KBytes
[  5]   5.00-6.00   sec  1.07 GBytes  9.21 Gbits/sec  3957    748 KBytes
[  5]   6.00-7.00   sec  1.07 GBytes  9.21 Gbits/sec  7508    875 KBytes
[  5]   7.00-8.00   sec  1.08 GBytes  9.31 Gbits/sec  5897    850 KBytes
[  5]   8.00-9.00   sec  1.08 GBytes  9.29 Gbits/sec  3255    822 KBytes
[  5]   9.00-10.00  sec  1.09 GBytes  9.33 Gbits/sec  2086    757 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  10.8 GBytes  9.25 Gbits/sec  52104             sender
[  5]   0.00-10.00  sec  10.8 GBytes  9.25 Gbits/sec                  receiver

 

Link to comment
Share on other sites

 

4 hours ago, XAXISNL said:

I just did a test with DS918-7.0.1-42218 using the virtio drivers and couldn't get the transfer speed above a gigabit per second, so 100MB/s (I have a 2.5gb LAN).

 

When I recompiled the loader with the vmxnet3 drivers and changed the nics in Proxmox to vmxnet3, transfers went up to 250MB/s

 

It seems, despite virtio being speed-independent, DSM does cap it at 1000mb/s max.

 

Maybe a tip for those out there using >gigabit nics.

It seems ok for my 2.5gbe LAN,also use DS918-7.01-42218 with virtio in proxmox 7.0

 

image.thumb.png.ef64ddeb90d565e3090f5af6a7ac73b4.png

Link to comment
Share on other sites

10 hours ago, pocopico said:

@jumkey Would It be better to not have anything on the bundled extensions and instead add extensions on demand ? for instance, In my case where i need to build baremetal and vmware loaders, i dont need virtio

I don't quite understand what you mean, I just included the redpill-virtio/rpext-index.json file for easy management.

Link to comment
Share on other sites

On 10/8/2021 at 9:58 PM, paro44 said:

I can wake-up my Intel SS4200 with "wol.exe". I also tried with Synology Assistant, but that only worked once. After that first try I couldn't login to the DSM, there was only a message saying no nas was found. I never used the Assistant wol before, maybe I made something wrong. With "wol.exe" I had no problem so far.

I'm not sure how the Gen8 will will behave, but generally wol works if you use third party tool. If you want to use the Assistant, maybe further work/testing is needed.

 

i haver also tried now with wol.exe, it is also working for me.

One thing does not work, in hardware and energy settings, i have setup that the hdd should go into sleep mode after 30 min and the syno should shutdown after 1h of the sleeping mode. but the hp gen8 stays on all the time.

 

i have installed 7.0.1 on a second gen 8 (test hardware), that should start every sunday for a backup (hyper backup client) from my main syno (also gen8), and after that it should turn off to save energy. 

Link to comment
Share on other sites

9 hours ago, AlexFullmoon said:

A minor question.

 

Seeing as there are some working (?) drivers for broadcom NIC for microserver — has anyone packaged them for redpill yet?

 

(I assume they should work for gen7 too)


Here you are :


https://github.com/pocopico/rp-ext/raw/main/tg3/rpext-index.json

Edited by pocopico
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...