tcs

New Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tcs

  • Rank
    Newbie
  1. I may have found a fix. In order for that to happen I'd need Jun to build us a custom bootloader. If he's not willing to build us a one-off, I can probably do it myself but it'll be a while before I have time to build out that environment myself. There's a possibility the change I want to make isn't possible without the full source, but I'm not sure at this point.
  2. Well gentlemen, I'm going to say after much gnashing of teeth I've found a solution. The source of the issue seems to be something in /etc/rc.subr but I can't quite pin it down. HOWEVER, what I *DID* find is that you can disable swap entirely, which is where the actual problem lies. Normally when you have external shelves, the system identifies drives in them with unique IDs per shelf. So the system is never expecting a drive with more than 3 letters in the device ID (IE: it expects an sda2, but not an sdaa2). First I tried getting it to identify my external trays, but I quickly realized that they are expecting certain SES (SCSI enclosure services) responses that we can't really mimic. Maybe if you purchased a shelf from the same vendor they buy theirs through, but that's kind of a lost cause. HOWEVER... drumroll (sorry for the long-winded response) - I did find that you can disable swap entirely. Simply add no_disk_swap="yes" to your synoinfo.conf. Once that's done, you should be good to go. TL;dr - add no_disk_swap="yes" to your synoinfo.conf ??? profit