DSM 6.2 Loader


Recommended Posts

15 minutes ago, dk2000 said:

I have Dell Power Edge R320

What is the best and latest Loader should i use ?

Please help me

thanks

 

On ‎1‎/‎25‎/‎2020 at 10:27 AM, IG-88 said:
On ‎1‎/‎25‎/‎2020 at 10:20 AM, carmeb said:

I would like to know how can I update to 6.2 and which bootloader I have to use.

 

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

Please read at least a few of the posts in the thread!

Link to post
Share on other sites

Hi Everyone,

 

I run two instances of DSM , one as a VM in Proxmox (DS3617xs)  , another as BareMetal on Proliant N54L (DS3615xs), both are running DSM 6.2-23739 Update 2.

 

I need to upgrade to newer version as Let's Encrypt is not supported anymore.

 

Is anyone can confirm ability to upgrade any of those two systems ? and if yes , is NIC was still OK or something for that was necessary ?

 

Thanks !

 

XT

Edited by extenue
add model
Link to post
Share on other sites
18 hours ago, extenue said:

Hi Everyone,

 

I run two instances of DSM , one as a VM in Proxmox (DS3617xs)  , another as BareMetal on Proliant N54L (DS3615xs), both are running DSM 6.2-23739 Update 2.

 

I need to upgrade to newer version as Let's Encrypt is not supported anymore.

 

Is anyone can confirm ability to upgrade any of those two systems ? and if yes , is NIC was still OK or something for that was necessary ?

 

Thanks !

 

XT

 

Hello extenue,

I've currently two Proliant, one N54L and one N40L. The N40L is running the 6.2.2-24922 Update 4, and the N54L is still running 6.1.7, but will be upgraded very soon.

To run the 6.2 version you need to add a new network card as the internal NIC is no longer supported.

I've added a HP NC360T card.

176114139_2020-02-1116_00_58-SynologyDiskStation.thumb.png.2ac70b4e2a625ca2947fa68fb7009518.png

Regards,

TomX

 

Link to post
Share on other sites

"To run the 6.2 version you need to add a new network card as the internal NIC is no longer supported'

 

My N54L is already running 6.2 , did you meant "To run the 6.2.2 version you need to add a new network card as the internal NIC is no longer supported" ?

 

Thanks

 

XT

Link to post
Share on other sites
il y a 59 minutes, extenue a dit :

"To run the 6.2 version you need to add a new network card as the internal NIC is no longer supported'

 

My N54L is already running 6.2 , did you meant "To run the 6.2.2 version you need to add a new network card as the internal NIC is no longer supported" ?

 

Thanks

 

XT

no need to add an additional LAN card with Driver extension jun ...
my N40L works perfectly

Link to post
Share on other sites
5 hours ago, lolvince said:

no need to add an additional LAN card with Driver extension jun ...
my N40L works perfectly

 

Hello lolvince,

I'm using the DS3615XS with the 1.03b loader.

Which loader are you using?

Thank you

Regards,

TomX

 

Link to post
Share on other sites
il y a 4 minutes, wstse a dit :

 

May I know finally you are following the way in Case 1 or Case 2?

 



 

sorry i don't understand your question.
I have an N40L which works in DSM 6.2.2-24922 Update 4 with the native network only, with the loader 1.03B and the drivers V0.5 for ds3615

Link to post
Share on other sites
9 minutes ago, lolvince said:

sorry i don't understand your question.
I have an N40L which works in DSM 6.2.2-24922 Update 4 with the native network only, with the loader 1.03B and the drivers V0.5 for ds3615

 

from here : https://xpenology.com/forum/topic/21663-driver-extension-jun-103b104b-for-dsm622-for-3615xs-3617xs-918/

 

Case 1: update from 6.2.0 to 6.2.2

Case 2: fresh install with 6.2.2 or "migration" (aka upgrade) from 6.0/6.1

Did you first try Case 1 but got unstable and then you do Case 2 with fresh install with backup? Or you do Case 2 with migration so you just put back config backup?

Link to post
Share on other sites
il y a 2 minutes, wstse a dit :

 

from here : https://xpenology.com/forum/topic/21663-driver-extension-jun-103b104b-for-dsm622-for-3615xs-3617xs-918/

 

Case 1: update from 6.2.0 to 6.2.2

Case 2: fresh install with 6.2.2 or "migration" (aka upgrade) from 6.0/6.1

Did you first try Case 1 but got unstable and then you do Case 2 with fresh install with backup? Or you do Case 2 with migration so you just put back config backup?

I was in 6.1.7, I should have done the migration in case N ° 2.

Link to post
Share on other sites

Thanks. 

 

Just try using Case 1. I didn't take out the USB boot. Instead I

 

1. mount the synoboot2 to a tmp directory 

2. copy the zImage, rd.gz, extra.lzma to synoboot2

3. umount the synoboot2

3. login to the DSM, click DSM update to DSM 6.2.2-24922

4. It will restart twice

5. All ok except the esataportcfg/internalportcfg/usbportcfg in synoinfo.cfg need to modify back to N54L setting. (I use both disk5 & disk6 as esata so I set 
esataportcfg="0x30"
usbportcfg="0x1fc0"
internalportcfg="0xf"

then reboot one more time my disk6 come back as esata disk

 

 

Link to post
Share on other sites

Hello,

 

I would like to load 1.03b (DS3617 ou DS3615) and DSM 6.2.2-24922-4 

 

Could you tell me if my current configuration will work : Case SilverStone CS380 / Asrock Q2900M / 8 Go RAM / SYBA SI-PEX40064 / PCI USB 3.0 PEXUSB3S24 / 2x Intel EXPI9301CTBLK / 4 X 2 To / Jun's v1.02b loader / DSM 6.1.7-1584 Update 3 - DS3617xs

 

Do I have to do an update or a new installation ?

 

Thanks

Edited by jojeju9428
Link to post
Share on other sites
  • 3 weeks later...

I made a loader USB stick with 1.03b@3615 ,but my machine always stopped at self test when power on, could you help me? It can't pass the memory test  T.T  But a loader with DSM6.1.3 is working well.

MAchine Info:

CPU:Intel Q9550s

MB:Gigabyte X38-DQ6

4GB DDR2

 

I found the reason is  I enabled legacy support of USB Mass Storage in the Bios.But when I disable it ,system can't find boot device. How should I do?

 

微信图片_20200311114851.jpg

Edited by Mapleaj
Link to post
Share on other sites
On 2/12/2020 at 9:01 PM, wstse said:

Thanks. 

 

Just try using Case 1. I didn't take out the USB boot. Instead I

 

1. mount the synoboot2 to a tmp directory 

2. copy the zImage, rd.gz, extra.lzma to synoboot2

3. umount the synoboot2

3. login to the DSM, click DSM update to DSM 6.2.2-24922

4. It will restart twice

5. All ok except the esataportcfg/internalportcfg/usbportcfg in synoinfo.cfg need to modify back to N54L setting. (I use both disk5 & disk6 as esata so I set 
esataportcfg="0x30"
usbportcfg="0x1fc0"
internalportcfg="0xf"

then reboot one more time my disk6 come back as esata disk

 

 

Hello,

 

I use only the 6th slot with inernal sata from the original CD Drive and didn't have to modifie any config in Grub before (only vid, pid and disable trim w/e for 8 GB RAM to show)

However when i created my usb drive, the synology assistant finds the diskstation (so it seems I'm ok on network card side with the extra drivers) but when i log it says that the configuration was lost and it needs to reinstall the DSM.

I was on 6.1 before. I stopped there and put back my old usb key with 6.1 before i make a mistake. Can anyone confirm me if this is expected ? As i modified the Jun loader 2nd partition to include the 6.2.2 rd.gz and zimage. Also once the installation is done, are all my configs back or do i need to load a backup from config ? The IP was manually set to x.x.x.13 before but when i started the process it was on automatic and set to x.x.x.18.. So I need to know if once i click reinstall , everything will go back to normal following reboot.

Link to post
Share on other sites
On 2/12/2020 at 9:01 PM, wstse said:

Thanks. 

 

Just try using Case 1. I didn't take out the USB boot. Instead I

 

1. mount the synoboot2 to a tmp directory 

2. copy the zImage, rd.gz, extra.lzma to synoboot2

3. umount the synoboot2

3. login to the DSM, click DSM update to DSM 6.2.2-24922

4. It will restart twice

5. All ok except the esataportcfg/internalportcfg/usbportcfg in synoinfo.cfg need to modify back to N54L setting. (I use both disk5 & disk6 as esata so I set 
esataportcfg="0x30"
usbportcfg="0x1fc0"
internalportcfg="0xf"

then reboot one more time my disk6 come back as esata disk

 

 

Hello,

 

I use only the 6th slot with inernal sata from the original CD Drive and didn't have to modifie any config in Grub before (only vid, pid and disable trim w/e for 8 GB RAM to show)

However when i created my usb drive, the synology assistant finds the diskstation (so it seems I'm ok on network card side with the extra drivers) but when i log it says that the configuration was lost and it needs to reinstall the DSM.

I was on 6.1 before. I stopped there and put back my old usb key with 6.1 before i make a mistake. Can anyone confirm me if this is expected ? As i modified the Jun loader 2nd partition to include the 6.2.2 rd.gz and zimage. Also once the installation is done, are all my configs back or do i need to load a backup from config ? The IP was manually set to x.x.x.13 before but when i started the process it was on automatic and set to x.x.x.18.. So I need to know if once i click reinstall , everything will go back to normal following reboot.

 

 

Edit : OK, tried it, and revert back to 6.1...

I tried removing disable mtrr trim since it detected the 8 GB correctly without it as well, but even with that modification, the dsm keeps crashing. It installs fine. I can access through web interface for some minutes but then it crashes... Web UI is down, SMB is down, SSH is up tho i get disconnected every minutes or so... Anyone had similar symptoms with HP N54L ?

I used Jun's Loader 1.03b + extra drive for 3615xs + extracted 6.2.2 zimage and rd.gz and injected it all in the loader 2nd partition...

I still have an old 99PowerSaving Shell script somewhere from dsm 5.2, dunno if it can explains the behavior ? Any way to check logs to know what happens or anyone can help me out ?

Link to post
Share on other sites
  • 2 weeks later...

I'm currently running 6.0.2-8451 Update 11 Baremetal on HP microserver Gen 8.
Is it possible for me upgrading to 6.2? And should I use loader 1.03b or 1.04b?
Will an upgrade mess something up with my current setting on Surveillance Station 8.0.3 with additional licences (not legit).

Thank you in advance.

Link to post
Share on other sites

Hello everyone,

 

I am currently running DSM 6.2-23739 Update 2 with Jun's V1.03b DS3615xs loader on the old server HP Proliant ML110 G4. It has been working great, the only issue is that I can't shutdown. When shutdown, the PC instead go and reboot.

Could you advise how to fix it? In BIOS menu there is no option to turn off WOL. Thanks!

Link to post
Share on other sites

Hello guys,
I just updated my synology setup to  6.2.2-24922  v1.03b - DS3615xs
I boot using: "DS3615xs 6.2 Baremetal with Jun's Mod v1.03b"
But I see this line  (see serial.out )
   patching file etc/synoinfo.conf
   Hunk #1 FAILED at 291.
   1 out of 1 hunk FAILED -- saving rejects to file etc/synoinfo.conf.rej


Is there a way to fix this ?
Why do I see it ?
I am attaching: 
   /etc/synoinfo.conf
   /etc.defaults/synoinfo.conf
   jun.patch (that everyone has it)

Thanks

 

My Setup Info:
  - DSM version prior update: DSM 6.1.7-15284 update 3  
  -  DSM after update 6.2.2-24922
  - Loader version and model: JUN'S LOADER v1.03b - DS3615xs  
  - Using custom extra.lzma: NO
  - Installation type: ESXi 6.5 (HP MicroServer Gen8 with Xeon CPU E31260L 1265v2)  (4 virtual SATA HardDrives: 50Mb 50Gb 1.7Tb 2.7Tb)
  - Additional comments: It failed in the beginning , as all services, including networking, would shutdown a few seconds after logging in to DSM  (SYNO.Core.Desktop.Initdata_1_get would call "usr/syno/bin/synopkg onoffall stop").  Saw other posts mentioning an old .xpenoboot folder in / as the cause, so I deleted (cd \;sudo rm -r .xpenoboot) that and upgrade worked fine.

 

 

jun.patch serial.out synoinfo.conf.etc synoinfo.conf.etc.defaults

Link to post
Share on other sites
On 8/1/2018 at 5:30 PM, Dfds said:

@jun A fresh baremetal install on a HP Microserver Gen7 N54L seems to be working ok. Many thanks for your hard work

 

Hi, what's your current dsm version and which loader did you used? I want to upgrade my 6.0.2 to a newer version but last time when I checked, the loader didn't had any grub entry for AMD.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.