HP N54L - DSM 6.1 onwards


Recommended Posts

On 05/07/2017 at 0:40 AM, Toetje583 said:

Guys with memory problems add this to the grub.cfg

disable_mtrr_trim

Example: 
 


set common_args_3617='disable_mtrr_trim syno_hdd_powerup_seq=0 HddHotplug=0 syno_hw_version=DS3617xs vender_format_version=2 console=ttyS0,115200n8 withefi elevator=elevator quiet syno_port_thaw=1'

Now I got:

                   total        used        free
Mem:          16034         260       15458           3         315       15560
Swap:         11665           0       11665


/proc/mtrr is editable even from a command shell: you can disable register records and/or write new values there this seems to be a Bios bug.
Adding disable_mtrr_trim disables it without losing any performance as far as I know.

Thanks,

 

This worked vbox see all the memory now :smile:

 

 

Link to post
Share on other sites
Hello,
 
I have an HP n54L installed DSM 6.0.1 Jun Loader, wondering if possible to upgrade to anything later than this?
 
Also how do I inject drivers into the system? Say I add 10 GbE or mellanox Infiniband connect x card etc...
 
Thank you all,
 

Technically this is not upgrade. If u are using 6.0.1. As far as I know, it only supports fresh install. Files will not missing but you need re-configure everything again.


Sent from my iPhone using Tapatalk
Link to post
Share on other sites

Sorry for late reply.

 

I was able to upgrade, (no losing of data) however I did not have lot of syno settings (custom config) so dont know much about those.

 

Trick I had to use, it kept failing - I had the correct VID / PID.Removed the 4 hard drive trays, booted up did force install.Then find synology com then, it comes to install (no hard drive found message).

 

I then pushed all 4 drives back and they spun up, and installation was a breeze.

 

Oh and ofcourse I had to disable the C1E whatever in the BIOS.

 

Very soon will try 8TB reds in the N54L :grin::grin: 

Link to post
Share on other sites
On 10/07/2017 at 10:42 AM, ygor said:

I Just used it to install text edit.

 

Mounting ext4fs USB drives is a problem. And vbox give an error of config.php.

vbox is working with the loader and 6.1-15047

 

ext4fs drives are not recognized, seems the driver is too old to read recent formated hdd.

 

exemple hdd formated with ubuntu 17.10 ext4, are not mountable with this loader / kernel .

 

Link to post
Share on other sites

BTW i just wanted to add i have 16GB memory, and apart from disabling C1E and removing the HDD during the boot , later re-inserted.

 

no extra steps needed to modify so that it would recognize the extra RAM.

 

Link to post
Share on other sites
10 hours ago, Half-Ogre said:

HP N40L upgrade from 6.0.2 to 6.1.2 with loader went smooth.Disabled C1E in bios and upgraded with reinstall (data partition is safe) from online mode.Thanks a lot.

 

I should do that, i should can keep push notification enable

Edited by ordimans
Link to post
Share on other sites
18 minutes ago, ordimans said:

At guys who use this loader on N40L or N54L, what network speed you have for NIC integrated ??

 

I have 100Mbps....
 

 

Replace cable for 5E-6 category. Interesting, but it worked with the old cable on Debian, refused to work on xpeno :smile: Check ports, replace cable.

Link to post
Share on other sites
On 13/7/2017 at 5:14 PM, pehun said:

Hello All, 

 

Thanks a lot for the loader.

Does a version which permit update mode is in progress?

 

Bruno

 

Hi Bruno, 

Sure it is.

For now, I'm using a trick to update without loosing anything. 6.1.3-15152 at the moment. Working flawlessly.

Just created a script to copy modules from /lib/modules/update to /lib/modules and reboot. It only acts when needed.

I attached the script.

I'm a linux newbie. Somebody would improve it, but it is working here.

Instructions:

 

Put it anywhere.

Set X permission to be executable (0744).

Go to scheduled tasks and program it on reboot. Root user.

Go to DSM and update from web UI normally.

 

I set a long time to reboot (720s) for safety reasons. In case of loop, I think is enough to disable the task. So, be patient.

As it only should work when needed, you can leave this task enabled.

I'm not an expert. Please, don't blame me if something fails. :smile:

update_patch.sh

Link to post
Share on other sites

Thank you, Everyone!

N40L with 1.02b (from the topic) worked great.

 

Encrypted folder speed is 50mb/s, looks like this encryption algo sucks a lot, what can we do? Plain 2xhdd raid0 gives 200mb/s

How to make it write at 100mb/s the encrypted folder?

 

How to mount fresh ext4 drive?

[ 4363.767818] JBD2: Unrecognised features on journal
[ 4363.767828] EXT4-fs (sda1): error loading journal
[ 6346.064135] EXT3-fs (sda1): error: couldn't mount because of unsupported optional features (2c0)

 

What is the right way to upgrade from 1.01?

Link to post
Share on other sites
6 hours ago, pehun said:

Thanks a lot Eduardo, 

 

So you just copy the datas, and the update propose the update function?

 

Bruno

Sorry. I just can't understand what you mean.

I attached a file (script). You just should copy it somewhere (share) in the NAS and give this file X permission.

After that, go to DSM UI Panel Control and program a scheduled task that will be execution of this script. On boot, root user parameters.

Now you are ready to update. Go to DSM UI Control Panel and Update normally.

 

One test you could do before updating is running the script without updating, just to assure it will work.

As I told you, after updating and reboot, script action will add a new long reboot. Don't worry.

  • Like 1
Link to post
Share on other sites
Guest
This topic is now closed to further replies.