Trial of Nanoboot (4493) - 5.0.3.1


Recommended Posts

Hi,

 

Hello

 

Is there a way to make with nanoboot a synology 1813 instead of the 3614 ?

 

 

Thanks

 

You would need to recompile nanoboot and figure out yourself as there is no support..

 

http://nanoboot.tk/source

 

Hey guys,

 

i just upgrade from Trantor his DSM 5.0 beta to Nano-boot 5.0.3.1/ 4493 update 2 without major issues. Only one bugging point and that is that my Gigabit Network Realtek 8111f is only seen als 100 Mpbs instead of 1000 Mbps.

 

Anyone having this same issue and found a solution for this issue ?

 

Greetz.

 

have you checked if the right kernelmodule is loaded?

You can ssh your box and check it with

lspci -v 

the loaded module should be r8168 i think..

 

 

Have a question,

 

It is possible to use USB TV stick on DSM that host on ESXi?

Since I am still thinking to build a XPEnology physically or virtually.

If answer is yes,

I will definitely go to VM!!!

 

This should answer your question.

 

http://pubs.vmware.com/vsphere-50/topic ... E800D.html

 

the only question is if nanoboot supports your stick.

 

 

 

Sent from my iPad using Tapatalk

Link to post
Share on other sites
Hi Thieson,

 

kernel driver R8169 is loaded. See include print screen

 

Can you try to add the following line to the boot option of your nanoboot sysconfig.cfg and report?

 

rmmod=r8169,r8169_new insmod=r8168

 

I think it could work as the r8169 module is for the 8169 and 8110..

 

Gesendet von iPad mit Tapatalk

Link to post
Share on other sites

Hi,

 

Would like to thank nanoboot for this fantastic project and all his effort into this.

Thanks

 

Just like to ask if the LSI 9211-8i will have problems with this version of Nanoboot (4493) - 5.0.3.1?

Link to post
Share on other sites

Hi All,

I finally managed to boot using xen, was quite straightforward in the end. Now I'm having trouble passing through more than 3 storage devices. using the hdx passthrough xen only supports 4 devices, but using the xvdx devices I should be able to use more - certainly the machine boots (it doesn't if I try going up to hde), but in DSM I only see 4 devices.

xen config :

 

bootloader='pygrub'

builder = 'hvm'

vcpus = '2'

memory = '1024'

disk = [ 'file:/media/isos/NanoBoot-5.0.3.1-fat.img,xvda,r' , 'phy:/dev/xenserver-vg/nas-lv,xvdb,w' , 'phy:/dev/sda,xvdc,w' , 'phy:/dev/sdb,xvdd,w' , 'phy:/dev/sdc,xvde,w' ]

name = 'vnas'

vif = [ 'mac=00:16:3E:51:20:4D,bridge=xenbr0,model=e1000' ]

#on_poweroff = 'shutdown'

#on_reboot = 'shutdown'

#on_crash = 'restart'

#on_xend_start = 'start'

#on_xend_stop = 'shutdown'

boot = 'dc'

acpi = '1'

acpi = '1'

apic = '1'

viridian = '1'

xen_platform_pci='1'

sdl = '0'

vnc = '1'

vnclisten = '0.0.0.0'

vncdisplay='1'

stdvga = '0'

usb = '0'

usbdevice = ['tablet' ]

device_model_version="qemu-xen-traditional"

gfx_passthru=0

 

 

I wonder if anyone has any experience of this? Is there anything in nanoboot that limits the number of devices?

Thanks,

Matt

Link to post
Share on other sites

xen is turning out to be a bit of a problem. Looks like hvm emulation only supports IDE emulation, and it seems that limits things to 4 devices. Not good. nanoboot knocks one off, I have an install logical volume carved off an ssd for DSM (and DSM apps etc), and then 2 out of the 3 disks. Starting to become a bit disappointed. I could use lvm or md to pool the drives and pass as one hdx ide drive, but that's rather defeating the point of using DSM to manage that.

 

Does anyone have any ideas?

:cry:

Link to post
Share on other sites

running Nanoboot (4493) - 5.0.3.1 and have problem expanding existing volume1. had five 4tb disks and putt the 5th disk in and it checked it butt did not expand the volume. now it says that I can expand the volume from 10,73gb to 14886gb but when I push the button it stops jus after a few seconds and it goes back to saying I can expand the volume again :sad:. have tried an test build with 2 disks and expanded it one disk at a time upp to 6 disks and it worked. it was just a bunch off small disks. butt now when I tried to bulild one with 4tb disks in the order off putting 2x4tb to start with and then expanding one disk at a time. worked great until then 5th disk. I have media on the disks and don't know what to do. have tried some off the instruktions like umounting the volume and resize it and stuff like that butt still says the same.

 

my rigg is

 

i7 960

GIGABYTE GA-X58A-UD3R V2.0 Motherboard Intel X58 Express LGA 1366 DDR3

5x4 tb segate nas hd

6gig corsair mem

650 corsair power

 

I get this when I type the command vgdisplay -v. is there something wrong?

 

TVIX> vgdisplay -v

Finding all volume groups

Finding volume group "vg1000"

--- Volume group ---

VG Name vg1000

System ID

Format lvm2

Metadata Areas 1

Metadata Sequence No 9

VG Access read/write

VG Status resizable

MAX LV 0

Cur LV 1

Open LV 1

Max PV 0

Cur PV 1

Act PV 1

VG Size 14.54 TB

PE Size 4.00 MB

Total PE 3810823

Alloc PE / Size 3810823 / 14.54 TB

Free PE / Size 0 / 0

VG UUID Md51rm-ke80-E104-cN2s-fuJT-Dbqo-WiOIN3

 

--- Logical volume ---

LV Name /dev/vg1000/lv

VG Name vg1000

LV UUID YiBJnA-k8yD-F2rq-Aj5t-rgwL-rkmz-UQG2SW

LV Write Access read/write

LV Status available

# open 1

LV Size 14.54 TB

Current LE 3810823

Segments 1

Allocation inherit

Read ahead sectors auto

- currently set to 4096

Block device 253:0

 

--- Physical volumes ---

PV Name /dev/md2

PV UUID H5YF1N-iNUc-CmJM-fjbZ-yKyp-Srz8-QdcwQJ

PV Status allocatable

Total PE / Free PE 3810823 / 0

Link to post
Share on other sites

Hi Werter,

Try doing a scrub of your volume, this will do a consistency check of your disks.

In DSM -

Storage Manager

Volume

Manage

This could take about a 24 hours or more

 

Once that is complete try expanding again

Cheers

Sinnuendo

Link to post
Share on other sites
Hi Werter,

Try doing a scrub of your volume, this will do a consistency check of your disks.

In DSM -

Storage Manager

Volume

Manage

This could take about a 24 hours or more

 

Once that is complete try expanding again

Cheers

Sinnuendo

 

I will try that and report back when it is done and I tried to expand.

Link to post
Share on other sites

did an scrub of my volume. and tried to expand again butt did not work :sad: it says faild to expand :sad:

 

unmounted the volume and did an fsck.ext4 /dev/md2

butt got the following message:

 

TVIX> fsck.ext4 /dev/md2

e2fsck 1.42.6 (21-Sep-2012)

fsck.ext4: Invalid argument while trying to open /dev/md2

 

The superblock could not be read or does not describe a correct ext2

filesystem. If the device is valid and it really contains an ext2

filesystem (and not swap or ufs or something else), then the superblock

is corrupt, and you might try running e2fsck with an alternate superblock:

e2fsck -b 8193

 

tried e2fsck -p /dev/vg1000/lv

and it started and finished and then I rebooted and tried to expand but did not work :sad:

 

tried another command to se if the system hass issues

TVIX> tail -f /var/log/messages

Jul 7 18:27:04 TVIX synocheckhotspare: synocheckhotspare.c:138 [iNFO] No hotspare config , skip hotspare config check. [0x2000 virtual_space_layer_get.c:98]

Jul 7 18:30:06 TVIX S99zbootok.sh: Error! synoservices start failed! (service [ssh-shell ] is not ready, please wait...)

Jul 7 18:30:09 TVIX ntpdate: Sync with time server 193.228.143.12 offset -0.001938 sec.

Jul 7 18:32:55 TVIX entry.cgi_SYNO.Core.Upgrade.Server[1].check[22835]: smallupdate.cpp: 413 small fix can't downgrade, org_version[2], new_version[2]

Jul 7 18:33:05 TVIX volumehandler.cgi: space_expand_unallocated.c:82 [info] Success Dump map file

Jul 7 18:33:10 TVIX kernel: [ 392.350262] EXT4-fs warning (device dm-0): ext4_resize_fs :1996: No reserved GDT blocks, can't resize

Jul 7 18:33:10 TVIX volumehandler.cgi: (fs_vol_expand.c)ExtFSExpand(88):Failed to '/sbin /resize2fs -fpF /dev/vg1000/lv > /dev/null 2>&1', WEXITSTATUS® = 1

Jul 7 18:33:10 TVIX volumehandler.cgi: volume_manage_with_temp_dev.c:279 Failed to expan d file system on /dev/vg1000/lv

Jul 7 18:33:10 TVIX volumehandler.cgi: volume_lib.cpp:952 Failed to expand file system o n /dev/vg1000/lv

Jul 7 18:33:10 TVIX volumehandler.cgi: volumehandler.cpp:1444 failed to expand unallocat ed file system: /volume1

file system on /dev/vg1000/lv

 

what dose it mean?

 

 

 

can I exchange the usb with another usb with a fresh 5,0,3,1 and try ?

or can I install a fresh install of the 5.0.3.1 and a fresh install of pat file?

Link to post
Share on other sites

Does nanoboot have drivers for the following ethernet drivers?

 

Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe

 

My Tadpole Pulsar Thin client is working without problems with gnoboot but no luck with nanoboot.

 

Thanks all for this amazing project

Link to post
Share on other sites
can I exchange the usb with another usb with a fresh 5,0,3,1 and try ?

or can I install a fresh install of the 5.0.3.1 and a fresh install of pat file?

 

I've done a few re-installs of the VM as using ESXi and not lost any data yet, appears to recognise the fact that the volumes are already synology disks, but YMMV.

Link to post
Share on other sites
can I exchange the usb with another usb with a fresh 5,0,3,1 and try ?

or can I install a fresh install of the 5.0.3.1 and a fresh install of pat file?

 

I've done a few re-installs of the VM as using ESXi and not lost any data yet, appears to recognise the fact that the volumes are already synology disks, but YMMV.

 

did an fresh install and the files were still there but still cant expand the volume with the last disk but it is initialized

I am going crazy. and I have no where to backup my data and start over with 5 drives in a new volume :sad: please help

 

found this guide but I don't want to lose the data. and Linux is not my strong suit. butt do you think it will work? link below of the guide

 

http://blog.azib.net/2013/12/how-i-upgr ... as-to.html

Edited by Guest
Link to post
Share on other sites

DSM 5 is fully working now, but i would like to hide the USB boot drive, i already used the search function, but couldn't find anything helpful.

So my question is it possible to hide the USB boot drive and how can i do this?

 

Thanks

Link to post
Share on other sites
DSM 5 is fully working now, but i would like to hide the USB boot drive, i already used the search function, but couldn't find anything helpful.

So my question is it possible to hide the USB boot drive and how can i do this?

 

Thanks

 

Yes, you can hide the boot drive: edit syslinux.cfg so your drive's vid and pid should be there

 

LABEL Synology DSM 5.0

MENU LABEL Synology DSM 5.0

kernel /zImage ihd_num=0 netif_num=4 syno_hw_version=DS3612xs mac1=00113208D63C mac2=00113208D63D sn=B3J4N01003 vid=0x0EA0 pid=0x2168 loglevel=0 vga=0x305

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.