jun

DSM 6.1.x Loader

Recommended Posts

5 hours ago, jitesh_88 said:

how did you copy the loader to ESXi server? i get IO error if i try to deploy the OVF template
did you have to do any modifications to the img ?

Jun's loader contains 4 files. I did the following steps:

1) modified ds3615.vmx ( virtualHW.version = "11" )
2) uploaded all 4 files to a new directory on the ESXi server
3) added ds3615.vmx to the list of Virtual Machines.
4) in the VM settings: deleted the network adapter and added a new one
5) in the VM settings: created and added 8GB virtual drive
6) started the vm an connected to it in the browser 
7) installed DSM 6.1.1 on DS3615xs
8) upgraded within DSM to 6.1.1-15101 Update 4
9) configured DS3615xs to my likes and shut it down
10) in the VM settings: created and added 4TB virtual drive
11) started VM 
12) on DSM: added new Raid Group (basic, btrfs)
13) on DSM: added a new volume
14) installed Hyper Backup and Hyper Backup Vault from the Package Center
15) tested my backup concept :-) after a few hours all data were restored ... 

  • Like 4

Share this post


Link to post
Share on other sites
6 minutes ago, hpk said:

Jun's loader contains 4 files. I did the following steps:

1) modified ds3615.vmx ( virtualHW.version = "11" )
2) uploaded all 4 files to a new directory on the ESXi server
3) added ds3615.vmx to the list of Virtual Machines.
4) in the VM settings: deleted the network adapter and added a new one
5) in the VM settings: created and added 8GB virtual drive
6) started the vm an connected to it in the browser 
7) installed DSM 6.1.1 on DS3615xs
8) upgraded within DSM to 6.1.1-15101 Update 4
9) configured DS3615xs to my likes and shut it down
10) in the VM settings: created and added 4TB virtual drive
11) started VM 
12) on DSM: added new Raid Group (basic, btrfs)
13) on DSM: added a new volume
14) installed Hyper Backup and Hyper Backup Vault from the Package Center
15) tested my backup concept :-) after a few hours all data were restored ... 

Thank you, i'll try it out. are there any issues with the latest 6.1.1 running on esxi?

Edited by jitesh_88
more info

Share this post


Link to post
Share on other sites
12 hours ago, meimeiriver said:

 

And now the only remaining question is, whether we can upgrade to 6.1.1-15101 Update 4 too, without data loss. :smile:

N.B. My 6.0.2-8451 install was already on Brtfs.

 

 

Can someone please answer this too?

Share this post


Link to post
Share on other sites
1 hour ago, meimeiriver said:

 

Can someone please answer this too?

I have 6.1.1-15101 Update 4 with no issue since it was released :smile:

Share this post


Link to post
Share on other sites
13 hours ago, Masrawy said:

I have 6.1.1-15101 Update 4 with no issue since it was released :smile:

 

Hmm, didn't they have like a new file system format? (Or at least one that was incompatible with 6.0.2 Brtfs) I recall reading something about that.

So, you just deployed jun's loader, installed 6.1, upgraded to latest version, and were able to mount your existing Btrfs? Cuz that would be ideal. :smile:

Share this post


Link to post
Share on other sites

Where can I download DSM 6.1.1-15101 Update 4 pat for 3615sx ?

Im trying update second pc to DSM 6.1.2-15132 from clean install 15047 - not boot no lan

Be careful, apparently there are pitfalls

Edited by g0dzilla

Share this post


Link to post
Share on other sites
On 14/06/2017 at 8:24 AM, hpk said:

Jun's loader contains 4 files. I did the following steps:

1) modified ds3615.vmx ( virtualHW.version = "11" )
2) uploaded all 4 files to a new directory on the ESXi server
3) added ds3615.vmx to the list of Virtual Machines.
4) in the VM settings: deleted the network adapter and added a new one
5) in the VM settings: created and added 8GB virtual drive
6) started the vm an connected to it in the browser 
7) installed DSM 6.1.1 on DS3615xs
8) upgraded within DSM to 6.1.1-15101 Update 4
9) configured DS3615xs to my likes and shut it down
10) in the VM settings: created and added 4TB virtual drive
11) started VM 
12) on DSM: added new Raid Group (basic, btrfs)
13) on DSM: added a new volume
14) installed Hyper Backup and Hyper Backup Vault from the Package Center
15) tested my backup concept :-) after a few hours all data were restored ... 

Cheers. works well for me too. I just had to edit grub.conf by mounting the .img file.

I tried 15132 in ESXi and it wasn't contactable so reverted to  snapshot.

Share this post


Link to post
Share on other sites

Same here, I ran the upgrade twice on a VM running on ESX 6.5 with DSM 6.1.1 U4 and both failed.

Will investigate further when I have more time but be careful and don't just hit that update button!

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi guys,

I tried to update my NAS (ds3617ds Jun's 1.02a2) from DSM 6.1.1-15101 Update 4 to DSM 6.1.2-15132 without luck, no lan. Fortunately I have serial cable connected to my router so I am able to debug it. Anyway the update removed all custom kernel drivers which was copied while initial installation. The modified rc and rc.modules are present, kernel modules and firmwares not. I tried also run reinstall bootloader choice, but it doesn't resolve missing kernel modules.

Last chance is to copy missing kernel modules manually with second USB drive.

Share this post


Link to post
Share on other sites

Damn, I can't edit my previous post. :-o

Anyway, after copy kernel modules from extra.lzma to /lib/modules, it works again! So it looks like missing kernel modules detection is not present in a bootloader.

Edited by Arcao

Share this post


Link to post
Share on other sites
45 minutes ago, mcdull said:

update always result in recovery mode.  Need clean install everytime.

 

So, it looks like I really have to wait for a new loader then, in order to upgrade from DSM 6.0.2-8451 Update 9 (ESXi 6) to the latest shiny. :(

Share this post


Link to post
Share on other sites
18 hours ago, g0dzilla said:

Where can I download DSM 6.1.1-15101 Update 4 pat for 3615sx ?

Im trying update second pc to DSM 6.1.2-15132 from clean install 15047 - not boot no lan

Be careful, apparently there are pitfalls

Yes, I am doing in same way in baremetal... also cannot access....

Share this post


Link to post
Share on other sites
11 hours ago, Arcao said:

Damn, I can't edit my previous post. :-o

Anyway, after copy kernel modules from extra.lzma to /lib/modules, it works again! So it looks like missing kernel modules detection is not present in a bootloader.

How to copy kernel modules if I am using baremetal version?

  • Like 1

Share this post


Link to post
Share on other sites
On 2017/6/14 at 11:37 PM, meimeiriver said:

 

Can someone please answer this too?

No, you cannot. You need to re-format the volume for a different file system

Share this post


Link to post
Share on other sites

Okay, reformat needed (when coming from DSM 6.0.2-8451 Update 9). Check. My remaining question then is, can DSM 6.1.2-15132 be (safely) installed on ESXi 6.5 at all yet?

Share this post


Link to post
Share on other sites

Full install (migrate) from 5.2 to 6.1.2-15132 successful on baremetal Gen8.

 

It wasn't straightforward though - the first time through I couldn't find the DS at all. Restarted, still nothing. Reinstalled the same version a second time, and it worked.

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.