DSM 6.1.x Loader


Recommended Posts

Hi guys and girls!

 

Have you set the vid & pid? if yes have you tried another usb stick. When I upgraded my N54L I removed all the boot entries except for the baremetal AMD option & everything worked ok.

 

VID and PID were set. Can you elaborate on how you remove the boot options?

 

 

hi there, i am also on N54L and just upgraded from 5.2 to 6.0.2 with v1.0.1. I am not sure what your problem is, but i just wanna share my experience. I followed the tutorial as u do and i found out that the Extra.lzma ramdisk is the problem for me. I managed to boot to the booting kernal page, but synology assistant could not detect it, may be becoz of the drivers. so i reverted back to original ramdisk and worked like a charm. i guess may be u got a wrong value of your vid and pid. or try on a different usb port and make sure u boot from usb. im not sure though.

 

Both the original and the replaced extra.lzma result in that black screen. I tried a different USB Drive - no joy. Different port - same result. I don't think I got the PID/VID part wrong, as the drive would boot fine on other machines.

 

Can someone tell me what the option "set default" in grub.cfg would do? Will it let me pick the AMD option as the standard option, so it would try to boot this without my interaction?

Link to post
Share on other sites
Hi guys and girls!

 

Have you set the vid & pid? if yes have you tried another usb stick. When I upgraded my N54L I removed all the boot entries except for the baremetal AMD option & everything worked ok.

 

VID and PID were set. Can you elaborate on how you remove the boot options?

 

 

hi there, i am also on N54L and just upgraded from 5.2 to 6.0.2 with v1.0.1. I am not sure what your problem is, but i just wanna share my experience. I followed the tutorial as u do and i found out that the Extra.lzma ramdisk is the problem for me. I managed to boot to the booting kernal page, but synology assistant could not detect it, may be becoz of the drivers. so i reverted back to original ramdisk and worked like a charm. i guess may be u got a wrong value of your vid and pid. or try on a different usb port and make sure u boot from usb. im not sure though.

 

Both the original and the replaced extra.lzma result in that black screen. I tried a different USB Drive - no joy. Different port - same result. I don't think I got the PID/VID part wrong, as the drive would boot fine on other machines.

 

Can someone tell me what the option "set default" in grub.cfg would do? Will it let me pick the AMD option as the standard option, so it would try to boot this without my interaction?

 

Might sounds silly, did u double check your bios that u boot from usb at 1st priority. if u not even see the loader's menu,i think it won't make any difference either u set default or not, even u load the intel version,u can still see the booting screen.

Link to post
Share on other sites
Can you elaborate on how you remove the boot options?

I just edited the grub.cfg file & removed all the boot entries except for the AMD one, so the last entry after function loadlinux {

..

..

}

 

Looks like this:

 

menuentry "DS3615xs 6.02 Baremetal AMD $VERSION" --class os {

set img=/image/DS3615xs

set zImage=bzImage

savedefault

loadlinux 3615 usb

loadinitrd

showtips

}

 

AMD is now the default boot option as it is the only one, therefore no interaction required.

Link to post
Share on other sites

 

I sent you a pm

 

Hello friend. May I also have the files for ESXi? Many Many thanks

I will when I get a chance. Been really busy with work. My server is not running by the way. We just moved to a new house :smile:

 

Sent from my XT1565 using Tapatalk

 

Thank you so so much.

Link to post
Share on other sites

If I want to change my SN and Mac after I have installed, how can i? I tried taking the USB drive and mouting it in Linux but there is no grub.conf and when the system is booted there is no /boot drive?

 

found it, just had to manually mount the /dev/sdb1 partition.

Link to post
Share on other sites

Hi all!

I have problem with 6.1.1 upd 4. Early i was update my system from ver 5 to ver 6.1.1 with Juns loader. All will be fine and system ask me about upd 4. After update also will be fine (web GUI and network access). But after 3 days i can't access to GUI, but network access to files has work fine. After reload network access also down and I can't to access to system (ping ok - system in network).

Now I want to back 5 version. Questions:

1. I have "native" Sinology (model not remember) with 6.0 version. If I put HDD to this system it will be work?

2. If it will be work I want to clear install ver 5 to my system and copy all files from "native" system to Xpenology system.

 

Alternative - go to downgrade topic and try to back...

Link to post
Share on other sites
I´m trying to register a new Xpenology with this S/N generator to have Quickconnect but it does not work, I have to reinstall DSM to make it work?.

 

Setup and use a custom DDNS. Use of quickconnect is an abuse of Synology's servers and a breach of the end user license.

Link to post
Share on other sites
Anyway for Quickconnect you need S/N and Network MAC Address valid pair.

 

it ius not anouth. you need real MAC and real SN

if you have not - Syno will broke your xpenology station and you wil can't use QC or manage syno account

 

[spoiler=QC problems]can't no more edit syno account on DS

14379024.png

 

shit in syno account

14294113.png

 

wanna delete SN? - nope. you cant :grin:

14311275.png

 

so, there is wery bas idea to use Syno QC

Link to post
Share on other sites
10 hours ago, jitesh_88 said:

hey meimeiriver, how did you get to 6.0.2?

did you upgrade from 5.2 or clean install?

did you loose your data?

 

I simply upgraded to DSM 6.0.2-8451 Update 9 (which is the latest the jun loader supported). No loss of data.

My question remains, though, Is there a reliable way yet to upgrade to 6.1.1-15101-4 by now? I've been out of it for several months. :smile:

Link to post
Share on other sites
13 часа назад, jitesh_88 сказал:

do i need to upgrade to 5.2 first?

no, try to update to 6.1.1 3615xs through force install, if it fail - remove system partitions on disks and make installation with save data

of course, you must use latest loader for 3615xs - Jun's loader 1.02a (not 1.02a2)

Edited by Lordbl4
Link to post
Share on other sites

That's what I did today.

Copied Jun's loader 1.02a to the ESXi Server and then a fresh install and update of DS3615xs ...
Now the VM is running with 6.1.1-15101 Update 4 like the physical Synologies I have here.

Edited by hpk
  • Like 1
Link to post
Share on other sites
5 hours ago, hpk said:

That's what I did today.

Copied Jun's loader 1.02a to the ESXi Server and then a fresh install and update of DS3615xs ...
Now the VM is running with 6.1.1-15101 Update 4 like the physical Synologies I have here.

how did you copy the loader to ESXi server? i get IO error if i try to deploy the OVF template

did you have to do any modifications to the img ?

Link to post
Share on other sites
5 hours ago, hpk said:

That's what I did today.

Copied Jun's loader 1.02a to the ESXi Server and then a fresh install and update of DS3615xs ...
Now the VM is running with 6.1.1-15101 Update 4 like the physical Synologies I have here.

 

Let me get this straight, you had to a clean install or an update? Really don't want to lose my data. Thx.

Link to post
Share on other sites
9 hours ago, meimeiriver said:

I simply upgraded to DSM 6.0.2-8451 Update 9 (which is the latest the jun loader supported). No loss of data.

Thanks meimeiriver, i used Jun's esxi download link and uploaded the OVF template

linked my RDM to the new VM, connected a serial port, and started the VM

synology assistant saw it as migratable, chose migration option and provided the 8451 patch file

now i am on 6.0.2-8451 with no data loss

Link to post
Share on other sites
28 minutes ago, jitesh_88 said:

i noticed my volume is ext4, is there a way to upgrade it to btrfs or do i need to delete the volume and create a new one?

I dont want to loose my data

 

And now the only remaining question is, whether we can upgrade to 6.1.1-15101 Update 4 too, without data loss. :smile:

N.B. My 6.0.2-8451 install was already on Brtfs.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.