IG-88

Driver extension jun 1.03b/1.04b for DSM6.2.3 for 918+ / 3615xs / 3617xs

Recommended Posts

9 hours ago, beantje said:

LS: cannot access /dev/dri: no such file ore directory

 

So I'm doing something wrong 

So today i have tried again,

 

i have downloaded

Loader:Jun's Loader v1.04b. ( https://xpenology.com/forum/topic/12952-dsm-62-loader/ ) 

then i added extra.lzma/extra2.lzma for loader 1.04b ds918+ DSM 6.2.3 v0.13.3

to the img file, convert to vmdk for esxi, run it 

then i backup old i915, replace it with this one the high end model  (same as above but for the new driver in 6.2.3 Update2

http://s000.tinyupload.com/?file_id=60054869936813513844)

 

but still nothing, not even ls dev/dri,

im i doing it wrong ?

 

thanks for helping!

 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, IG-88 said:

if you use a i5-10600t then this driver would be the one you need to test:

8086:9BC8 => iGPU UHD 630, Low End Desktop i5 10500 and lower

 

https://ark.intel.com/content/www/us/en/ark/products/199279/intel-core-i5-10600t-processor-12m-cache-up-to-4-00-ghz.html

-> 9BC8

 

Thanks for helping me out,

but i have tried all of them and still nothing show up dev/dri

 

and then now i tried this insmod

and got this

insmod: ERROR: could not insert module /volume1/Netwerkschijf/i915.ko: Unknown symbol in module

 

edit,

i just placed it in the update folder and on reboot i saw this

image.png.61ec06aeb909624940131ed41564fec0.png

 

but still same thing :(

Edited by beantje

Share this post


Link to post
Share on other sites
4 minutes ago, beantje said:

insmod: ERROR: could not insert module /volume1/Netwerkschijf/i915.ko: Unknown symbol in module

the the same procedure as above for bimmer2020

i915.ko in /usr/lib/modules/update/ ? (and related kernel modules that are loaded on boot from there)

still using jun's extra/extra2 or any older extra/extra2 - replace them with the extra/extra2 i made for 6.2.3

Share this post


Link to post
Share on other sites
41 minutes ago, IG-88 said:

the the same procedure as above for bimmer2020

i915.ko in /usr/lib/modules/update/ ? (and related kernel modules that are loaded on boot from there)

still using jun's extra/extra2 or any older extra/extra2 - replace them with the extra/extra2 i made for 6.2.3

OK so i did it wrong,

i replaced the extra/extra2 then i did reboot,

try insmod did not work

replaced the file on /usr/lib/modules/update did not work

then i placed the file in /usr/lib/modules/ reboot

 

and now it WORKS!!!!

EVEN PLEX HW TRANSCODE!!!!!

 

i thank you so much!!!!! i even updated it on my main server!!!

 

(is there anywhere i can donate for your work ?)

 

 

THANK YOU AGAIN!

 

Share this post


Link to post
Share on other sites
1 hour ago, beantje said:

(is there anywhere i can donate for your work ?)

no, but trying to help others here in the forum is always appreciated

thanks for retesting with plex, i will edit the 1st post and also add some information so its more clear how to do it (the way i intended it to be used)

Share this post


Link to post
Share on other sites

I9-9900t es, in the active hardware decoding ("extra/extra2" and "i915.ko"). 
Use Web (Chrome) to play Emby multimedia videos (4k x265), CPU utilization is more than 70%, before this 8700t hardware decoding CPU utilization is only about 50%, I do not know why?

20200731105340.png

Share this post


Link to post
Share on other sites

I would like to report that I just tested the 3E98 U2 after the update and it works just fine. Greatly appreciated.

 

I apologize for not reporting sooner as the whole family was in quarantine due to contracting COVID-19.

Share this post


Link to post
Share on other sites
12 hours ago, bimmer2020 said:

I9-9900t es, in the active hardware decoding ("extra/extra2" and "i915.ko"). 
Use Web (Chrome) to play Emby multimedia videos (4k x265), CPU utilization is more than 70%, before this 8700t hardware decoding CPU utilization is only about 50%, I do not know why?

 

maybe try synologys own videstation to exclude emby as a source of problem, also try some different h.264 video material

https://xpenology.com/forum/topic/24864-transcoding-without-a-valid-serial-number/

 

Share this post


Link to post
Share on other sites

Hey Folks,

 

I'm doing some tests on ESXi right now, because my last XPEnology is years and versions (5.x) ago. With help of @flyride I got 918+ running.

 

Now I am on a new 3617 installation, because I prefer native SAS Support. With FixSynoBoot I solved the eSATA problem. Everything looks good, create Raid and Volume, but in Seriel Console I got some errors:

 

[   18.415623] BUG: Bad rss-counter state mm:ffff88061eecf1c0 idx:2 val:-1
 ... [  OK  ]
:: Loading module mptctl ... [  OK  ]
:: Loading module megaraid_sas ... [  OK  ]
:: Loading module mpt2sas ... [  OK  ]
:: Loading module mpt3sas ... [  OK  ]
Insert net driver(Mindspeed only)...
Starting /usr/syno/bin/synocfgen...
/usr/syno/bin/synocfgen returns 0
All disk ready or timeout execeed
[   18.486300] md: invalid raid superblock magic on sdb1
[   18.487202] md: invalid raid superblock magic on sdc1
[   18.495084] md: invalid raid superblock magic on sdd3
[   18.506535] md: invalid raid superblock magic on sde3
[   18.516730] md: invalid raid superblock magic on sdf3
[   18.524530] md: invalid raid superblock magic on sdg3
Partition Version=8
 /sbin/e2fsck exists, checking /dev/md0...
/sbin/e2fsck -pvf returns 0
Mounting /dev/md0 /tmpRoot
------------upgrade
Begin upgrade procedure
No upgrade file exists
End upgrade procedure
============upgrade

 

My grub is this:

set extra_initrd="extra.lzma"
set info="info.txt"

set vid=0x058f
set pid=0x6387
set sn=XXX
set mac1=0011322CAXXX
set rootdev=/dev/md0
set netif_num=1
#set extra_args_3617='earlycon=uart8250,io,0x3f8,115200n8 earlyprintk loglevel=15'
set extra_args_3617=''

set common_args_3617='syno_hdd_powerup_seq=0 HddHotplug=0 syno_hw_version=DS3617xs vender_format_version=2 console=ttyS0,115200n8 withefi elevator=elevator quiet syno_port_thaw=1'

set sata_args='sata_uid=1 sata_pcislot=5 synoboot_satadom=1 DiskIdxMap=0C SataPortMap=1 SasIdxMap=0'

Loader: 1.03b

DSM: 6.2.3-25426 Update 2

 

Thanks for your ideas. :)

Bildschirmfoto 2020-07-31 um 21.42.49.png

Bildschirmfoto 2020-07-31 um 22.10.14.png

Share this post


Link to post
Share on other sites

Is there something not working?  There are a lot of "normal" errors in /var/log/messages, particularly on bootup.

Share this post


Link to post
Share on other sites

Unbelievably fast. Raids are working. No problems in general, but I trie to find out, why hibernation is not working. 😅

Share this post


Link to post
Share on other sites

DSM 6.2.3-25426 Update 2 working out of the Box with 1.03b on ESXi, but not working after replacing extra.lzma with 11.2_test:

 

Boot on ESXi 6.7 with original 1.03b Loader (all good):

 

   The highlighted entry will be executed automatically in 0s.
patching file etc/rc
Hunk #1 succeeded at 184 (offset 13 lines).
patching file etc/synoinfo.conf
Hunk #1 FAILED at 261.
1 out of 1 hunk FAILED -- saving rejects to file etc/synoinfo.conf.rej
patching file linuxrc.syno
Hunk #1 FAILED at 39.
Hunk #2 succeeded at 131 (offset 32 lines).
Hunk #3 succeeded at 694 (offset 179 lines).
1 out of 3 hunks FAILED -- saving rejects to file linuxrc.syno.rej
patching file usr/sbin/init.post
cat: can't open '/etc/synoinfo_override.conf': No such file or directory
START /linuxrc.syno
Insert Marvell 1475 SATA controller driver
Insert basic USB modules...
:: Loading module usb-common ... [  OK  ]
:: Loading module usbcore ... [  OK  ]
:: Loading module ehci-hcd ... [  OK  ]
:: Loading module ehci-pci ... [  OK  ]
:: Loading module ohci-hcd ... [  OK  ]
:: Loading module uhci-hcd ... [  OK  ]
:: Loading module xhci-hcd ... [  OK  ]
:: Loading module usb-storage ... [  OK  ]
:: Loading module BusLogic ... [  OK  ]
:: Loading module vmw_pvscsi ... [  OK  ]
:: Loading module megaraid_mm ... [  OK  ]
:: Loading module megaraid_mbox ... [  OK  ]
:: Loading module megaraid ... [  OK  ]
:: Loading module scsi_transport_spi ... [  OK  ]
:: Loading module mptbase ... [  OK  ]
:: Loading module mptscsih ... [  OK  ]
:: Loading module mptspi ... [  OK  ]
:: Loading module mptsas[    8.312612] sd 1:0:0:0: [sdb] No Caching mode page found
[    8.313475] sd 1:0:0:0: [sdb] Assuming drive cache: write through
[    8.314820] sd 1:0:0:0: [sdb] No Caching mode page found
[    8.315678] sd 1:0:0:0: [sdb] Assuming drive cache: write through
[    8.317621] sd 1:0:0:0: [sdb] No Caching mode page found
[    8.318471] sd 1:0:0:0: [sdb] Assuming drive cache: write through
[   18.432499] sd 1:0:1:0: [sdc] No Caching mode page found
[   18.433377] sd 1:0:1:0: [sdc] Assuming drive cache: write through
[   18.435439] sd 1:0:1:0: [sdc] No Caching mode page found
[   18.436341] sd 1:0:1:0: [sdc] Assuming drive cache: write through
[   18.439377] sd 1:0:1:0: [sdc] No Caching mode page found
[   18.440202] sd 1:0:1:0: [sdc] Assuming drive cache: write through
 ... [  OK  ]
:: Loading module mptctl ... [  OK  ]
:: Loading module megaraid_sas ... [  OK  ]
:: Loading module mpt2sas ... [  OK  ]
:: Loading module mpt3sas ... [  OK  ]
Insert net driver(Mindspeed only)...
Starting /usr/syno/bin/synocfgen...
/usr/syno/bin/synocfgen returns 0
All disk ready or timeout execeed
[   18.545176] md: invalid raid superblock magic on sdb1
[   18.546051] md: invalid raid superblock magic on sdc1
[   18.564310] md: invalid raid superblock magic on sdd3
[   18.582823] md: invalid raid superblock magic on sde3
[   18.604436] md: invalid raid superblock magic on sdf3
[   18.626405] md: invalid raid superblock magic on sdg3
Partition Version=8
 /sbin/e2fsck exists, checking /dev/md0...
/sbin/e2fsck -pvf returns 1
Mounting /dev/md0 /tmpRoot
------------upgrade
Begin upgrade procedure
No upgrade file exists
End upgrade procedure
============upgrade
ls: /tmpRoot/usr/share/init/root-file-system.override: No such file or directory
ls: /tmpRoot/usr/share/init/hostname.override: No such file or directory
ls: /tmpRoot/usr/share/init/syslog-ng.override: No such file or directory
ls: /tmpRoot/usr/share/init/dsmupdate.override: No such file or directory
ls: /tmpRoot/usr/share/init/smallupdate.override: No such file or directory
ls: /tmpRoot/usr/share/init/rc.override: No such file or directory
Wait 2 seconds for synology manufactory device
Fri Jul 31 21:10:00 UTC 2020
/dev/md0 /tmpRoot ext4 rw,relatime,journal_checksum,data=ordered 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
sys /sys sysfs rw,relatime 0 0
none /dev devtmpfs rw,relatime,size=12334232k,nr_inodes=3083558,mode=755 0 0
proc /proc proc rw,relatime 0 0
linuxrc.syno executed successfully.
Post init

[   30.617155] device-mapper: flashcache: preread max memmory count=2048
[   30.647777] flashache: /dev/md2 exclude check success
[   30.648606] flashache: /dev/md3 exclude check success
[   30.649945] Only DIRTY blocks exist in cache
[   30.650615] flashcache: flashcache_writeback_load: md_blocks = 47682, md_sectors = 381456, md_block_size = 8
[   30.650615]
[   32.157772] flashcache: creating finish
[   32.499033] BTRFS: has skinny extents

MA-SYN-01 login: 

 

oot on ESXi 6.7 with modified 1.03b Loader (replaced extra.lzma, not working):

 

patching file etc/rc
patching file etc/synoinfo.conf
Hunk #1 FAILED at 291.
1 out of 1 hunk FAILED -- saving rejects to file etc/synoinfo.conf.rej
patching file linuxrc.syno
patching file usr/sbin/init.post
cat: can't open '/etc/synoinfo_override.conf': No such file or directory
START /linuxrc.syno
Insert Marvell 1475 SATA controller driver
Insert basic USB modules...
:: Loading module usb-common ... [  OK  ]
:: Loading module usbcore ... [  OK  ]
:: Loading module ehci-hcd ... [  OK  ]
:: Loading module ehci-pci ... [  OK  ]
:: Loading module ohci-hcd ... [  OK  ]
:: Loading module uhci-hcd ... [  OK  ]
:: Loading module xhci-hcd ... [  OK  ]
:: Loading module usb-storage ... [  OK  ]
:: Loading module scsi_transport_spi ... [  OK  ]
:: Loading module BusLogic ... [  OK  ]
:: Loading module vmw_pvscsi ... [FAILED]
:: Loading module megaraid_mm ... [  OK  ]
:: Loading module megaraid_mbox ... [  OK  ]
:: Loading module megaraid ... [  OK  ]
:: Loading module mptbase ... [  OK  ]
:: Loading module mptscsih ... [  OK  ]
:: Loading module mptspi ... [  OK  ]
:: Loading module mptsas[    2.003319] general protection fault: 0000 [#1] SMP
[    2.003332] Modules linked in: mptsas(F+) mptspi(F) mptscsih(F) mptbase(F) megaraid(F) megaraid_mbox(F) megaraid_mm(F) BusLogic(F) scsi_transport_spi(F) usb_storage xhci_hcd uhci_hcd ohci_hcd(F) ehci_pci(F) ehci_hcd(F) usbcore usb_common mv14xx(O) xxllouald(OF)
[    2.004208] CPU: 2 PID: 3899 Comm: insmod Tainted: GF          O 3.10.105 #23739
[    2.004220] Hardware name: VMware, Inc. VMware Virtual Platform/440BX Desktop Reference Platform, BIOS 6.00 12/12/2018
[    2.004232] task: ffff88062082f040 ti: ffff88061dc80000 task.ti: ffff88061dc80000
[    2.004244] RIP: 0010:[<ffffffff814bc205>]  [<ffffffff814bc205>] _raw_spin_lock+0x5/0x30
[    2.004256] RSP: 0018:ffff88061dc83c00  EFLAGS: 00010002
[    2.004268] RAX: 0000000000000100 RBX: ffff88061d82fd18 RCX: 0000000000000000
[    2.004280] RDX: 0000000000000000 RSI: ffff88061dc83c08 RDI: cccccccccccccccc
[    2.004292] RBP: cccccccccccccccc R08: 0000000000000000 R09: 0000000000000000
[    2.004304] R10: ffff88061f4c0600 R11: 0000000000000000 R12: 0000000000000008
[    2.004316] R13: ffff88061d82f008 R14: ffffffffa017df80 R15: ffff88061d82f000
[    2.004328] FS:  00007f1462cb4700(0000) GS:ffff88063fd00000(0000) knlGS:0000000000000000
[    2.004340] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    2.004352] CR2: 00007f146259fe10 CR3: 000000061ca64000 CR4: 00000000003407e0
[    2.004364] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[    2.004376] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[    2.004388] Stack:
[    2.004400]  ffffffff8103eb32 0000000000000086 0000000000000206 ffffffffa01a06e0
[    2.004413]  0000000000000000 ffffffff8104a125 ffff88061d869940 ffffffffa01793da
[    2.004425]  ffff880600000000 ffff88061d82fcf8 0000000000000000 ffff880620f22098
[    2.004437] Call Trace:
[    2.004453]  [<ffffffff8103eb32>] ? add_timer_on+0x52/0xa0
[    2.004469]  [<ffffffff8104a125>] ? queue_delayed_work_on+0x25/0x30
[    2.004485]  [<ffffffffa01793da>] ? mpt_attach+0x93a/0xc90 [mptbase]
[    2.004502]  [<ffffffffa019db40>] ? mptsas_probe+0x10/0x490 [mptsas]
[    2.004518]  [<ffffffff81298160>] ? pci_device_probe+0x60/0xa0
[    2.004534]  [<ffffffff81302d2a>] ? really_probe+0x5a/0x220
[    2.004550]  [<ffffffff81302fb1>] ? __driver_attach+0x81/0x90
[    2.004565]  [<ffffffff81302f30>] ? __device_attach+0x40/0x40
[    2.004581]  [<ffffffff81301023>] ? bus_for_each_dev+0x53/0x90
[    2.004599]  [<ffffffff813024c8>] ? bus_add_driver+0x158/0x250
[    2.004614]  [<ffffffffa01a3000>] ? 0xffffffffa01a2fff
[    2.004630]  [<ffffffff813035b8>] ? driver_register+0x68/0x150
[    2.004645]  [<ffffffffa01a3000>] ? 0xffffffffa01a2fff
[    2.004661]  [<ffffffffa01a3122>] ? mptsas_init+0x122/0x13a [mptsas]
[    2.004676]  [<ffffffffa01a3000>] ? 0xffffffffa01a2fff
[    2.004691]  [<ffffffff810003aa>] ? do_one_initcall+0xea/0x140
[    2.004707]  [<ffffffff8108925e>] ? load_module+0x1a0e/0x20f0
[    2.004723]  [<ffffffff81086410>] ? store_uevent+0x40/0x40
[    2.004739]  [<ffffffff810899d1>] ? SYSC_init_module+0x91/0xc0
[    2.004754]  [<ffffffff814bcc32>] ? system_call_fastpath+0x16/0x1b
[    2.004766] Code: 66 0f 1f 44 00 00 8d 8a 00 01 00 00 89 d0 f0 66 0f b1 0f 66 39 d0 75 e5 b8 01 00 00 00 c3 0f 1f 84 00 00 00 00 00 b8 00 01 00 00 <f0> 66 0f c1 07 0f b6 d4 38 c2 74 10 0f 1f 80 00 00 00 00 f3 90
[    2.004778] RIP  [<ffffffff814bc205>] _raw_spin_lock+0x5/0x30
[    2.004790]  RSP <ffff88061dc83c00>
[    2.004802] ---[ end trace 6d74f38908e1dd40 ]---
 ... [FAILED]
:: Loading module mptctl[    2.006461] Fusion MPT misc device (ioctl) driver 3.04.20
[    2.007315] mptctl: Registered with Fusion MPT base driver
[    2.007642] mptctl: /dev/mptctl @ (major,minor=10,220)
 ... [  OK  ]
:: Loading module megaraid_sas[    2.009998] megasas: 06.506.00.00-rc1 Sat. Feb. 9 17:00:00 PDT 2013
 ... [  OK  ]
:: Loading module mpt2sas[    2.012639] mpt2sas version 20.00.00.00 loaded
 ... [  OK  ]
:: Loading module mpt3sas[    2.015667] mpt3sas version 22.00.02.00 loaded
 ... [  OK  ]
:: Loading module sx8 ... [  OK  ]
:: Loading module aacraid[    2.021277] Adaptec aacraid driver 1.2-0[30200]-ms
 ... [  OK  ]
:: Loading module aic94xx[    2.023996] aic94xx: Adaptec aic94xx SAS/SATA driver version 1.0.3 loaded
 ... [  OK  ]
:: Loading module 3w-9xxx[    2.026608] 3ware 9000 Storage Controller device driver for Linux v2.26.02.014.
 ... [  OK  ]
:: Loading module 3w-sas[    2.029631] LSI 3ware SAS/SATA-RAID Controller device driver for Linux v3.26.02.000.
 ... [  OK  ]
:: Loading module 3w-xxxx[    2.032564] 3ware Storage Controller device driver for Linux v1.26.02.003.
 ... [  OK  ]
:: Loading module mvumi ... [  OK  ]
:: Loading module mvsas ... [  OK  ]
:: Loading module arcmsr ... [  OK  ]
:: Loading module isci[    2.042928] isci: Intel(R) C600 SAS Controller Driver - version 1.1.0
 ... [  OK  ]
:: Loading module hpsa ... [  OK  ]
:: Loading module nvme ... [  OK  ]
:: Loading module ata_piix[    2.051508] ata_piix 0000:00:07.1: version 2.13
[    2.054223] scsi1 : ata_piix
[    2.055189] scsi2 : ata_piix
[    2.055932] ata2: PATA max UDMA/33 cmd 0x1f0 ctl 0x3f6 bmdma 0x1060 irq 14
[    2.056601] ata3: PATA max UDMA/33 cmd 0x170 ctl 0x376 bmdma 0x1068 irq 15
[    2.114185] tsc: Refined TSC clocksource calibration: 3503.993 MHz
[    2.115145] Switching to clocksource tsc
[    2.214080] ata2: Read current link speed fail, retry 1
[    2.220075] ata2: Read current link speed fail, retry 2
[    2.226071] ata2: Read current link speed fail, retry 3
[    2.243026] ata3: Read current link speed fail, retry 1
[    2.249052] ata3: Read current link speed fail, retry 2
[    2.255047] ata3: Read current link speed fail, retry 3
 ... [  OK  ]
Insert net driver(Mindspeed only)...
[    2.270268] broadwell_synobios: module license 'Synology Inc.' taints kernel.
[    2.271236] 2020-7-31 20:34:19 UTC
[    2.271508] synobios: load, major number 201
[    2.271834] Brand: Synology
[    2.272135] Model: DS-3617xs
[    2.272156] set group disks wakeup number to 4, spinup time deno 7
[    2.273021] synobios cpu_arch proc entry initialized
[    2.273043] synobios crypto_hw proc entry initialized
[    2.273064] synobios syno_platform proc entry initialized
[    2.273085] synobios open /dev/ttyS1 success
Starting /usr/syno/bin/synocfgen...
/usr/syno/bin/synocfgen returns 0
[    2.275136] synobios: unload
All disk ready or timeout execeed
Exit on error [1] DISK NOT INSTALLED...
[    3.237255] usb 1-1: new full-speed USB device number 2 using xhci_hcd
[    3.249339] Got empty serial number. Generate serial number from product.
Fri Jul 31 20:34:21 UTC 2020
none /sys/kernel/debug debugfs rw,relatime 0 0
sys /sys sysfs rw,relatime 0 0
none /dev devtmpfs rw,relatime,size=12332888k,nr_inodes=3083222,mode=755 0 0
proc /proc proc rw,relatime 0 0
linuxrc.syno failed on 1
starting pid 4328, tty '': '/etc/rc'
:: Starting /etc/rc
:: Mounting procfs ... [  OK  ]
:: Mounting tmpfs ... [  OK  ]
:: Mounting devtmpfs ... [  OK  ]
:: Mounting devpts ... [  OK  ]
:: Mounting sysfs ... [  OK  ]
mdadm: error opening /dev/md1: No such file or directory
rc: Use all internal disk as swap.
rc: No internal disk installed.
swapon: can't stat '/dev/md1': No such file or directory
:: Loading module sg[    4.357081] sd 0:0:0:0: Attached scsi generic sg0 type 0
 ... [  OK  ]
:: Loading module crc-ccitt ... [  OK  ]
:: Loading module crc-itu-t ... [  OK  ]
:: Loading module mdio ... [  OK  ]
:: Loading module fat ... [  OK  ]
:: Loading module vfat ... [  OK  ]
:: Loading module ip_tunnel ... [  OK  ]
:: Loading module vxlan ... [  OK  ]
:: Loading module dca[    4.436263] dca service started, version 1.12.1
 ... [  OK  ]
:: Loading module e1000e[    4.440891] e1000e: Intel(R) PRO/1000 Network Driver - 3.6.0-NAPI
[    4.441849] e1000e: Copyright(c) 1999 - 2019 Intel Corporation.
[    4.443208] e1000e 0000:03:00.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
[    4.444350] e1000e 0000:03:00.0: irq 78 for MSI/MSI-X
[    4.444898] e1000e 0000:03:00.0: irq 79 for MSI/MSI-X
[    4.445705] e1000e 0000:03:00.0: irq 80 for MSI/MSI-X
[    4.548623] e1000e 0000:03:00.0 eth0: (PCI Express:2.5GT/s:Width x1) 00:11:32:2c:a7:88
[    4.549804] e1000e 0000:03:00.0 eth0: Intel(R) PRO/1000 Network Connection
[    4.550840] e1000e 0000:03:00.0 eth0: MAC: 3, PHY: 8, PBA No: 000000-000
 ... [  OK  ]
:: Loading module i2c-algo-bit ... [  OK  ]
:: Loading module igb[    4.559367] Intel(R) Gigabit Ethernet Linux Driver - version 5.3.5.39
[    4.560322] Copyright(c) 2007 - 2019 Intel Corporation.
 ... [  OK  ]
:: Loading module be2net ... [  OK  ]
:: Loading module ixgbe[    4.568655] Intel(R) 10GbE PCI Express Linux Network Driver - version 5.6.3
[    4.569677] Copyright(c) 1999 - 2019 Intel Corporation.
 ... [  OK  ]
:: Loading module r8168 ... [  OK  ]
:: Loading module libcrc32c ... [  OK  ]
:: Loading module mii ... [  OK  ]
:: Loading module libphy ... [  OK  ]
:: Loading module atl1 ... [  OK  ]
:: Loading module atl1e ... [  OK  ]
:: Loading module atl1c ... [  OK  ]
:: Loading module alx ... [  OK  ]
:: Loading module uio ... [  OK  ]
:: Loading module ipg ... [  OK  ]
:: Loading module jme[    4.619756] jme: JMicron JMC2XX ethernet driver version 1.0.8
 ... [  OK  ]
:: Loading module skge ... [  OK  ]
:: Loading module sky2[    4.628158] sky2: driver version 1.30
 ... [  OK  ]
:: Loading module ptp_pch ... [  OK  ]
:: Loading module pch_gbe[    4.636151] pch_gbe: EG20T PCH Gigabit Ethernet Driver - version 1.01
 ... [  OK  ]
:: Loading module qla3xxx ... [  OK  ]
:: Loading module qlcnic[    4.645163] QLogic 1/10 GbE Converged/Intelligent Ethernet Driver v5.2.42
 ... [  OK  ]
:: Loading module qlge ... [  OK  ]
:: Loading module netxen_nic[    4.654182] QLogic/NetXen Network Driver v4.0.80
 ... [  OK  ]
:: Loading module sfc[    4.658772] Solarflare NET driver v3.2
 ... [  OK  ]
:: Loading module e1000[    4.663407] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[    4.664485] e1000: Copyright (c) 1999-2006 Intel Corporation.
 ... [  OK  ]
:: Loading module pcnet32[    4.669144] pcnet32: pcnet32.c:v1.35 21.Apr.2008 tsbogend@alpha.franken.de
 ... [  OK  ]
:: Loading module vmxnet3[    4.674077] VMware vmxnet3 virtual NIC driver - version 1.1.30.0-k-NAPI
 ... [  OK  ]
:: Loading module bnx2 ... [  OK  ]
:: Loading module bnx2x[    4.684132] bnx2x: Broadcom NetXtreme II 5771x/578xx 10/20-Gigabit Ethernet Driver bnx2x 1.78.17-0 (2013/04/11)
 ... [  OK  ]
:: Loading module igbvf[    4.691249] igbvf: Intel(R) Gigabit Virtual Function Driver - 2.3.8.2
[    4.692222] igbvf: Copyright (c) 1999-2015 Intel Corporation.
 ... [  OK  ]
:: Loading module ixgbevf[    4.697629] ixgbevf: Intel(R) 10GbE PCI Express Virtual Function Driver - version 4.6.1
[    4.698568] Copyright(c) 1999 - 2019 Intel Corporation.
 ... [  OK  ]
:: Loading module r8101 ... [  OK  ]
:: Loading module r8125 ... [  OK  ]
:: Loading module r8169 ... [  OK  ]
:: Loading module tg3 ... [  OK  ]
:: Loading module usbnet ... [  OK  ]
:: Loading module ax88179_178a[    4.724548] usbcore: registered new interface driver ax88179_178a
 ... [  OK  ]
:: Loading module button[    4.729828] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
[    4.730944] ACPI: Power Button [PWRF]
 ... [  OK  ]
:: Loading module evdev ... [  OK  ]
:: Loading module atl2[    4.743048] Atheros(R) L2 Ethernet Driver - version 2.2.3
[    4.743883] Copyright (c) 2007 Atheros Corporation.
 ... [  OK  ]
:: Loading module e100[    4.748551] e100: Intel(R) PRO/100 Network Driver, 3.5.24-k2-NAPI
[    4.749461] e100: Copyright(c) 1999-2006 Intel Corporation
 ... [  OK  ]
:: Loading module ixgb[    4.754886] ixgb: Intel(R) PRO/10GbE Network Driver - version 1.0.135-k2-NAPI
[    4.755526] ixgb: Copyright (c) 1999-2008 Intel Corporation.
 ... [  OK  ]
:: Loading module forcedeth ... [  OK  ]
:: Loading module tn40xx[    4.764578] tn40xx: Tehuti Network Driver, 0.3.6.17.2
[    4.765381] tn40xx: Supported phys : MV88X3120 MV88X3310 MV88E2010 QT2025 TLK10232 AQR105 MUSTANG
 ... [  OK  ]
:: Loading module cxgb ... [  OK  ]
:: Loading module cxgb3 ... [  OK  ]
:: Loading module cxgb4 ... [  OK  ]
:: Loading module atlantic ... [  OK  ]
:: Loading module bna[    4.786981] Brocade 10G Ethernet driver - version: 3.1.2.1
 ... [  OK  ]
:: Loading module vxge[    4.791706] vxge: Copyright(c) 2002-2010 Exar Corp.
[    4.792462] vxge: Driver version: 2.5.3.22640-k
 ... [  OK  ]
:: Loading module aqc111[    4.797028] usbcore: registered new interface driver aqc111
 ... [  OK  ]
:: Loading module asix[    4.801785] usbcore: registered new interface driver asix
 ... [  OK  ]
:: Loading module cx82310_eth[    4.806244] usbcore: registered new interface driver cx82310_eth
 ... [  OK  ]
:: Loading module et131x[    4.810703] et131x: module is from the staging directory, the quality is unknown, you have been warned.
 ... [  OK  ]
:: Loading module i40e[    4.815650] i40e: Intel(R) 40-10 Gigabit Ethernet Connection Network Driver - version 2.4.10
[    4.816797] i40e: Copyright(c) 2013 - 2018 Intel Corporation.
 ... [  OK  ]
:: Loading module i40evf[    4.821557] i40evf: Intel(R) 40-10 Gigabit Virtual Function Network Driver - version 3.6.15
[    4.822705] Copyright(c) 2013 - 2018 Intel Corporation.
 ... [  OK  ]
:: Loading module mcs7830[    4.827385] usbcore: registered new interface driver MOSCHIP usb-ethernet driver
 ... [  OK  ]
:: Loading module pegasus[    4.832361] pegasus: v0.9.3 (2013/04/25), Pegasus/Pegasus II USB Ethernet driver
[    4.833522] usbcore: registered new interface driver pegasus
 ... [  OK  ]
:: Loading module plusb[    4.837999] usbcore: registered new interface driver plusb
 ... [  OK  ]
:: Loading module r8152[    4.842566] usbcore: registered new interface driver r8152
 ... [  OK  ]
:: Loading module rtl8150[    4.847196] usbcore: registered new interface driver rtl8150
 ... [  OK  ]
:: Loading module s2io ... [  OK  ]
:: Loading module xgmac ... [  OK  ]
:: Loading module i2c-i801 ... [  OK  ]
:: Loading module adt7475 ... [  OK  ]
Can not detect ADT device, Retry: 1...
:: Unloading module adt7475 ... [  OK  ]
:: Unloading module i2c-i801 ... [  OK  ]
:: Loading module i2c-i801 ... [  OK  ]
:: Loading module adt7475 ... [  OK  ]
Can not detect ADT device, Retry: 2...
:: Unloading module adt7475 ... [  OK  ]
:: Unloading module i2c-i801 ... [  OK  ]
:: Loading module i2c-i801 ... [  OK  ]
:: Loading module adt7475 ... [  OK  ]
Can not detect ADT device, Retry: 3...
:: Unloading module adt7475 ... [  OK  ]
:: Unloading module i2c-i801 ... [  OK  ]
:: Loading module i2c-i801 ... [  OK  ]
:: Loading module adt7475 ... [  OK  ]
:: Loading module synobios[   10.961095] 2020-7-31 20:34:28 UTC
[   10.961611] synobios: load, major number 201
[   10.962254] Brand: Synology
[   10.962750] Model: DS-3617xs
[   10.963212] set group disks wakeup number to 4, spinup time deno 7
[   10.964126] synobios cpu_arch proc entry initialized
[   10.964860] synobios crypto_hw proc entry initialized
[   10.965609] synobios syno_platform proc entry initialized
[   10.966415] synobios open /dev/ttyS1 success
 ... [  OK  ]
[   11.134141] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
udhcpc (v1.16.1) started
eth0      Link encap:Ethernet  HWaddr 00:11:32:2C:A7:88
          inet addr:192.168.252.140  Bcast:192.168.252.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1044 (1.0 KiB)  TX bytes:1660 (1.6 KiB)
          Interrupt:18 Memory:fd4a0000-fd4c0000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

:: Starting syslogd ... [  OK  ]
:: Starting scemd
:: Starting services in background
Starting findhostd in flash_rd...
Starting services in flash_rd...
Running /usr/syno/etc/rc.d/J01httpd.sh...
Starting httpd:80 in flash_rd...
Starting httpd:5000 in flash_rd...
Running /usr/syno/etc/rc.d/J03ssdpd.sh...
/usr/bin/minissdpd -i eth0
(15): upnp:rootdevice
(51): uuid:upnp_SynologyNAS-0011322ca788::upnp:rootdevice
(60): Synology/synology_broadwell_3617xs/6.2-23739/192.168.252.140
(48): http://192.168.252.140:5000/description-eth0.xml
Connected.
done.
/usr/syno/bin/reg_ssdp_service 192.168.252.140 0011322ca788 6.2-23739 synology_broadwell_3617xs eth0
Running /usr/syno/etc/rc.d/J04synoagentregisterd.sh...
Starting synoagentregisterd...
Running /usr/syno/etc/rc.d/J30DisableNCQ.sh...
Running /usr/syno/etc/rc.d/J80ADTFanControl.sh...
Running /usr/syno/etc/rc.d/J98nbnsd.sh...
Starting nbnsd...
Running /usr/syno/etc/rc.d/J99avahi.sh...
Starting Avahi mDNS/DNS-SD Daemon
cname_load_conf failed:/var/tmp/nginx/avahi-aliases.conf
:: Loading module hid ... [  OK  ]
:: Loading module usbhid[   20.099616] usbcore: registered new interface driver usbhid
[   20.100449] usbhid: USB HID core driver
 ... [  OK  ]
============ Date ============
Fri Jul 31 20:34:37 UTC 2020
==============================
starting pid 6746, tty '': '/sbin/getty 115200 console'

Fri Jul 31 20:34:38 2020

DiskStation login:

I think it's my fault, but don't find my mistake.

Edited by etests

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.