jun

Progress of 6.2 loader

Polanskiman

Let me get things straighten up here before this thread starts going sideways. This is the developper discussion room. Not a newbie forum to start asking for guides and whatnot. @jun hasn't even said anything about the loader he has uploaded to his repository. So I would advise self control. Also, to those in panic mode trying to make things work desperately please use your personal jugement and experience. If you want to have a positive contribution to this thread then please do so by posting about possible bugs or things that don't work (beyond the "no network" boring posts of course). I am talking about serious bugs or the such. All other requests will from now on be deleted or moved if appropriate. I have no time to babysit anymore. Use the forum subsections.

Message added by Polanskiman

Recommended Posts

1.03a2 is not working with ESXI 6.7 Tried everything in the book. I give up.. Moving on. It's been fun and take care my friend's. I'm done with this.

Sent from my VS501 using Tapatalk

  • Haha 1

Share this post


Link to post
Share on other sites

Asus E2KM1I-Deluxe, stops after "screen will stop updating shortly" with a blinking cursor, will not boot OS. Tried PCIe card (Marvell 9215), will not boot either. Both working in 6.1, just tested.

Edited by error403

Share this post


Link to post
Share on other sites
В 16.6.2018 в 22:50, x01015918 сказал:

Any Idea why scaling_driver is acpi-cpufreq and not INTEL_PSTATE? intel_pstate=enable don't work either.

918d99a.thumb.png.31368279d738390e16f7e613b78ce243.png

Share this post


Link to post
Share on other sites
4 hours ago, x01015918 said:

ok, so I need to recompile the kernel?

 

i guess if you try this you will fail

dsm 6.2 seems to have even more protections then 6.1 and we always used jun's 6.1 loader (hack) and the original synology kernel (remember the never compiled hyper-v and amd support because it was missing in syno's kernel?), beside this i have'nt seen a recent 6.2 kernel source from synology, just the old beta 6.2 was released

https://sourceforge.net/projects/dsgpl/files/Synology NAS GPL Source/

 

why do we need INTEL_PSTATE?

 

Share this post


Link to post
Share on other sites

Hello,

 

I just test new loader 1.03a2.

DSM 6.2 is install and fine on my configuration: ASrock Z370M Pro4, Pentium G5500.

Everything work fine except support of LSI  9211-8i controler. I use it on my old xpenology project. 

Can I install driver for it ?

 

Many thanks for your work.

Share this post


Link to post
Share on other sites

jun wrote in his "whats new.txt" with 1.03a2

DS918+ may need a reasonable recent cpu instruction set to run properly.

so we dont know for sure whats working with 918+ lmage

we should start collecting and summarizing information about that

918+ is not just interesting because of supported apollo lake and hardware transcoding it also uses kernel 4.4 and we might have more luck with additional drivers (dead ends with dsm 6.1 for hpsa and sata/pata drivers)

 

so lets have a limbo contest about "how low can you go" ;-)

collected information might look like this in the end (i've already started collecting, so things below are based on users and my own tests)

for now i will extend this list here in this place

 

Edit: the CPU list is now maintained with the extended extra drivers see here for latest list

 

 

https://en.wikipedia.org/wiki/Silvermont#Roadmap

edit: but from "non working" feedback it looks like Haswell (4th gen intel core) might be the minimum for desktop cpu's, afair that was the same with the 916+ image

 

i'm planning to do a driver package like we had for 6.1

so we could maintain a driver and cpu support list with it

 

 

 

Edited by IG-88

Share this post


Link to post
Share on other sites
13 minutes ago, BORoSA said:

 

Everything work fine except support of LSI  9211-8i controler. I use it on my old xpenology project. 

 

that's mpt2sas.ko, this driver is not part of jun's extra.lzma inside of 1.03a2

i need bnx2x that is also not part of jun's package so if i'm starting to try to compile drivers i will do other too so mpt2sas will be part of it

 

Edited by IG-88
  • Like 1

Share this post


Link to post
Share on other sites
1 час назад, IG-88 сказал:

just the old beta 6.2 was released

 

that's just the point (22259branch)

 

#Celeron N3150

tested to boot:  ok

tested to video hardware transcode:  ~ok

 

hw transcode  

918c.thumb.png.b7f4f890da39d69f29a8e7d6e97df6d0.png

Hide 
Edited by Архип
  • Like 1

Share this post


Link to post
Share on other sites
22 minutes ago, Архип said:

that's just the point (22259branch)

 

i guess thats what jun used for his additional drivers, as long as there ist nothing else i will try to make drivers from this

i do have a 9211-8i controller for testing and my bcm 10G card (bnx2x) so i will know if it does work or not and as with the 6.1 drivers i will need feedback from others

 

 

Quote

#Celeron N3150

 

already in my list for now

Edited by IG-88
  • Like 2

Share this post


Link to post
Share on other sites
В 25.06.2018 в 00:29, Архип сказал:

 

that's just the point (22259branch)

 

#Celeron N3150

tested to boot:  ok

tested to video hardware transcode:  ~ok

 

hw transcode

918c.thumb.png.b7f4f890da39d69f29a8e7d6e97df6d0.png

Hide

 

Good day, what you think, Skylake G4400 and H110 maybe this can work? 

 

Share this post


Link to post
Share on other sites

Good sound bare metal i7-4790 with z97-k, install and work good, but if first reboot, stop and cant init onboard lan, I power off, add cheap realtek and boot is OK.

 

Jun you is best of the best. I need test all options. I write later about what working.

 

image.thumb.png.6c8e3288268041591687d834dae112b7.png

Share this post


Link to post
Share on other sites

If I unplug vga cable, keyboard and mouse from bare metal, system is down. I thinks USB ID list crash.

Share this post


Link to post
Share on other sites
7 hours ago, vortexxx said:

Good day, what you think, Skylake G4400 and H110 maybe this can work? 

 

there is already a skylake in my list (i5-6500) so i guess it will work, if hardware transcoding can be used is a different matter

Share this post


Link to post
Share on other sites
58 minutes ago, IG-88 said:

 

there is already a skylake in my list (i5-6500) so i guess it will work, if hardware transcoding can be used is a different matter

 

It works on my Kaby Lake processor, and Skylake/Kaby Lake are basically identical.  I don't have QuickSync model however, so can't address transcoding questions.

Share this post


Link to post
Share on other sites

Because my NAS install DSM 6.2 automatically, it's not visible on my net, now :-(

So, I'm very impatient to read about you !

Thanks for your wonderful work !

Best regards

Share this post


Link to post
Share on other sites
Because my NAS install DSM 6.2 automatically, it's not visible on my net, now :-(
So, I'm very impatient to read about you !
Thanks for your wonderful work !
Best regards
As far as I know your system is bricked. Major releases such as going from 6.1 to 6.2 almost always cause problems.

Always check the forums before doing any updates. Thus far, we need a loader specifically for 6.2 compatibility.

Sent from my ONEPLUS A5000 using Tapatalk

Share this post


Link to post
Share on other sites

Hello,

 

bootloader 1.03a2 does NOT work on my HP MicroServ GEN8 with Intel Xeon E3-1220L neither on the original Celeron CPU.

 

FYI :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.