pmchan

Members
  • Content count

    16
  • Joined

  • Last visited

  • Days Won

    3

pmchan last won the day on August 29

pmchan had the most liked content!

Community Reputation

3 Neutral

About pmchan

  • Rank
    Newbie
  1. Yes, it was my first option too, but then I discovered my D-Link DIR868L router doesn't handle VPN tunneling , even with the latest Tomato by Shibby v140 firmware. I don't want to buy a new one or keep another device powered just for this job, so port forwarding will do for some time et merci pour ton travail
  2. OK, just tried it, WOL port 22 is not linked to ssh port so you can change it for better security and do a port forward to 22 on the router only for wake on wan.
  3. You're right, it was only for testing and the external port (internet side) was not 22. But I'm not very fond of the idea of making my router available from the web, too If I modify the SSH default port 22 in configuration/terminal, does it also change the WOL port or is it still 22? If WOL stays at 22 when SSH is a different port, this should be a good solution?
  4. Q1900-itx on 6.1.3 U3 here, I don't use power schedule but did run a test few minutes ago and it's working. Are you sure you don't have any other scheduled task interfering?
  5. OK, I did some more tests and it definitely works, I can even Wake On Wan with android app "Wol wake On Lan Wan" (redirect to port 22), DSM 6.1.3 U3.
  6. already did it in the Q1900-itx topic.
  7. Thank you for your reply, I finally found a way to make WOL work on my Asrock Q1900-itx running 6.1.3 U3.
  8. WOL finally works! I've created a short script saved in a file I named ETH0wake.sh and placed it in usr/local/etc/rc.d, along with S99PowersavingIntel.sh and S99ZZZ_Shutdown.sh. The content is very simple, enables (at boot and stop) the wakeup flag of the Q1900 LAN which was always "disabled" for me, you can test by typing: cat /sys/class/net/eth0/device/power/wakeup and the "ethtool -s eth0 wol g" to force enable WOL at boot and stop. I really suck at scripts and I know it's not a good idea to put sudo command, but it works for me, so you could try on your own Q1900 or other hardware if WOL is not working. If someone with good knowledge can make it better, that would be awesome! so, go to the rc.d folder by ssh, then "vi ETH0wake.sh", type "i" to switch to edit mode and copy/paste the following content: #!/bin/sh case $1 in start) sudo sh -c "echo enabled > /sys/class/net/eth0/device/power/wakeup " sudo ethtool -s eth0 wol g ;; stop) sudo sh -c "echo enabled > /sys/class/net/eth0/device/power/wakeup " sudo ethtool -s eth0 wol g ;; esac then hit "ESC", type ":wq" and give 755 permissions to the file. It works for me, I did test with DS Finder on my smartphone but I suppose it works too with my tomato router WOL menu, hope it will be the same for other Q1900 owners.
  9. Hello, regarding WOL, did you also have to modify the synoinfo.conf file, as explained in this S99ZZZ_Shutdown.sh how-to? I'm not using the same hardware (asrock Q1900-itx) but my WOL isn't working and I'm trying to understand why. Thank you for your help!
  10. Working on my Q1900-ITX too (6.1.3 U3), but some apps, like Plex, may prevent HDD hibernation. If it's the reason why yours can't hibernate, you could create scheduled tasks to stop and launch those apps during the night so HDDs can sleep too I did it for Plex and the logs clearly list HDD hibernation few minutes after it stopped.
  11. nothing special, just update in corresponding DSM section.
  12. updated DSM to 6.1.3-15152 Update 3 without problems so far, I'm very pleased with this little Q1900, only missing feature at the moment is WOL, I can't make it works with S99ZZZshutdown.sh Can anyone confirm it's working in DSM 6.1.3 and is it the right way to do it?
  13. Sure, here it is: remember to enable speedstep in Bios, I'm not sure for C1-C7 state and C1E but I enabled those two and it works OK.
  14. Oh, another thing that bugs me, I have random system logs "System started counting down to shutdown", is it normal thing? I have only enabled disk sleep (20 minutes) but not automatic shutdown.
  15. I didn't change the SataPortMap, just plugged 2 SATA drives and it worked (lucky me), but I suppose you found the real culprit with this power issue. Regarding the CPU power states, I followed the S99PowersavingINTEL howto and it seems to work as it should, it varies from 1993Mhz to 1328Mhz and I set speedstep to enable, C State to C1 and C1E enabled, don't know if il was the right thing to do..? The last thing not working is WOL and I didn't look the powerswitch script yet... But so far, so good!