Leaderboard


Popular Content

Showing content with the highest reputation on 10/09/2019 in all areas

  1. 1 point
    Hi, everyone, Thanks for you patience. A new ds918 loader support 6.2/6.21 is uploaded. whats new: uefi issue fixed. i915 driver updated. link https://mega.nz/#F!Fgk01YoT!7fN9Uxe4lpzZWPLXPMONMA (for DS918+) - v1.04b ---Beginning of addition by polanskiman--- link https://mega.nz/#!OV4gVKyZ!dCgfXx1bgAOyvbFwFiov3s7RSNoFuqnAcNmSllLoUiw (for DS3615xs) - v1.03b link https://mega.nz/#!zcogjaDT!qIEazI49daggE2odvSwazn3VqBc_wv0zAvab6m6kHbA (for DS3617xs) - v1.03b Please read this topic to know what loader to chose: ---End of addition by polanskiman---
  2. 1 point
    this is the first (experiential?) test version of the driver extension for loader 1.04b and 918+ DSM 6.2.2 packages for 1.03b and 3615/3617 are coming (need to get a "older" hardware tor testing, my new B360M/G5400 testsystem did seem to freeze when loading the kernel with 1.03b, even no serial console output after starting loading the kernel) tested as fresh install with 1.04b loader with DSM 6.2.2, there are extra.lzma and extra2.lzma in the zip file - you need both - the "extra2" file is used when booting the 1st time and under normal working conditions the extra.lzma is used (i guess also normal updates - jun left no notes about that so i had to find out and guess) hardware in my test system used additional driver: r8168, igb, e1000e, bnx2x, tn40xx, mpt2sas the rest of the drivers just loads without any comment on my system, i've seen drivers crashing only when real hardware is present so be warned extra.lzma/extra2.lzma for loader 1.04b ds918+ DSM 6.2.2 v0.6_test http://s000.tinyupload.com/?file_id=29784352988385987676 !!! still network limit in 1.04b loader for 918+ !!! atm 918+ has a limit of 2 nic's (as the original hardware) if there are more then 2 nic's present and you can't find your system in network then you will have to try after boot witch nic is "active" (not necessarily the onboard) or remove additional nic's and look for this after installation you can change the synoinfo.conf after install to support more then 2 nic's (with 3615/17 it was 8 and keep in mind when doing a major update it will be reset to 2 and you will have manually change this again, same as when you change for more disk as there are in jun's default setting) - more info's are already in the old thread about 918+ DSM 6.2.(0) i might change that later so it will be set the same way as more disks are set by jun's patch - syno's max disk default for this hardware was 4 disks but jun's pach changes it on boot to 16!!! (so if you have 6+8 sata ports then you should not have problems when updating like you used to have with 3615/17) i will extend here to what is in the old thread for 6.2 had but atm i'm more willing to add 3615/17 support basically what is on the old page is valid, so no sata_*, pata_* drivers here the driver in the test version listed as kernel modules the old thread as reference !!! especially read "Other things good to know about DS918+ image and loader 1.03a2:" its still valid for 1.04b loader !!!
  3. 1 point
    Long time user of Xpenology under ESXi on older hardware. Started a new baremetal build with new hardware and thought I'd share my experiences. Haven't been able to find anyone using the B365 chipset so thought I'd give it a go and report on functionality. CPU = Intel i5-9400 Motherboard = Asrock B365M Pro4 Micro ATX RAM = 16GB HyperX Fury 2666Mhz (2x 8GB) NIC = HP NC360T PCIe (Dual Intel NIC) USB = Sandisk Cruzer Fit 8GB Will be recycling old hardware in but not there yet, just validating new hardware. HBA = LSI 9201-16i 16 port PCIe (IT mode) Hard Drives = 8x 3TB Seagate Enterprise Drives, 4x 256GB SSD (Brand escapes me at the moment) Case = Fractal Node 804 The Good All basic functionality worked, out of box. Using 918+ 1.04b loader booted and performed install, no issues. UEFI boot works. Patched to latest build via GUI without issues. Powers off, reboots and WOL all working perfectly. (Had issues on some old hardware) Cold boots fast with no delays. (have read other experienced long boot times) Didn't need to tweak BIOS settings at all for first boot. I did subsequently go back and tuned some BIOS settings as follows. Disabled onboard NIC (I219V, knew it wasn't going to work), disabled onboard audio and wifi/bluetooth (no module installed anyway), disabled C1E state. CPU temp is monitored in Xpenology (Have had issues before with some hardware reading sensor) Seems to have full fan control with all options available but requires further validation. Again hasn't worked with some older hardware I've used but that may not be surprise to other users. CPU/Cores recognised and report accurately thanks to FOXBI's "ch_cpuinfo.tar" mod. VMM works and detected CPU & core correctly. Quick built a Win server 2016, powered on and booted fine. I only ran it for about 15 minutes but looked and worked well. With MB, CPU, RAM, PCIe NIC Card and 1 SSD connected and booted to Xpenology, seems to idle around 20w power usage but will confirm with more accurate meter. The Bad Onboard NIC is not recognised. As with all newer motherboards, the Intel I219V is not recognised, I knew it wouldn't, but have a stack of old PCIe Intel NICs so no issue for me. Hardware transcoding looks to be an issue. Cannot get /dev/dri folder to appear. Have done some BIOS settings with the GPU, to no avail. Have tried i915.alpha_support=1 in the GRUB file to no avail. To be fair, there seems to be little info on this setting and I'm probably putting it in the wrong location. I will troubleshoot further and advise. Was really a nice-to-have for me as I run separate Intel NUC for Plex, which handles the transcoding role well. That's probably it for now, from a couple of hours testing last night, so pretty pleased so far. If people are interested, I'll continue to update thread as further testing and commissioning occurs. Cheers.
  4. 1 point
    SUCCESS!!! I now have access to my data! mdadm --assemble --force --run /dev/md2 /dev/sdg5 /dev/sdh5 /dev/sdi5 /dev/sdk5 /dev/sdl5 /dev/sdm5 /dev/sdj5 /dev/sdn5 -v vgchange -a y vg1000 lvm lvchange -ay /dev/mapper/vg1000-lv mount /volume1 was the magic commands. Any ideas on how to re-create the Meta-data of Shared Folders? I can see in the log that it was removed after reboot following the crash.
  5. 1 point
    Look up the real3x mod to disable the faulty i915 video driver, the combination you are proposing works fine.
  6. 1 point
    i hope next weekend last thing i remember from last year is that i compiled some of this but people got nowhere with it because the kernel options in the synology kernel where not set (we cant change the kernel), but we might try later again atm i want to do the drivers for 3615/17, then some newer versions of drivers people need
  7. 1 point
    Hello! I am xpenology user. And I am an IT engineer who creates shell scripts as hobbies. Please understand that it is written by a google translate site. because i’m korean who is not fluent in English. I created a tool to change cpu information for Xpenology’s users. Modify the actual cpu name and cores of your pc or server. Howto Run ============================================================= 1. Download attached file on your PC (ch_cpuinfo.tar) (ch_cpuinfo_en.tar) / (ch_cpuinfo_kr.tar is file for korean) 2. Upload file to your DSM location (by filestation, sftp, webdav etc....) 3. Connect to ssh by admin account. (dsm > control panel > terminal & snmp > terminal > enable ssh check) 4. Switch user to root: sudo su - (input admin password) 5. Change directory to where ch_cpuinfo.tar file is located: cd /volume1/temp 6. Decompress file & check file: tar xvf ch_cpuinfo.tar ls -lrt (check root’s run auth) 7. Run to Binary file ./ch_cpuinfo or ./ch_cpuinfo.sh (If you use busybox in DSM 5.x, you can use it as a source file) 8. When you execute it, proceed according to the description that is output. 9. Check your DSM’s CPU name, CPU cores at “information center” ==================================================== Addtional, Adjust binary to excute file made by shc(http://www.datsi.fi.upm.es/~frosal) The tool does not inclue worms, bad code. If you want to edit the CPU information yourself manually, please refer to the contents below. ——————————————————————————————————————————————————————————————— Location : /usr/syno/synoman/webman/modules/AdminCenter Source : admin_center.js / admin_center.js.gz(above 6.2) Add Before -> if(Ext.isDefined(h.cpu_vendor)&&Ext.isDefined(h.cpu_family)&&Ext.isDefined(h.cpu_series)){ o.push([_T("status","cpu_model_name"),String.format("{0} {1} {2}",h.cpu_vendor,h.cpu_family,h.cpu_series)])} if(Ext.isDefined(h.cpu_cores)){o.push([_T("status","cpu_cores"),h.cpu_cores])} Add contents: h.cpu_vendor="Intel";h.cpu_family="Xeon";h.cpu_series="E3-1220 V3";h.cpu_cores="4 Cores (1 CPU/4 Cores | 4 Threads)"; h.cpu_detail="<a href='https://ark.intel.com/content/www/us/en/ark/search.html?_charset_=UTF-8&q=E3-1220 V3' target=_blank>detail</a>" Change contens: String.format("{0} {1} {2}",h.cpu_vendor,h.cpu_family,h.cpu_series) to String.format("{0} {1} {2} {3}",h.cpu_vendor,h.cpu_family,h.cpu_series,h.cpu_detail) ——————————————————————————————————————————————————————————————— Finally, All descriptions are based on version 6.2, and the actual executable file supports both 5.x and 6.x. Publish the source through github(https://github.com/FOXBI/ch_cpuinfo). For versions DSM 6.x and later, you can use the binary as before. If you use busybox in DSM 5.x, you can use it as a source file(ch_cpuinfo.sh). Please contact me by comment or bug report, i’ll respond to you as much as possible within my ability. Test & Made Environment ———————————————————————————————————— Base Server : HP ML310e v2 gen8 + VMware ESXi 6.0 + RDM DSM : 6.2.2-24922 Update 2 (DS3615xs/DS3617xs/918+) 6.1-15284 Update 2 (DS3615xs) Base Server : Intel E5-2630 v2 + VMware ESXi 6.7u2 DSM : 6.2.2-24922 Update 2 (DS3617xs) ———————————————————————————————————— Change Log 1. Support DSM 6.2.2-24922 Update 2 2. Consolidate and change to run in accordance with used DSM language environment(Only One File) 3. Add link for cpu detail information(Intel, AMD Site Link) - Support above version 6.x Thank you!! Have a nice day!! ============================================= Download links: ch_cpuinfo ver 1.1.0-r01 - new version update -> ch_cpuinfo.tar Reference images # 1.04b + DS918+ # 1.03b + DS3615xs # 1.03b + DS3617xs # Normal output is possible even when using more than 8core.
  8. 1 point
    Don't bother with the Synology package its far too limiting, do the steps below and you can run as many Wordpress sites as you like on your NAS: - Install MariaDB package, set the root password. - Install phpmyadmin and create your Wordpress database. - Then create a shared folder, set the permissions to include local group http. - Then download the Wordpress install zip from Wordpress.org. - Unzip it directly into the shared folder you created. - Copy all the contents of the Wordpress folder into the root of the shared folder. - Open Web Station - Create a new virtual server and point it to your new shared folder - Connect to whatever you called your virtualserver - The Wordpress setup page will appear - The only thing that you need to know that's special from here is on Synology your host address for MariaDB is this format to use in the Wordpress install: 127.0.0.1:/run/mysqld/mysqld10.sock Thats it, as long as you create virtual server names that are unique you can create as many Wordpress sites as you like. Note; in order to automatically upgrade Wordpress or install plugins via the GUI you will need to chmod +x the shared folder you created.
  9. 1 point
    OK, that was a stupid question (maybe every body could guess it??? ) I restarded my NAS and eveything is fine now 🙈
  10. 1 point
    Стратегически правильное решение не заниматься костылями, а поставить сетевуху Intel или HP и юзать без виртуализации... Я отказался от виртуальной DSM когда попробовал пробросить диски и попытался покрутить бесперебойник к EXSI по USB... После этого я понял что такой гемморой не для меня...
  11. 1 point
    1) Uninstall Video Station 2) Install Docker 3) Install Plex or Emby or Jellyfin 4) profit