HP Proliant N54L installation loop - can't get it working.


Recommended Posts

H,
I spent few hours struggling with DSM installation, I have tried versions 6.2.3 and 6.2.1 (with juns bootloader 1.03b) 6.1 with 1.02b and finally wend down to 6.02 with 1.01.
Last one I tried with both normal and AMD modes (in newer bootloaders there is no AMD option).
I have Csomething switched off in my BIOS. I have Intel PCIE Gigabit card and I have noted it MAC address and used in in grub config each time I tried.
Also VID and PID noted and changed in grub config according to that what I found in device manager for my usb dongle.
Before each next try I took HDD out, and and wiped out previous installation. 
I also tried two different USB sticks - to be sure if it's not the issue.
This also didn't help. 

Unfortunately each time result was the same. After initial setup (partitioning, uploading DSM) machine reboots and instead of next steps of installation, I see just counter going down to 0:00 ... nothing else. If I refresh the page, I see option to migrate ... so actually to restart installation.

I did try everything suggested in loop installation topic already. I have no idea what it can be.

On the screen I see Booting kernel image and nothing more - it stuck on that - however, initial installation page is accessible still.
I'm frustrated a bit - I bought this server specially for that purpose - to upgrade from my ancient Synology DS509+ and now I feel it can't be done.

Do you have any ideas maybe? 
Thanks,
A
 

Link to post
Share on other sites

The N54L works with DSM 6.2.3 with an intel NIC. Disable the mainboard integrated nic on the BIOS.

 

Prepare the Boolloader 1.03b and execute the installation from the scratch, you can  install by default leaving the DSM assistant download the last image from internet.

Link to post
Share on other sites

The N54L works on 6.2.3 with either the onboard nic or a compatible Intel nic.

The display should "freeze" after putting up the messages about booting the kernel. That's normal. As you know, a "real" Synology doesn't have a monitor

When you put the Intel nic in, did you turn the onboard one off?

 

And.. when you get the page offering to migrate, does that page also give you further information? Sometimes it may say that you are migrating from an earlier release or a different machine?

Link to post
Share on other sites

Thanks for your replies,
In terms of switching internalNIC off, I could not find that switch in the BIOS. There is only witch in Boot tab - that can switch on/off booting from internal NIC.  
I didn't know that internal NIC is supported, so I used external one (which was already fitted by previous server owner). 

I reed somewhere that it can be important which SATA port is used, and that first disk should be connected to first port.
In Microserver there is one big port that split into 4 bays - I tried first and last. Should I try the others?
Maybe I should use 3617 instead of 3615?

Page offering migration has nothing else. You can choose from between two options migrate with keeping data or do migrate with wiping data off.
 If I use find.synology.com - NAS is being found, but it says that status is: Configuration Lost. If I connect I can only migrate/reinstall.

My hardware is HP Proliant microserver with AMD Turion II Neo N54L  2.2Ghz , 6GB RAM

Could someone point to exact files that I should download and use for installation? 
Maybe I should use different extras file?
 

Link to post
Share on other sites

Great thanks,
As I don't know French, I have to use google translation - which confuses me - I'm not sure if I have BIOS 041-2011 what should I do? Should I flash with which BIOS file ?

Link to post
Share on other sites

I've updated BIOS to modded one, set everything as on the screens, prepared 1.03b bootloader, downloaded DSM6.2.3 from linked topic, and ... nothing. Still the same. After uploading machine reboots, and go back to initial installer screen. No prompt for username/password as expected.

I think that boot process is initiated, as HDD LED flashes for several seconds as when data are loading, but on some point it stops - it looks it stuck on some point - before installation web service is changed to DSM.

 

Edited by amikot
Link to post
Share on other sites

Are you using onboard nic?

I recently configured one n54l with onboard nic only, it works. if it is enabled make sure you have both nic's mac address on grub.

after installation check with the mobile app fing if the server is online on some ip and test the lan cable on both ports.

and are you using an extra file? you don't need it.

Also try not using the dsm file you downloaded, let the installer download latest version.

Link to post
Share on other sites

No ... onboard NIC is switched off in the BIOS. 
I'm using Intel based PCIe card that was inserted by previous owner.
I did try to load from the network - the same problem.
Now I removed that PCI card and I'm going to try internal NIC - just need to get MAC and generate new loader. 

I removed PCIe card and tried using Atheros onboard NIC - apart of front LED activity didn't notice anything new. :( 

Edited by amikot
Link to post
Share on other sites

Yes, device is getting DHCP. The issue is not with network connection.
The issue is that booting is not passing early installer stage - where you can connect via IP:5000 to upload DSM file. 
Whole problem is that I can't go beyond that point. It is installing than server automatically reboot and that's it. I have to use find tool again and I see device with status: Configuration lost. And only what I can do is to start installation again. 

Only other ideas I have are to try different hard drive for installation and to take one of memory DIMMs out... as maybe it's RAM related error.

The machine itself works - I booted Linux Mint from USB stick without any issue.
It must be something, but what? and worst thing is that there is no any debug information.
Is there any way to switch debug on to see what's happening during the boot?

Edited by amikot
Link to post
Share on other sites

I have AHCI enabled.
RAM is not the case - tested both modules.
Now I'm doing backup of another HDD to get it for tests, as my last chance is that it's HDD's fault.
It can be HDD as 2TB disk is discovered by BIOS as 200.0GB - is that normal?
Both Windows and DS509+ sees it as 2TB, and it's nothing unusual - its normal WD Green 2TB.
Now I'm going to test Seagate Barracuda 1TB, but if it's HDD issue, I'm a bit worried, I have SHR of 4x2TB disks mixed types - I don't even want to think about that. :(

 

Link to post
Share on other sites

OK - so problem solved.

Everything was caused by HDD - 2TB WD Green that I used for installation.
I was always thinking that WD and Seagate hard drives are reliable and should work with any controller - always trusted them more than to Toshiba, Hitachi etc. That actually are probably just rebranded - and unknown origins.
My Raid setup is based on two Seagate Pipelines 2TB and one WD RED 2TB. WD Green was just an spare in case if one of three mentioned would fail.

I was hoping I will be able to use my old disks, now I'm not sure - what if they wont work? 
If as simple drive, as WD Green 2TB can't work here - what drives should I use?
Is that exact drive faulty? Or is that controllers fault? Or what?
 

Link to post
Share on other sites
On 2/8/2021 at 2:59 AM, amikot said:

but not as bootable for DSM

Just "jumping in" before reading the complete topic:

The *only* bootable drive, is your USB drive holding the bootloader.

None of the HDD's are "bootable for DSM".

Link to post
Share on other sites
14 hours ago, bearcat said:

Just "jumping in" before reading the complete topic:

The *only* bootable drive, is your USB drive holding the bootloader.

None of the HDD's are "bootable for DSM".

You're right and wrong at the same time. For BIOS only USB stick is bootable, but from USB stick we load bootloader which is booting Synology OS (called DSM) from HDD.
My problem was with that second booting - after bootloader from USB was already loaded.
Situation is actually similar to modded consoles - some consoles could be soft-modded when custom bootloader was loaded from CD prior booting actual game from CD/DVD or hard-modded when custom bootloader was flashed into the console, or fitted as additional chip.
 

14 hours ago, scoobdriver said:

Also check C1E is disabled in the bios, when I built my N54L I remember this been required . 

 

Edit - didn't read the entire thread.. see you have it working now ! .. 


"Have" it's to early to say :)
I'm waiting for another disks that are about to arrive today - then I will be able to install DSM and set everything UP.

 

Link to post
Share on other sites
10 hours ago, amikot said:

You're right and wrong at the same time...

Let's just agree to disagree ;-) the USB boots the bootloader, the bootloader loads DSM

And since I have at least 7 HP G7 Microservers. home and at friends, running XPE flawlessly, since DSM 4.x, in addition to a handfull others

no need to tell me that Synologys OS is called DSM. 

 

All the best of luck to get your G7 up and running 100% 👍

Link to post
Share on other sites

Sorry, I have sometimes a bit annoying style ;)
Of course I believe you have lots of experience - I'm the noob here. :P 
In case of getting G7 up and running - second disk arrived faulty/damaged. Seller wrapped it just into bubble envelope and nothing else, so it would be miracle if it would survive.
I bought another disk from local seller, so have it tested. Unfortunately, the third one WDGreen (that I had problems earlier) - I tested it looking for bad sectors and found plenty - so that was the reason. I have 4 NAS dedicated disks in total, but I have not enough to fill two NAS drives at the same time. So I have to improvise.
Anyway ... tonight it will happen ;), so soon will report. 

  • Like 1
Link to post
Share on other sites

Going a bit OT, then in days of old and "real" IBM mainframes, there was a hardwired process to start the machine called Initial Program Load. There were dials on the console so that you could dial in the address of the IPL device (card, tape or disk) and press a button to load all of 24 bytes into memory (starting at address 0). Those 24 bytes contained the code to load the operating system - which needed to be loaded to address 0. So the first thing the 24 bytes would do is to copy themselves into "high" memory and branch to the copy. This left room for it to load the OS.

This initial code was called a bootstrap loader because it "pulled itself up by its bootstraps" into high memory.

Today hardware is "soft" but we still "boot" our machines and we still have "bootloaders"

Edited by billat29
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.