Possible bricked HP Gen 8. Need advice.


Recommended Posts

Several years ago I snagged  the Gen8 and discovered xpenology. I dont really understand what I am doing but followed a tutorial and successfully got Bootloader running on micro SD inside the box, first go. Worked very well. Installed Plex to manage media and had DSM 5.2-5644.5 running. (DS3615xs).

I started to get messages about DSM being out of date but ignored it. I really didn't want to change something that was working especially as i don't know what I am doing. 

Recently though, Plex was insistent I had to update DSM. Foolishly I clicked the button. Advice was to go to 6.0.3-8754 then onto update 8. OK so I clicked install without checking here.

Now I cant access the NAS.  

So last few weeks I have been searching through the forums trying to figure out what to do, I am really going to need some help here.

Seems my options are;-

1. Use Ubuntu on either CD or USB stick and then a) clear the system partition, b) change the version (DSM?), c) something else.

2. Use SSH via puTTY to a) reset DSM config or b) reset to reinstall DSM.

3. Do a fresh install with current best DSM version (6.1.xx ?)

Any advice on simplest option as I will need specific instructions for any of these.

I have attached the  config file from the SD card.

 

Thanks

 

syslinux.cfg

Link to post
Share on other sites

you could just follow the guide here

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

 

instead of loader 1.02b for dsm 6.1 use loader 1.03b for ds3615 and install the latest dsm 6.2.3, ignore anything about driver problems related to dsm 6.2.2, thats "fixed" with 6.2.3, just use the loader as it comes and modify the grub.cfg (serial and mac of the nic are optional, can be changed later if needed, mac is only needed for wake on lan)

 

these are the most sources of trouble when installing on a microserver gen8

 

- disable C1E in bios


- micro sd card reader usb VID 0x0424 PID 0x4030 (when using a usb flash drive to boot it needs to be the vid/pid it that instead of the vid/pid of the micro sd card reader)


- delete the folder ".xpenoboot" in root of filesystem when present (login via ssh using putty, use admin account set in webgui and elevate your rights with "sudo -i" berfore trying to delete it)

https://xpenology.com/forum/topic/30171-upgrade-from-617-to-623-bare-metal-hp-n54l/

 

as of the big change in version you will need to reinstall most of you plugins

Link to post
Share on other sites

ok, looks terrifying.

I tried to see the Gen8 on my Router LAN but cant see it. If I disconnect/reconnect LAN cable nothing happens.

The HP is currently just in a loop attempting to boot from CD then hard drive then NIC. I get a message about exiting broadcom PXE. 

I typed the last known IP (10.1.1.51) into putty and it timed out.

Is the C1E setting in the HP BIOS?

Oddly the vid/pid i have on my existing micro sd card cfg file is 0x0EA0/0x2168. what's that? 

Should I just go through the steps in the tutorial with 1.03b loader, install dsm 6.2.3 and take it from there? 

How do I do that if i cant connect to the box?

Sorry, i don't know what I'm doing.

Thanks for assistance.

 

 

Link to post
Share on other sites

First of all, IG-88 is the guru as their signature says. I just stumble around here :-).

You trashed your SD card when you attempted the upgrade. The HP needs to boot the loader from the card and the loader can then bring up the DSM system which is resident on the system partition of all your disks.

SO you need to do two things:

1) You need to create a new bootloader which must match the version of DSM you are trying to run. Until you do that we are not going anywhere

2) If you plan to upgrade directly to 6.2.3, you must find and delete the /.xpenoboot directory first. If you have no system, then you must boot something else, mount the RAID array and delete from the system partition (looks like /dev/sda1).

 

One other piece of information is that on my older box (Gen7), 6.17 worked just fine without deleting that directory, So my different advice would be to upgrade to 6.1.7 and get your system running.

And then you can delete .xpenoboot and upgrade to 6.2.3, Twice the work, but the "same" steps twice.

 

 

...more

 

 

 

Link to post
Share on other sites

Some answers:

C1E (or C1) is a BIOS setting. It needs to be set to disable on my AMD based Gen7 machine otherwise my loader does not boot (no xpenology messages on console). Might not be a requirement on your Intel G8. Go and have a look and disable it if you find it.

 

vid stands for vendor id and pid is product id. They are properties of the card you are going to boot from. You need to follow the tutorial to identify them and put them in the cfg file on the loader you are creating otherwise your DSM system won't start. If you are going to overwrite your existing SD card, then you can use the same values as before. You can also use the mac and sn from from the cfg file you posted earlier.

 

So go and do that. You have to make a decision whether you want to go "my" way and do an intermediate upgrade to 6.1.7 or take IG-88's advice and go in one step.

If you are going to 6.1.7, you need the1.02b DS3615xs loader

If you are going to 6.2.3 you need the 1.03b  DS3615xs loader AND the HP must be booting in BIOS rather than UEFI mode (if there is such a thing on that box),

 

 

Link to post
Share on other sites

Boot the HP when you've done that. You need to see some messages from the loader on the console and then connect to the box from your PC  with Synology Assistant or find.synology.com.

Report back on the options that it shows.

Link to post
Share on other sites

well I got as far as this but then I couldn't connect with http://find.synology.com/ or synology assistant. 

 

 image.thumb.png.578581c66d27661f808b924c43178f57.png

 

When I get here, which option do i want, I wasnt sure and it just timed out and I assume first option was selected.

image.thumb.png.e5aee0bdf64ae99d9238821bcdbc6302.png

 

I'm just going to go around again and make sure everything is correct. Nearly there. (i think)

Link to post
Share on other sites

Progress.

Try option 2. You will need to press and hold the down key just in advance of the menu coming up. Then you will have time to select the correct option.

Or use the instructions in the FAQ to amend the timeout in the bootloader.

If that works and you can connect this time, then I am expecting that you can download the 6.1.7 .pat file and do a manual install keeping your configuration,

Link to post
Share on other sites

OK got it running. Big thanks to you guys.

I chickened out and went for v6.1.7. followed the tutorial, edited the grub file with VID/PID 0x0424/0x04030 for the HP Gen8 internal SD card slot. Also refreshed the S/N (this seems to change daily), entered NIC1 MAC.

At first it would not run at all, it was bypassing the SD card even though I had it 1st in boot order. I googled and did 2 things, changed power management settings from "performance" to "balanced" and also pulled power cord out for 1 minute. Then it ran, I selected Reinstall then I could see it with the assistant etc. Updated DSM and now got access to all my media. 

I just need to make sure it is reliable.

Should I risk updating again? v6.2.3?

Might just enjoy for now.

Link to post
Share on other sites

Excellent!

My plan was to get you to a stable platform so that you could easily SSH in and remove the .xpenoboot directory before jumping to the latest stable release, 6.2.3.

You can stop and enjoy some movies but I suggest you plan some time to make the move before you forget how to do an upgrade.

But do the bit about the directory removal now. Upgrade when you are ready.

Link to post
Share on other sites

I tried rebooting again. I pulled the power cord and left it for a few minutes this time and it has booted up OK.

I have a feeling there is a bit more to be done.

 

Next problem is getting Plex to see my media correctly.

 

dries my eyes

Link to post
Share on other sites
23 hours ago, hcardle said:

well i had to try rebooting the NAS and its still bust. It isnt seeing the SD card and goes off in a loop trying to boot from CD, Hard drive then NIC. 

if the sd card is to much trouble maybe a simple usb flash drive works reliable? there are smaller version that only stick out a few milometers

Edited by IG-88
Link to post
Share on other sites

Its still working OK. Later on I will shut down instead of rebooting and then switch it on again and see if that works OK. if it does I will just stay with the SD card.

If I do need to change to USB flash drive what is the VID/PID i need to use?

Could the SD boot issue be due to ".xpenoboot" folder? Should I delete this?

 

PS I also got Plex working, now i can access my media and also see it across the network. Its such a pain to configure.

Thanks again.

Might get brave and try the 6.2.3 version  (later). What's the benefit?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.