vtrchan

Trial of Nanoboot (4493) - 5.0.3.1

Recommended Posts

With the NanoBoot-5.0.2.2 release my network card Realtek 8111 has stopped working.

When you boot into the update mode, Synology Assistant recognizes my system and assigns an IP. After installing the .pat file and rebooting to the normal mode, network card stops working. Booting with 'rmmod=r8168,r8169_new insmod=r8169' command doesn't help.

With the NanoBoot-5.0.2.1 release everything worked well.

Share this post


Link to post
Share on other sites

Why do you need to run Nanoboot in upgrade mode when upgrading Nanoboot? To upgrade Nanoboot, just copy the boot image to a USB drive and boot your system. You only need to run Nanoboot in upgrade mode when installing an updated .pat file. Or are you saying you are updating Nanoboot and a new .pat file at the same time?

 

I solved my 8111F problem with 'rmmod=r8168,r8169_new insmod=r8169'

 

Do you know which kernel driver you were using under NanoBoot-5.0.2.1? SSH in when running NanoBoot-5.0.2.1 and run 'lspci -v'

 

My system showed me I was running r8169 and that's why 'rmmod=r8168,r8169_new insmod=r8169' worked for me. Others were telling me to run with 'rmmod=r8169,r8169_new insmod=r8168'

 

My NIC was giving me trouble for both Nanoboot and gnoBoot, until I tried insmod=r8169. Trantor's builds had always worked on this particular motherboard but he doesn't have a DSM 5 release.

Share this post


Link to post
Share on other sites

Hi,

I'm using gnoboot 10.5 with adaptec 3805 raid controller.

Can I use this nanoboot with adaptec 3805 raid controller? When I test with nanoboot, hard disks didn't detect.

Thanks.

Share this post


Link to post
Share on other sites

I´ve installed latest DSM and Nanoboot native on a HP54L.

Question: can i simple edit menu_nano.lst

 

kernel /zImage ihd_num=0 netif_num=4 syno_hw_version=DS3612xs sn=xxxxxxxxx vid=0x0EA0 pid=0x2168 loglevel=0 vga=0x305

 

with my usb stick vid and pid to hide the stick in the dsm? I don´t found syslinux.cfg in the native img file.

Share this post


Link to post
Share on other sites

is there any way to have r8192u for usb dlink dwa 130 rev b ?

on nanoboot.

 

cause kernel doesnt work :/ (on last release)

 

thx

Share this post


Link to post
Share on other sites
Hi,

I was previously trying to run gnoBoot on XenServer. Any chance you could add Xen virt drivers in future build? Currently nanoboot cant find NICs and HDDs..

 

http://wiki.xenproject.org/wiki/Mainlin ... mU_Support

 

There might be another issue, virtualized HDD will be /dev/xvda.. /dev/xvdb .. etc.. instead of /dev/sda ...

 

If needed I can provide testing, etc..

 

Thank you

 

 

+1

 

There's even a standard configuration for Synology KVM builds in the kernel! But my kernel build does not seem to start. I will investigate that, if I have some time to spare.

 

Even though it's currently possible to run DSM with decent performance on a Xen domU, virtio drivers are still missing in the Nanoboot build. That means you need to turn on Veridian virtualisation and HVM (instead of PV).

 

Here's a cut down version of my XL configuration:

 

builder = 'hvm'
name = "synology"
memory = 4096
vcpus = 2
# Nanboot image (first; read-only) and some virtual disk as boot disk to install apps to them
disk = ['file:/etc/xen/images/nanoboot/latest.img,hda,r','file:/etc/xen/images/synology.img,hdb,w']
#boot = 'dc'
vif = [ 'mac=00:16:3E:58:D7:8A,bridge=xenbr0,model=e1000' ]
# No virtio tty (=console) drivers => Use VNC as a console replacement
vnc = 1
# ACPI and APIC events
acpi=1
apic=1
# Windows virtualization
viridian =1
# PCI passthrough of an Intel SATA controller to get physical disk control
xen_platform_pci=1
pci = ['00:1f.2']

Share this post


Link to post
Share on other sites

Hello Guys,

 

Im currently using Trantor Nanoboot on a DS3612xs using the beta version of the DSM 5.0 4418.

 

How can i go about upgrading to 4493?

 

Thank you.

Share this post


Link to post
Share on other sites

Please stop referring to Nanoboot as Trantor Nanoboot. Nanoboot is made by Sancome

 

https://translate.googleusercontent.com ... 7-ya4kumFw

 

Trantor has been nice enough to host the files on his site because the hosting sites used by Sancome had been slow and problematic.

 

Edit:

I reread your posts. Are you asking to upgrade from Trantor DSM 5.0-4418 Beta to Trantor DSM 5.0-4493? You can't. Trantor has not released any update to DSM 5.0-4418 Beta.

 

You can upgrade from Trantor DSM 5.0 4418 Beta to Nanoboot 5.0.3.1 DSM 5.0-4493

Edited by Guest

Share this post


Link to post
Share on other sites

Has nanobot 5.0.3.1 enable ACPI in kernel and module button.ko ?

In my nano 5.0.2 this module no existis, propably Sacome forgot enable ACPI in cfg file before compiling this version :smile:

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Yes you can. It's the same line. I think you got my image which uses grub instead of syslinux.

 

Yes you´re right, it´s the image from your site. Thank you :wink: .

Share this post


Link to post
Share on other sites

Hi!

 

I wonder which is the easiest way to upgrade form Nanoboot 5.0.1.4 to 5.0.3.1?

 

Currently im running Nanoboot 5.0.1.4 on a native N54L. Everything works fine, including my DVB-C Terratec Syncergy HTC Stick with TVHeadend.

I wanted to upgrade from DSM 5.0-4482 to 4493, but the inline upgrade didn't work. I guess Nanoboot 5.0.3.1 is required right?

 

Is it safe/possible to perform the following?

 

- create/boot from new nanoboot stick (5.0.3.1)

- inline upgrade to from 4482 to 4493

 

thx in advance

-c

Edited by Guest

Share this post


Link to post
Share on other sites

sorry, i confused the versions... of course i meant 5.0.3.1 .... i corrected it in the original post

Share this post


Link to post
Share on other sites

any support in nanoboot for broadcom (now qlogic) net extreme II 10 gig adapter like 57710? possible to add?

Share this post


Link to post
Share on other sites

Hello all,

I recently updated from gnoboot to latest nanoboot with DSM 4493 but I noticed a decrease of my network speed.

Before update a copy from my HP N40L was 120MBs approx and now 70-75MBs :sad:

Any idea ?

It's not critical but annoying.

Thanks guys.

Share this post


Link to post
Share on other sites

I've recently upgraded from Trantor DSM 4.3-3810 to Nanoboot DSM 5.0-4493 Update 1.

Is there any way to check if disk hibernation works?

In Trantor 4.3 it was shown in journal log, in 5.0 there is no messages about hibernation.

Is it OK or means hibernation not working?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.