Jump to content
XPEnology Community

Trouble with install on HP Compaq 8300 SFF


Recommended Posts

I am trying to install Xpenology with the bootloader v1.03b (ds3617xs) for DSM 6.2 (Baremetal).  Everything goes well and i get the happy hacking screen but i cannot find it with the synology assistant.


Just on a whim i tried Genesys modified bootloader v1.02b (ds3617xs) with MBR partition Table and it works perfectly fine. The problem is the DSM cannot be updated to 6.2.


I am good at following instructions, but not the most technical. I have updated the HP to the latest BIOS and still have the same results.


Any insights?  Also the cpu is a i5-3570, 16 GB Ram installed, and intel NIC


I may just stay with 6.1, but the fact that the normal loader is not working may affect further updates??



Link to comment
Share on other sites

On 2/2/2019 at 12:28 PM, b889 said:

I may just stay with 6.1, but the fact that the normal loader is not working may affect further updates??


There is nothing wrong with 6.1.7, it's fully supported by Synology and will be for some time.  I'm sure you understand you cannot upgrade the DSM to 6.2 without using 1.03b loader.

That said, I can't see any reason you cannot use 1.03b and DS3615 as your chipset NIC (Q77 Intel 82579LM/82579V Gigabit Ethernet) is supported by e1000e which is what is required.


16 minutes ago, b889 said:

flyride, i tried the DS3615 as well, didn't work


I actually have one of these in my office that I was making ready to sell... I might try to do an install on it just to prove it works.  But I think you might be making a mistake somewhere.

Link to comment
Share on other sites

10 часов назад, b889 сказал:

or else i saw a video on compiling the bootloader with other drivers... i may try that.

Compiled drivers don't work on 6.2.1 (syno signed own drivers, and only they can be loaded).

Edited by Olegin
Link to comment
Share on other sites

11 hours ago, djsoundround said:

I had the same problem with this pc hp 8300sff is the bios the problem !. impossible to boot legacy 1.03b.    1.02 no problem

in force the bios in legacy in 1.03b. it does not recognize the usb boot


This seems to be the case.  I retried the 1.03b with 3615xs, and got the same thing, i get the happy hacking screen, but no ip detected.


ill stick with 1.02b and DSM 6.1.7.


Thanks for everyone's help!!



Link to comment
Share on other sites

  • 3 months later...


I would like to take up the problem again. I have an HP Compaq Elite 8300 PC. If I create a USB flash drive with the Loader 1.03b DS3617, I can only boot it in UEFI, but it must be booted in Legacy BIOS. As soon as I start in Legacy BIOS the system told that no bootable medium can be found. I have already installed the latest BIOS update. Does anyone have a solution for me?

Excuse me for my english.

Link to comment
Share on other sites

Been there. Elite 8300 PITA of a system to set up Xpenology.
Someone on the forum sugested Hybrid partition usb working.
Found it, credit goes to "Mitja"

Use 1.03b ds3615 (maybe 3617 works, but 3615 is prefered).

You MUST create "HYBRID" partition bootable usb for HP Compaq Elite 8300.
Using it myself, update from 6.2.1 to 6.2.2 or clean install of latest 6.2.2 working perfect.

Allow me to make it easyer for you:


PART 1. preparation:

-Download: "gdisk-windows-1.0.4.zip" (for windows) or appropriate one for other systems from here

-unzip content to folder (in the instructions bellow I unziped it in folder named "a" and copied that folder to root of a C disk)

-in the BIOS of the HP Compaq Elite 8300 turn OFF UEFI boot by going to boot menu and press (I think) "F5" while UEFI option is highlighted,
 this will disable PC to default to UEFI boot on restart or powering on after power off.

-in option ROM loading menu set all to legacy (storage, gpu, network)


-on the working pc create standard clean usb with 1.03b - ds3615xs as usual

 leave it in the PC when done.


-go to computer manager/disk managment (right click "My Computer" or "This PC" select "Manage" then "disk managment")


  note your USB key disk number ( Disk 0 is usually system partition). Please be carefull and double check!
  in the down listed commands the USB Key is "Disk 2" , copy/paste commands to lets say notepad, and CHANGE to match your situation
  (including for folder "a" in a root off a C disk if you didnt do it that way).


PART 2. creating HYBRID partition USB Key-
"gdisk-windows-1.0.4.zip" unziped to folder "a" in root of a C disk, USB KEY is "Disk 2" - !!!ALTER THIS TO MATCH YOUR SITUATION!!!

first command "cd c:\a"  - "a" represents folder named "a" and location in root (C:\) of a C disk - !!!ALTER THIS TO MATCH YOUR SITUATION!!!

second command: "gdisk64 2:" - nr.64 represents 64bit system is running on, if you use 32bit system use #gdisk32 2:"
 -nr.2 represents Disk 2 on the system - !!!ALTER THIS TO MATCH YOUR SITUATION!!!

-open command prompt as admin

           List of commands as per situation above (64bit sys, gdisk in folder "a" root C, USB is "Disk 2") press ENTER after each one of course:--------------------------------------

cd c:\a

gdisk64 2:




1 2 3











Now window will probably pop up asking you to format the drive,
DO NOT DO IT!! Safely remove USB and put it in Elite 8300 and You are ready to go.

This way created USB is harder to reformat and use again.
Best way I found is to use free version of "MiniTool Partition Wizard" , first rebuild MBR whitin the
program then delete partitions one by one (apply betwen each operation).
I am sure you manage it and find best way if you need to reformat and reuse USB Key.

Sorry for my English, not native speaker....
Good Luck!!

Edited by jamkiki72
  • Like 2
  • Thanks 5
Link to comment
Share on other sites


you are the best. With the help of your post I could solve my problem and boot from the USB stick. I installed 3617 and it's working. Only under info is a wrong CPU displayed, is it a problem? Is it possible for me to update to the latest version?

Link to comment
Share on other sites

Glad It worked for You!
Wrong CPU displayed is just cosmetic issue.

You can install or upgrade to the latest 6.2.2-24922 (I use it on 8300).


If you asking about future updates - no one knows.

Keep eye on DSM update threads or if you feeling lucky, you can try for yourself and report to those threads.


Best way is to have one spare HDD and USB stick with DSM which is same as
your main syno box and when update comes unplug all disks and usb, put only that spare HDD and
USB and check if it works after update. If it does, replug main HDD(s) and USB then update that.
I do it that way.

Link to comment
Share on other sites

  • 2 weeks later...

I confirm that jamkiki72 and Mitja's methods also work on a Lenovo m82 SFF desktop!!


Just migrated a ds3615 installation from a Dell Optiplex 990 Midi tower to an m82 running DSM 6.2.2-24922.


I spent all eveneing yesterday trying to make it work. 6.1 / 1.02 worked flawlessly everytime, 6.2/1.03 didn't


Disabled all uefi boot options, switched to legacy an boom! instantly online!!


Thank all for your good work!

Link to comment
Share on other sites

  • 8 months later...

I don't quite understand why you use a hyper terminal.
1. create a normal bootable usb-stick with the looder
2.use the program gdisk-windows and work through the described points. alternatively, these points can also be executed on a Linux computer.

Link to comment
Share on other sites

2 hours ago, Pengo said:

I don't quite understand why you use a hyper terminal.

because of the serial connection/console to monitor the boot process - the things you can't see on a display

most people might use putty but any terminal will do


7 hours ago, lexx57 said:

I dont understand how we a making this

did you try the mbr loader from here?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...