Jump to content
XPEnology Community

Drivers requests for DSM 6.2


Recommended Posts

  • 1 month later...

Can someone add a driver for the AOC-SAS2LP-MV8

 

It uses the: Marvell 88SE9485

 

The driver can be found here: https://www.supermicro.com/wftp/driver/SAS/Marvell/MV8/SAS2/Driver/Linux/

 

I tried manually injecting, using the driver for marvell on this thread, and all the versions of the extra drivers posted with no luck 😕 

insmod complains about symbols and refuses to load, help?

Link to comment
Share on other sites

On 10/12/2018 at 4:32 PM, fa2k said:

please try this one...

Marvel_SATA.zip

 

@fa2k I am getting this error when loading through insmod, any ideas?

 

[ 2484.614966] ahci: version magic '3.10.105 SMP mod_unload ' should be '4.4.59+ SMP preempt mod_unload '

[ 2558.588455] sata_mv: version magic '3.10.105 SMP mod_unload ' should be '4.4.59+ SMP preempt mod_unload '

[ 2562.630399] libahci: version magic '3.10.105 SMP mod_unload ' should be '4.4.59+ SMP preempt mod_unload '

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...
  • 2 weeks later...
  • 3 weeks later...
  • 2 weeks later...

hello!

I got ioDrive2 from ebay on 1.2Tb - its PCIe Enterprise ssd but with stupid drivers.

On windows no proplem - just instal and use.

But I dream about use it on xpenology )

May be someone already use this awesome device?

Here drivers for some *nix systems (need registration)

https://link.westerndigital.com/enterprisesupport/software-download.html

but I don't understand how to start this device under DSM.

I don't need it's as volume1 with system... may be just mount in some directory.

Can someone help?

Thanks!

Edited by BoyNG
Link to comment
Share on other sites

On 8/3/2018 at 8:48 AM, hanulis said:

Need virtio_net driver for QEMU/Proxmox.

 

Thank you.

 

This is a very old request from 2018

 

Does anyone know if there is a with support for a 1.03b bootloader with VIRTIO drivers?

I need this in order to get better LAN performance using Xpenology as a VM on Unraid server

 

Link to comment
Share on other sites

On 4/20/2020 at 5:25 PM, casperse said:

Does anyone know if there is a with support for a 1.03b bootloader with VIRTIO drivers?

I need this in order to get better LAN performance using Xpenology as a VM on Unraid server

virtio dirver are in my 6.2.2 driver extension but dont get loaded automatically

i will do now drivers for 6.2.3 with new released 24922 kernel source

how much experiace you have with kvm?

as i got not much feedback yout the drivers in 6.2.2 i was planing to do a special version for kvm where virtio is loaded

willing to test? the get in contact be PM and i will send you a test version

 

Edited by IG-88
  • Thanks 1
Link to comment
Share on other sites

7 hours ago, IG-88 said:

virtio dirver are in my 6.2.2 driver extension but dont get loaded automatically

i will do now drivers for 6.2.3 with new released 24922 kernel source

how much experiace you have with kvm?

as i got not much feedback yout the drivers in 6.2.2 i was planing to do a special version for kvm where virtio is loaded

willing to test? the get in contact be PM and i will send you a test version

 

 

I have an xpenology vm in proxmox and only using e1000e at this moment, i can test your special version for kvm too. i am want to have virtio then my xpenology is perfect. with my test cluster i can easy test with some vms.

Link to comment
Share on other sites

On 4/23/2020 at 12:17 AM, IG-88 said:

virtio dirver are in my 6.2.2 driver extension but dont get loaded automatically

i will do now drivers for 6.2.3 with new released 24922 kernel source

how much experiace you have with kvm?

as i got not much feedback yout the drivers in 6.2.2 i was planing to do a special version for kvm where virtio is loaded

willing to test? the get in contact be PM and i will send you a test version

 

Yes I would really like to test it just PM me with a link and I will go to work testing! :-)

Link to comment
Share on other sites

Hi there, I am wondering if you can help me to get my Intel® Dual Band Wireless-AC 3160 to work on DMS918+, I did search around see others request for it as well but got no answer.
Is it even possible with that? Sorry that I have no idea about linux. Here's some link for files and informations I got seems related to it, see if somebody can work on it and make it works. 
Any help would be appreciated. Thanks

 

https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html
https://github.com/zerotier/edge/tree/master/lib/modules/4.19.1zerotier/kernel/drivers/net/wireless/intel/iwlwifi

 


My system running loader 1.04b for DSM_DS918+ 6.2.3_25423

Hardware details:
Zotac ZBOX CI320 nano Plus

Intel®Celeron® N2930 
Intel® Dual Band Wireless-AC 3160
DDR3L-SDRAM 8GB
60GB SSD

 

ci320.thumb.jpg.a1231ae0e5ffd777f1ac7a4ee0f6cbeb.jpg

 

iwlmvm.ko iwldvm.ko iwlwifi.ko iwlwifi-3160-14.ucode

Link to comment
Share on other sites

25 minutes ago, snajper said:

Please don't laught on this.

just sniggering and shaking my had in disbelieve ;-)

 

 

26 minutes ago, snajper said:

r8101: 10/100 Realtek PCIe FE Family RTL8101E

 

https://xpenology.com/forum/topic/21663-driver-extension-jun-103b104b-for-dsm622-for-3615xs-3617xs-918/

if you open the extra.lzma you will find that there is already a r8101.ko - why ask for a driver if its already there?

 

On 5/7/2020 at 8:09 PM, ioeg1221 said:

AMD Opteron(tm) X3421 APU driver

just out of curiosity, what driver would that be and what do you plan to do with it

Link to comment
Share on other sites

On 5/15/2020 at 3:22 AM, IG-88 said:

just sniggering and shaking my had in disbelieve ;-)

 

 

 

 

if you open the extra.lzma you will find that there is already a r8101.ko - why ask for a driver if its already there?

 

just out of curiosity, what driver would that be and what do you plan to do with it

 transcoding

Link to comment
Share on other sites

5 minutes ago, ioeg1221 said:

transcoding

yes, that much was my guess but what kind of software layer would you use (pretty sure its not intel qsv) and what packages would be needed in addition (like you will need additional libs when wanting to use vdpau from nvidia), its not like you can just install it with apt-get if you have a driver

Edited by IG-88
Link to comment
Share on other sites

Hello guys,

 

I buyed dell poweredge T620 with Raid controller PERC LSI SYMBIOS logic H710 PCIE adapter, i tryed some versions loaders and dsm and spend full weekend to try on esxi 6.7... not sucesfull to view native hdds...

 

Can please add this driver for this raid controller card to next update? 

 

Thank you in advance

 

Link to comment
Share on other sites

1 hour ago, dlabanec said:

Can please add this driver for this raid controller card to next update?

(hardware)raid is not supported by DSM, it needs single disks, you need to install IT (initiator target) firmware instead of IR (it is shown in the bios what firmware is flashed, so look for IR/IT)

like here in a picture

https://forums.servethehome.com/index.php?threads/jbod-adventures-with-dell-perc-h710p-mini-lsi-2208.22019/

Usp3A3i.png&hash=8edc9021acbe9c7ce19d384

 

 

Link to comment
Share on other sites

 

Motherboard: Gigabyte GA-Z270M-D3H

NIC1: Intel GbE LAN chip (10/100/1000 Mbit) (On Board, should be Intel I219-V but not 100% sure since it's not mentioned except on Amazon)

NIC2: Cisco N12075 Broadcom BCM95709A0906G PCIe 4-port Gigabit Ethernet Network Card (4-port PCIE NIC) (Broadcom BCM5709C chip)

SATA Controller: ASM-1061 2 Port SATA Controller (No name brand)

 

Both NIC don't work, not sure about the SATA controller as I have no way to test it. These exact same hardware used to work on DSM 6.0.2-8451.

 

Thanks very much.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...