Recommended Posts

NO DOT INITIATE DISCUSSIONS OR ASK QUESTIONS BEYOND YOUR DRIVER REQUEST.
Such posts will be deleted without warning.

 

 

This topic is for requesting drivers for hardware (net, storage) which are not supported by XPEnology yet.

 

The purpose of this it to regroup drivers request in order to improve XPEnology compatibility. However, please note that there is absolutely no guarantee that any of these requests will be taken into consideration as this is done on people's free time. 

 

Please check the following 3 links before asking for any driver ! 

 

https://xpenology.com/forum/topic/12859-driver-extension-jun-103a2dsm62x-for-ds918/

https://xpenology.com/forum/topic/12867-user-reported-compatibility-thread-for-dsm-62/

https://xpenology.com/forum/forum/78-critical-updates/

 

Give the most detailed information as you can (brand, chip, revision...).

If you can test your hardware with ubuntu livecd to get modules infos and/or give manufacturer download link.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Need virtio_net driver for QEMU/Proxmox.

 

Thank you.

Edited by hanulis

Share this post


Link to post
Share on other sites

Hi team,  is possible to implement the same driver configuration of the DSM 6.x.x Loader (with MBR partition Table) is misisng the Intel PRO/1000 driver

 

Thanks

Share this post


Link to post
Share on other sites

Marvell storage driver:

mvsas: Marvell PCIe 88SE64XX (3Gb/s) and 88SE94XX 6Gbs) SAS/SATA support, HighPoint RocketRAID 2710/2720/2721/2722/2740/2744/2760

 

Thank you

Share this post


Link to post
Share on other sites
Posted (edited)

Loader DS3617 1.03b on a Dell R410 on board Network not working guess drivers are missing, I added an Intel dual lan card and I was able to update the system.   

to the latest 6.2-23739 update 2.

 

painkiller895@DSMv2410-127:/$ dmesg | grep "eth"
[    4.295929] usbcore: registered new interface driver ethub
[   18.736287] igb 0000:03:00.0: added PHC on eth0
[   18.736294] igb 0000:03:00.0: eth0: (PCIe:2.5GT/s:Width x4)
[   18.736297] igb 0000:03:00.0 eth0: MAC: 00:1b:21:a7:42:9c
[   18.736640] igb 0000:03:00.0: eth0: PBA No: G18758-001
[   18.900626] igb 0000:03:00.1: added PHC on eth1
[   18.900635] igb 0000:03:00.1: eth1: (PCIe:2.5GT/s:Width x4)
[   18.900638] igb 0000:03:00.1 eth1: MAC: 00:1b:21:a7:42:9d
[   18.900941] igb 0000:03:00.1: eth1: PBA No: G18758-001
[   20.237881] jme: JMicron JMC2XX ethernet driver version 1.0.8
[   20.304867] bnx2 0000:01:00.0 eth2: Broadcom NetXtreme II BCM5716 1000Base-T  (C0) PCI Express found at mem d8000000, IRQ 36, node addr 78:2b:cb:20:98:a7
[   20.305773] bnx2 0000:01:00.1 eth3: Broadcom NetXtreme II BCM5716 1000Base-T  (C0) PCI Express found at mem da000000, IRQ 48, node addr 78:2b:cb:20:98:a8
[   23.591877] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   24.221221] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   25.778307] igb 0000:03:00.0 eth0: igb: eth0 NIC Link is Up 1000 Mbps Full Du plex, Flow Control: None
[   25.778465] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
painkiller895@DSMv2410-127:/$

 

painkiller895@DSMv2410-127:/$  lspci -k | grep 'Kernel driver'
        Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: pcieport
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: ehci-pci
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: uhci_hcd
        Kernel driver in use: ehci-pci
        Kernel driver in use: lpc_ich
        Kernel driver in use: ahci
        Kernel driver in use: bnx2
        Kernel driver in use: bnx2
        Kernel driver in use: igb
        Kernel driver in use: igb
painkiller895@DSMv2410-127:/$

 

Looks like the bnx2 is missing a driver or file...

 

I also can not update my Dell R710 which uses the same.

Edited by Polanskiman
Added code tags

Share this post


Link to post
Share on other sites
On 8/3/2018 at 2:48 AM, hanulis said:

Need virtio_net driver for QEMU/Proxmox.

 

Thank you.

+1 

virtio_net driver for QEMU/KVM

Share this post


Link to post
Share on other sites
On 9/17/2018 at 5:54 AM, Jose said:

+1 

virtio_net driver for QEMU/KVM

+2

virtio_net driver for QEMU/KVM will be also useful for me.

I am using the unraid, which using RedHat KVM, I have to change the setting in xml, the network from  "<model type='virtio'/>" to the " <model type='e100'/>".

For the reason I don't understand, this setting will be reset every time I reboot the VM, so It will be best if it has driver for KVM.

Share this post


Link to post
Share on other sites

i have build some kernel modules for broadwell 6.2. I have checked all things related to virtio, AMD, Intel Net, Broadcom Net and many Media Drivers. Maybe you will find some useful modules.

Also i have build modules for TT-Budget S2-4200, SkyStar2 and SkystarHD.

 

When you get a error message regarding "missing symbols" then you had to load a dependent module before.

Broadwell_6.2_Kernel-Modules.zip

Edited by fa2k

Share this post


Link to post
Share on other sites

need 

Marvell storage driver: marvell 88SE9230 PCIe SATA 6Gb/s Controller

Share this post


Link to post
Share on other sites

needed

Marvell storage driver: Chipset: Marvell 88SE9230 PCIe SATA 6Gb/s Controller  for Loader  Jun 1.04b DS918+

Share this post


Link to post
Share on other sites

I Need the driver for the raid Controller of the HP ProLiant DL380 G7. This is the HP Smart Array P410i

 

thank you.

Share this post


Link to post
Share on other sites
20 hours ago, KryptonSERV said:

I Need the driver for the raid Controller of the HP ProLiant DL380 G7. This is the HP Smart Array P410i

 

thank you.

please try this one. Let me know if you cant load this modules.

hpsa.zip

Share this post


Link to post
Share on other sites

unzip, copy the files to filesystem of the filer and then

insmod /path/file.ko

Share this post


Link to post
Share on other sites
2 hours ago, charmzine said:

ALX : Atheros AR8161 Driver : Qualcomm Atheros AR816x/AR817x support

 

please...

you're welcome

alx.zip

Share this post


Link to post
Share on other sites

I'm use mainboard XFX 790i ultra SLI: in XPEnoboot 5.2-5967.1 SATA and NET driver are worked correctly

In Jun's loader 6.1 - v1.02b DS3615xs NET and SATA is not worked.

Please add NVIDIA nForce driver and JMicron SATA (i think driver from XPEnoboot 5.2-5967.1)

 

Thanks you.

Edited by narutoxboy

Share this post


Link to post
Share on other sites

The i915 driver can be changed? The one included in 1.04b crashes both system i’m testing (i3 6300 & nuc5i3)

 

 

Share this post


Link to post
Share on other sites

I have old machine and tried to load ata_piix.ko in dsm6.2 (DS3615ws) . but it didn't work (made coredump)..

I need ata-piix.ko in dsm6.2 . Thanks.

Edited by nymph

Share this post


Link to post
Share on other sites

Since there is a big userbase with HP Microserver G7,

it would be nice to have support for the builtin NIC, HP NC107i based on BCM5723.

It has been supported up until now, when 6.2.1 broke it.

Share this post


Link to post
Share on other sites

KVM/QEMU Drivers:

  • virtio
  • virtio_ring
  • virtio_scsi
  • virtio_pci
  • virtio_net

Intel Virtual Function Driver:

  • IXGBEVF

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now