Help me chose a quad-port GbE NIC, please


Recommended Posts

Hi,

 

As you could tell from the threads I started about issues with quad-port NICs from DeLock (Realtek RTL8111G), I am in a pretty annoying situation.

I am currently considering returning these cards and buy a different model.

The following cards are priced close enough and uses the BCM5719 chipset (AFAIU)

 

 - HP 331T (HPE 647594-B21)

 - ThinkSystem Broadcom 5719 1GbE RJ45 4-Port PCIe Ethernet Adapter

 

However, reading this, I wonder if it will work in ds3617xs with loader 1.03b.

Or would I need extra drivers?

Or wouldn't it work at all unless 918+ & 1.04b?

 

All the aforementioned NICs are PCIe2.0 x4

 

Cheaper alternatives include PCIe2.0 x1 but I was told to avoid these since the bandwidth could be limiting (although theoretically PCIe2.0 x1 is just enough for 4 GbE concurrent connections)

 - DeLock 89025 (based on Realtek RTL8111F)

 - Exsys 6084 (based on Realtek RTL8153B) !!"The Product is in PCIExpressform factor with a built-in USB3.1 (Gen 1)Host Controllerand 4 USB3.1 Gigabit Ethernet Converters to provide an instant expansion of 4Gigabit Ethernet ports for your Desktop, Server and Thin-Client computers."!!

 

Thank you very much in advance for your help.

 

Best,

-a-

Edited by asheenlevrai
Link to post
Share on other sites
  • asheenlevrai changed the title to Help me chose a quad-port GbE NIC, please
44 minutes ago, gadreel said:

I have this https://www.amazon.de/-/en/10Gtek®-Gigabit-PCIE-Network-I350-T4/dp/B01H6NE4X2/ref=sr_1_3?crid=1LDVHK8KG489E&dchild=1&keywords=i350-t4&qid=1626087365&sprefix=I350%2Caps%2C244&sr=8-3

 

I pass this through and never had an issue with it (DS918+). i350 chips was launched in 2011. I do not see any reason not to be supported.

@IG-88 do you know if this card would require any special drivers for 3617xs & 1.03b?

Link to post
Share on other sites
4 hours ago, asheenlevrai said:

do you know if this card would require any special drivers for 3617xs & 1.03b?

to be sure you would need to know pci vendor an product id

these are supported by the igb.ko driver (5.3.5.39) in the last published extra.lzma

17aa 1074  ThinkServer I350-T4 AnyFabric
8086 0001  Ethernet Server Adapter I350-T4
8086 0003  Ethernet Server Adapter I350-T4
8086 00a1  Ethernet Server Adapter I350-T4
8086 00a3  Ethernet Server Adapter I350-T4
8086 5001  Ethernet Server Adapter I350-T4

 

a more recent 2021 5.5.2 igb driver has one i350-T4 entry more

8086 00aa  Ethernet Network Adapter I350-T4 for OCP NIC 3.0

but thats a special version for .opencompute 3.0 spec, not relevant for your problem

 

so i guess it should work, if not with synology own driver in 6.2.3 u3 (igb.ko version 5.3.5.3, source ~5 years old?) then at least with the extra.lzma's newer driver

i had v5.3.5.4 around and that supports the following id's

17aa 1074  Lenovo ThinkServer I350-T4 AnyFabric
8086 0001  Ethernet Server Adapter I350-T4
8086 00a1  Ethernet Server Adapter I350-T4
8086 5001  Ethernet Server Adapter I350-T4
thats what is to expect to work ootb with 3617 6.2.3 u3

 

at least the extra.lzma it should work if your are unlucky and its a 8086:00a3

 

  • Like 1
Link to post
Share on other sites
37 minutes ago, IG-88 said:

to be sure you would need to know pci vendor an product id

 

@IG-88 does the below helps?

[8086:1521] 04:00.0 Ethernet controller: Intel Corporation I350 Gigabit Network Connection (rev 01)

 

Link to post
Share on other sites
2 hours ago, gadreel said:

[8086:1521] 04:00.0 Ethernet controller: Intel Corporation I350 Gigabit Network Connection (rev 01)

according to the pci.update file in the driver source thats just one of the main id's of i350, there should be sub id's like the one's from above

the sub id's might be there because of different phy chips (i guess), the 00a3 sub id not persent in the ootb driver is the only one (important) missing but present in the driver from my extra.lzma, if the card does not work ootb then try the extra.lzma with the newer driver

  • Like 1
Link to post
Share on other sites
On 7/12/2021 at 2:23 AM, asheenlevrai said:

Hi,

 

As you could tell from the threads I started about issues with quad-port NICs from DeLock (Realtek RTL8111G), I am in a pretty annoying situation.

I am currently considering returning these cards and buy a different model.

The following cards are priced close enough and uses the BCM5719 chipset (AFAIU)

 

 - HP 331T (HPE 647594-B21)

 - ThinkSystem Broadcom 5719 1GbE RJ45 4-Port PCIe Ethernet Adapter

 

However, reading this, I wonder if it will work in ds3617xs with loader 1.03b.

Or would I need extra drivers?

Or wouldn't it work at all unless 918+ & 1.04b?

 

All the aforementioned NICs are PCIe2.0 x4

 

Cheaper alternatives include PCIe2.0 x1 but I was told to avoid these since the bandwidth could be limiting (although theoretically PCIe2.0 x1 is just enough for 4 GbE concurrent connections)

 - DeLock 89025 (based on Realtek RTL8111F)

 - Exsys 6084 (based on Realtek RTL8153B) !!"The Product is in PCIExpressform factor with a built-in USB3.1 (Gen 1)Host Controllerand 4 USB3.1 Gigabit Ethernet Converters to provide an instant expansion of 4Gigabit Ethernet ports for your Desktop, Server and Thin-Client computers."!!

 

Thank you very much in advance for your help.

 

Best,

-a-

 

I was running HP card under 3615xs loader. This was a while ago, but I didn't need any drivers to make it work.

 

The card was:

HP 435508-B21

https://www.newegg.com/hp-435508-b21/p/N82E16816401074

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.