Sign in to follow this  
burg3r

DDNS + PhotoStation

Recommended Posts

Moin Moin, als frischer Besitzer einer DSLR bin ich aus den latschen gefallen wie übersichtlich und schnell die PhotoStation ist. Nur leider klappt bei mir der Zugriff von außerhalb nicht. Sowohl per "DS PhotoStation" auf meinem Android (welche im Lan mit IP Adresse funktioniert) als auch über die Oberfläche des Webbrowers. Also ich logge mich normal in der Oberfläche ein. Klicke auf die PhotoStation und dann kommt der 404er klassiker. Benutzt das Programm einen eigenen Port?

 

bin echt am verweifeln.

Share this post


Link to post
Share on other sites

Moin!

 

Benutzt Du den selben User wie auch im LAN?

 

Sind Deine Portfreigaben eingerichtet?

 

Benutzt Du einen DDNS Service? Probier mal Deine Direkte IP anzuwählen.

Share this post


Link to post
Share on other sites

Ich benutzte No-IP.com, also der normale zugriff von außen funktioniert. Auch die Portweiterleitung von meinem Router auf die Lokale IP und den richtigen Port funktioniert. Einzig und allein auf die PhotoStation kann ich von außen nicht zugreifen. Wenn ich mich von außen anmelde und wähle im DSM die PhotoStation aus kommt die 404.

Share this post


Link to post
Share on other sites

Die Photostation benutzt den normalen Port 80 oder 443 je nach dem ob http oder https

 

Habe gerade kein Xpenology laufen deswegen kann ich nicht nachschauen.

Share this post


Link to post
Share on other sites

Ist die Photostation über DSM Konten eingerichtet oder hat jeder User die eigene Photostation?

 

Kontrolliere die Rechte der Benutzer und die Einstellungen in der Photostation.

 

Greife mal als Admin auf Deine DS zu und schau was dann passiert.

 

Ansonsten noch:

 

DeineIP/photo

 

12.34.56.789/photo

 

So sollte der Zugriff klappen,wenn alles korrekt eingestellt ist.

 

filelink.lua?id=6b4f9899d1e5143d

 

 

filelink.lua?id=2ce700e21ab873ed

Share this post


Link to post
Share on other sites

Das interne klappt. Also

 

#lokale ip#/photo

 

aber von außen keine Chance.

 

#ddns adresse#/photo

 

Kann ja schlecht bei meinem Router eine Portweiterleitung einrichen über den port "photo". Ich muss dem Router genau saugen wenn von außen auf dem Port eine anfrage kommt auf welche interne IP es weitergeleitet werden soll. Auch meine versuche mit dem 80er Port sind fehlgeschlagen

Share this post


Link to post
Share on other sites

aber von außen keine Chance.

 

#ddns adresse#/photo

 

Versuche bitte deine externe IP die Du vom Anbieter bekommst. Vielleicht wird Deine DDNS Adresse nicht aufgelöst. Kannst Du aber auch auf dem Server sehen.

 

Unter :

 

Systemsteuerung>Externer Zugriff

 

Dort kannst Du den Status ablesen.

Share this post


Link to post
Share on other sites

die DDNS adresse wird richtig aufgelöst. der normale umgang mit FileStation und DSM über externen DDNS zugriff funktioniert ja. Nur die PhotoStation will nicht so recht

Share this post


Link to post
Share on other sites

Läuft es mittlerweile bei Dir??

 

Hier vielleicht die Lösung:

 

In DSM anmelden:

 

Systemsteuerung->Webdienste->HTTP-Dienst->Zusätzlichen HTTP-Port hinzufügen (Haken rein)-> dann z.B. 8080 einsetzen-> Übernehmen-> Neustart Server ---> Photostation App ausprobieren

Share this post


Link to post
Share on other sites

Der Aufruf von außen funktioniert nur ohne WWW also in die Adressleiste explizit von Hand eingeben http://deinedyndns.domain/photo gilt für fast alle Dienste also Mail/Audio/File. Wenn du es nicht explizit so eingibst, dann setzen die Browser irgendeine Kennung davor, mit der die DS nicht klar kommt.

Share this post


Link to post
Share on other sites

Ich hatte die gleichen Probleme. Bei mir läuft es aktuell mit folgendenden Einstellungen:

 

XPE DSM Einstellungen:

-Systemsteuerung--> Webdienste --> Webstation aktivieren (ist glaube ich eine Vorraussetzung für die Photostation)--> HTTPS Verbindung für Webdienste aktivieren--> SPDY aktivieren

-Systemsteuerung--> Netzwerk --> DSM Einstellungen ---> HTTPS Verbindung aktivieren--> HTTP Verbindungen automatisch zu HTTPS umleiten--> SPDY aktivieren

(Port habe ich erstmal auf Standard HTTP = 5000 und HTTPS = 5001 gelassen)

 

Fritzbox Portfreigabe:

-TCP Port 5000 bis 5000 an interne Diskstation IP an Port 5001 (ist ja der Standard HTTPS Port der Diskstation).

-TCP Port 443 (HTTPS Standardport) bis 443 an interne Diskstaion IP an Port 443.

 

zur Erklärung:

HTTPS wegen der Sicherheit. Da die Photostation normal über Port 80 (Standard Webport) läuft und den sollte man eigentlich nicht öffnen, müssen wir nach der HTTPs Aktivierung natürlich die Anfragen hierhin weiterleiten. Deshalb 443 auf 443 intern weiterleiten. Das Gleich auch bei der Umstellung für das Webinterface von 5000 auf 5001.

 

Somit kann aus der Ferne per https://deineDynDNSName:5000 das Webinterface aufrufen und über das Webinterface auch die Photostation starten. Um über die Synology Photo APP auf die Photostation zuzugreifen reicht HTTPS zu aktivieren, nur den DynDNS Namen als Adresse eintragen + Benutzer und PW. kein PORT!

Bei der File-APP musst du den den Port mit :5000 noch hinter deinen DynDNS Namen setzen, ansonsten gleiche Settings wie beim Login der Photo-App.

 

Hoffe ich konnte helfen

 

chill

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this