Which NIC works on DS3617xs ?


Recommended Posts

I've just build a new Xpenology box with AMD 4650G APU and Asus TUF GAMING B550M-PLUS mainboard
The internal NIC doesn't work even after replacing all the extra.lzma, zImage and rd.gz
I've got some USB & PCIe NICs and luckily one and only one USB card works
I'm now running Jun's loader 1.03b for DS3617xs and DSM 6.2.2
Everything seems fine but I do not want to run the box on a USB NIC
I want to purchase a new gigabit PCIe NIC but don't know which one will certainly work
Is there any suggestions? I'm not going to upgrade to 10Gbe anytime soon

 

I installed a M.2 NVMe SSD in the system but I couldn't install DSM into it
Is M.2 SSD can only be used as cache? Is there any work around to install DSM into it?

Thanks

Link to post
Share on other sites

Hi Katana,

My Supermicro mbrd (X11SSL-CF) has a Dual GbE LAN with Intel® i210-AT.  I know that it has always worked with Jun's DS3617xs loader 103b.

 

Edited by Rhubarb
Link to post
Share on other sites
On 8/8/2020 at 7:50 PM, Katana said:

Is there any suggestions?

any cheap intel based should do the job

it it needs to be "native" it gets more complicated to choose

https://xpenology.com/forum/topic/13922-guide-to-native-drivers-dsm-617-and-621-on-ds3615/

 

On 8/8/2020 at 7:50 PM, Katana said:

Is M.2 SSD can only be used as cache?

yes and only after patching and before updating dsm the cache support should be disabled

 

On 8/8/2020 at 7:50 PM, Katana said:

Is there any work around to install DSM into it?

not to install directly to it but you can create the partitions manually and integrate it it manually into a running system but thats not suggested and can break on updates

https://xpenology.com/forum/topic/13342-nvme-cache-support/?do=findComment&comment=151565

 

Link to post
Share on other sites
On 8/8/2020 at 10:50 AM, Katana said:

I want to purchase a new gigabit PCIe NIC but don't know which one will certainly work
 

I installed a M.2 NVMe SSD in the system but I couldn't install DSM into it
Is M.2 SSD can only be used as cache? Is there any work around to install DSM into it?

Thanks


Intel CT is the stalwart option for a PCIe card US$20 or less.  Ironically the newer the motherboard, the less likely the drivers will be able to address the onboard NIC.  extra.lzma can help but Intel enjoys changing PCI device ID's which breaks old drivers.

 

Other more functional option for NVMe SSD is to use a hypervisor and then bring in the SSD as an emulated SATA device (RDM or RAW in ESXi, for example).

Edited by flyride
Link to post
Share on other sites

Hi Katana 

FYI

I have the same issue with 1.03b and 3617 no nic will work also not with the extra.lzma but with 3615 and 1.03b loader without special extra.lma ll is working fine

I have tried with sfp+ intel 10gbit and mellanox sfp+ card on 3617 no nic is working.

 

When i try with 3617 with xeon 1240 v2  processor is there en advantage instead of 3615? with the 1.03b loader 

and is there a 10gbit sfp+ card who will work with 1.03b 3617 dsm 25426?

thank you

Michael  

 

Edited by nemesis122
Link to post
Share on other sites
2 hours ago, nemesis122 said:

When i try with 3617 with xeon 1240 v2  processor is there en advantage instead of 3615?

no this cpu has 4 cores and HT, 3615 can do up to 8 cores (8 real cores or 4+HT), the only difference would be newer lsi sas drivers in 3617

 

2 hours ago, nemesis122 said:

I have tried with sfp+ intel 10gbit and mellanox sfp+ card on 3617 no nic is working.

could you name the chip or card modells?

i update intel and realtek drivers from time to time, the additional extra.lzma should support most intel nic's and if needed i can do a refresh of a driver (i was planning to refresh the intel anyway but i dont have mach time lately)

 

Link to post
Share on other sites

Hi 

Voila 

 

Intel X520-DA1 10 Gigabit 10Gbps PCI-E E10G42BTDA Server Network Adapter only working with 1.03b 3615 

https://www.ebay.com/itm/Intel-X520-DA1-10-Gigabit-10Gbps-PCI-E-E10G42BTDA-Server-Network-Adapter/131847037922?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

 

____________________________________________________________________________________________________________________________________________________________

 

This one Mellanox is  only working with 3615 1.03b  25426 when the installtion is done with a intel nic and when the installtion is done you can switch to only this nic.means for the installtion both nic must be connected.

Mellanox MCX311A-XCAT CX311A ConnectX-3 EN 10G Ethernet 10GbE SFP+ PCI-E NIC

 

I have tried now with my mellanox adapter 1.03b 3617 no nic was found

 

@flyride is this the correct adapter for 3617 with 1.03b DSM 25426 ??

Mellanox MCX311A-XCAT CX311A ConnectX-3 EN 10G Ethernet 10GbE SFP+ PCI-E NIC

https://www.ebay.com/itm/Mellanox-MCX311A-XCAT-CX311A-ConnectX-3-EN-10G-Ethernet-10GbE-SFP-PCI-E-NIC/223088957450?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

 

edit:

I have tried now with my mellanox adapter 1.03b 3617 no nic was found

@flyride which Mellanox nic you exactly have link pls and thos one working with baremetall 1.03b 3617?? or do you mean with esxi?

thank you all

 

 

 

Edited by nemesis122
Link to post
Share on other sites
On 8/10/2020 at 7:51 PM, nemesis122 said:

Intel X520-DA1 10 Gigabit 10Gbps PCI-E E10G42BTDA Server Network Adapter only working with 1.03b 3615 

E10G42BTDA - i found it as X520-DA2 (dualport sfp+) , single port X520-DA1 would be E10G41BTDA

 

i guess it will be Intel 82599 Chipset for both, there might be different or newer phy chips involved, driver is ixgbe

pci vid/pid and its sub id's would be making it clear and it would be possible to check against the driver in the current extra.lzma

but  making new intel drivers is already on my list so you might check the additional driver 6.2.3 thread later for a newer driver and if that fails we could later check why and look for the vid(pid data

 

On 8/10/2020 at 7:51 PM, nemesis122 said:

@flyride is this the correct adapter for 3617 with 1.03b DSM 25426 ??

Mellanox MCX311A-XCAT CX311A ConnectX-3 EN 10G Ethernet 10GbE SFP+ PCI-E NIC

 

my extra.lzma for 3617 does not contain newer driver for mellanox cards as synology already has mlx4/mlx5 drivers in its dsm *.pat file so cx3 cards should work "native" with 3617

Link to post
Share on other sites
On 8/10/2020 at 10:51 AM, nemesis122 said:

 

@flyride is this the correct adapter for 3617 with 1.03b DSM 25426 ??

Mellanox MCX311A-XCAT CX311A ConnectX-3 EN 10G Ethernet 10GbE SFP+ PCI-E NIC

https://www.ebay.com/itm/Mellanox-MCX311A-XCAT-CX311A-ConnectX-3-EN-10G-Ethernet-10GbE-SFP-PCI-E-NIC/223088957450?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

 

edit:

I have tried now with my mellanox adapter 1.03b 3617 no nic was found

@flyride which Mellanox nic you exactly have link pls and thos one working with baremetall 1.03b 3617?? or do you mean with esxi?

thank you all

 

Yeah I have a couple of those.  The one in my server is the dual port version.  I run it passthrough on ESXi but that's the same thing as baremetal support. Is the secondary NIC though, along with another Gbps adapter though (in this case ESXi virtual Ethernet).

 

# lspci -k

0000:03:00.0 Class 0200: Device 15b3:1003
        Subsystem: Device 15b3:0049
        Kernel driver in use: mlx4_core


image.thumb.png.eda1011210fab69451d091634ac6cfc9.png

Edited by flyride
Link to post
Share on other sites
On 8/10/2020 at 7:51 PM, nemesis122 said:

I have tried now with my mellanox adapter 1.03b 3617 no nic was found

please provide a dmesg log, we could check if the pcie device is found and what the mlx driver has to say when its loading

(if you dont want to post the log here you can PM it to me)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.