iedwardos

phpVirtualbox на XPEnology

Recommended Posts

Добрый день! Суть проблемы. На версии 6.1.4 стоял такой  пакет "VirtualBox_x64_5.1.30-118389-1_(for 6.1.4).spk" скаченный  с итальянского репозитория по адресу http://spk.synologyitalia.com/index.php?fulllist=true

После обновления до версии 6.1.5 отказался работать и был удален. Попытки установить новую версию под 6.1.5 

 https://xpenology.com/forum/applications/core/interface/file/attachment.php?id=2194 не увенчались успехом. 

Есть у кого мысли, в какую сторону копать?

 

 

spk.jpg

spk0.jpg

spk1.jpg

Share this post


Link to post
Share on other sites

лог из файла var/log/synopkg.log

2018/02/14 09:45:39<--->install virtualbox 5.1.30-118389-1 Begin preinst
2018/02/14 09:45:39<--->install virtualbox 5.1.30-118389-1 End preinst ret=[1]
2018/02/14 09:45:39<--->install virtualbox 5.1.30-118389-1 Begin /bin/rm -rf /volume1/@tmp/pkginstall
2018/02/14 09:45:39<--->install virtualbox 5.1.30-118389-1 End /bin/rm -rf /volume1/@tmp/pkginstall ret=[0]
2018/02/14 09:45:39<--->install virtualbox 5.1.30-118389-1 failed

Edited by iedwardos

Share this post


Link to post
Share on other sites
В 15.02.2018 в 07:38, iedwardos сказал:

Спасибо, Ваша версия установилась и работает

Скажите, у вас эта версия стабильно работает? У меня установилась нормально и запустилась, но после ребута - Не удалось запустить службу. И некоторые пакеты также перестали запускаться, напр File station, Web station. После удаления Virtualbox и ребута, все пакеты запустились.

Edited by vitall10

Share this post


Link to post
Share on other sites

Работает стабильно. Правда я её обновил до последней.

Edited by iedwardos

Share this post


Link to post
Share on other sites

попытался поставить у меня выдает вот такое окно

Quote

An unknown PHP error occurred. This is most likely a syntax error in config.php in phpVirtualBox's folder. The most common errors are an unclosed quote or a missing semicolon in a configuration item that has been entered (e.g. location, username, or password).

Depending on your PHP configuration, navigating directly to config.php in your web browser may display the PHP error message.

If find that this is not the case, or have no idea what this error message means, please raise the issue at http://sourceforge.net/p/phpvirtualbox/discussion/help/

 

Share this post


Link to post
Share on other sites

включил, все вроде запустилось, начал ставить в виртуалку server2008, и в какой то момент наглухо все повисло, так что даже после рестарта Gen8 не могу войти рабочий стол DSM, да и по сети девайс пропал

 

Share this post


Link to post
Share on other sites

удалил эго к чертям через консоль

synopkg uninstall virtualbox

DSM заработал

Share this post


Link to post
Share on other sites

Я когда-то с ним тоже поипа.ся, крайне нестабильно работал. Щас на VMM и тьфу-тьфу-тьфу, никаких проблем (виртуалки на вынь10, бубунте, федоре и VDSM для полного комплекта).  

Share this post


Link to post
Share on other sites

у меня не хватает памяти для нормального запуска VMM - Gen 8 хочет ECC Unbuffered и с другой не работает в принципе.

А такая двольно дорогая, я попробовал поставить ECC Reg и одну ECC Unbuf одновременно, но какая то ерунда вышла

в iLO показычвает что 8+2гб при заргузке показывает что 2, в DSM показывает что 10, но 8 кем то зарезервировано.

VMM видит только 2. Пытаюсь сейчас купить пару планок по 8 ECC Unbuf по нормальной цене, чт обы не вышло что память будет стоить дороже самого сервера.

Share this post


Link to post
Share on other sites

Здравствуйте, подскажите, какой порт открыть, чтоб извне можно было подключиться к phpvirtualbox? Ссылка имеет вид http://ip_адрес/phpvirtualbox/ 

Share this post


Link to post
Share on other sites
6 часов назад, hellion сказал:

Рискну предположить, что 80

:7_sweat_smile:

Вообще все просто:) 

Share this post


Link to post
Share on other sites

Пакет VirtualBox_x64_5.0.40-115130-15254.spk не устанавливается на DSM 6.1.-15266 Может есть другая версия VirtualBox????

Share this post


Link to post
Share on other sites
19 минут назад, ZOV сказал:

VirtualBox_x64_5.0.40-115130-15254.spk не устанавливается на DSM 6.1.-15266

Под какую архитектуру нужно? Вот мануал как самому слепить.

Share this post


Link to post
Share on other sites

Очень глупый вопрос, как узнать какая у меня архитектура????:oops:

Share this post


Link to post
Share on other sites
Posted (edited)
7 минут назад, ZOV сказал:

Очень глупый вопрос, как узнать какая у меня архитектура????:oops:

3615, 3617 или 916?

Edited by Olegin

Share this post


Link to post
Share on other sites

Ой Ну это я знаю 3615

Share this post


Link to post
Share on other sites
2 минуты назад, ZOV сказал:

Ой Ну это я знаю 3615

Ну, значит bromolow.

Share this post


Link to post
Share on other sites
15 минут назад, Olegin сказал:

Под какую архитектуру нужно? Вот мануал как самому слепить.

это не нодо..

Надо просто в ...spk/scripts/installer.sh

поменять номер сборки ядра

expl:

REQUIRED_KERNEL_BUILD="15254" > REQUIRED_KERNEL_BUILD="15266"

Share this post


Link to post
Share on other sites
2 минуты назад, A.S._id сказал:

Надо просто в ...spk/scripts/installer.sh

поменять номер сборки ядра

expl:

REQUIRED_KERNEL_BUILD="15254" > REQUIRED_KERNEL_BUILD="15266"

Это для меня сложно. Буду наглым, может есть готовый пакет????

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now