vicrod74

HP EX495 network speed

Recommended Posts

Hello everyone,

This is my first post and I was wondering if someone can help me.

I recently converted my HP EX495 to Diskstation with the help of your forum. :mrgreen:

 

I was trying to upload some files and I discovered for some reason my network adapter is running at 100 Mbps when it it fully capable of 1000 Mbps.

 

I am currently running all gigabit setup including switch, router, and ethernet cable (CAT5e).

 

So I decided to dive into the SSH console to make changes using, Ethtool command. Here is the output:

 

[MyDiskstation> ethtool eth0
Settings for eth0:
       Supported ports: [ TP MII ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: Yes
       Advertised link modes:  10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Advertised pause frame use: Symmetric Receive-only
       Advertised auto-negotiation: Yes
       Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                            100baseT/Half 100baseT/Full
       Link partner advertised pause frame use: Symmetric Receive-only
       Link partner advertised auto-negotiation: Yes
       Speed: 100Mb/s
       Duplex: Full
       Port: MII
       PHYAD: 0
       Transceiver: internal
       Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
       Current message level: 0x00000033 (51)
                              drv probe ifdown ifup
       Link detected: yes

 

 

But when I try to run command to change the adapter speed to 1000 it doesn't let me.

 

here is what happens when i try to set it 1000:

 

Mydiskstation> ethtool -s Eth0 speed 1000
Cannot get current device settings: No such device
 not setting speed

 

So I am not sure why it is not letting change the link speed.

Could it be that it is using the wrong drivers?

 

Thanks for helping me out.

Share this post


Link to post
Share on other sites

Linux is case sensitive. Eth0 != eth0.

Not sure if that's the issue, but it doesn't hurt to try.

Share this post


Link to post
Share on other sites
Linux is case sensitive. Eth0 != eth0.

Not sure if that's the issue, but it doesn't hurt to try.

What he said.

sander@sander-laptop:~/docker/devbox(master)> ifconfig eth0
eth0      Link encap:Ethernet  HWaddr d8:9d:67:d4:b8:0c  
         UP BROADCAST MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000 
         RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
         Interrupt:17 Memory:d4700000-d4720000 

sander@sander-laptop:~/docker/devbox(master)> ifconfig Eth0
Eth0: error fetching interface information: Device not found

Share this post


Link to post
Share on other sites

Hi thanks for the correction on the eth0 syntax. I also discovered that I was logged in incorrectly. So I logged in using root and I was able to get elevated privileges.

 

A little more poking around with BusyBox and I found my LAN adapter to be Realtek 8111c, which does support gigabit speed. So my question - does XPEnoboot 5.25565.2 support Realtek 8111c LAN card in gigabit mode? Not sure if I should turn off auto negotiation and hard code to 1000 Mbps direct.

Share this post


Link to post
Share on other sites

Just a quick update...

 

It seems like kernel is loading RTL8169 drivers, which for whatever reason does not talk correctly to the gigabit controller. The current controller I have is a RTL8168.

 

Next steps -

 

- Download the Linux driver from RTL8168 from RealTek.

- rmod 8169 driver. (offending driver, :smile: )

- unload tar ball file from manufacturer and run autorun.sh with elevated privileges.

- check to see if driver has loaded after reboot with lsmod | grep 8168 command.

- if successful I will test transfer speeds and see how it goes.

 

But I have one issue - being that it is a headless system (no VGA, serial ports) I cannot make modifications via ssh console. It will boot me off and go crazy - I have to reboot system manually which is no good - it can damage my disks with improper shutdowns.

I will need full hardware access and my next option is to get a Debug Cable which I need to connect to the system board in order to access bios, VGA, and serial connections.

 

I will report my findings once i get the cable i need.

 

All of this to save money lol . :razz:

Share this post


Link to post
Share on other sites

Actually i think i spoke too soon. :mrgreen::mrgreen: I got the driver working although I did it via ssh and it knocked my connection out - it seem to run the script in the background and remove the 8169 driver too!! :mrgreen::mrgreen:

 

I noticed when I rebooted and check again just out of curiosity and bam! 1000 mbps was advertised on the Network Interface.

 

Here's the console output as proof:

 

BusyBox v1.16.1 (2015-05-11 02:57:09 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

MyDiskStation> ethtool eth0
Settings for eth0:
       Supported ports: [ TP MII ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: Yes
       Advertised link modes:  10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Advertised pause frame use: Symmetric Receive-only
       Advertised auto-negotiation: Yes
       Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                            100baseT/Half 100baseT/Full
                                            1000baseT/Full
       Link partner advertised pause frame use: Symmetric Receive-only
       Link partner advertised auto-negotiation: Yes
       Speed: 1000Mb/s
       Duplex: Full
       Port: MII
       PHYAD: 0
       Transceiver: internal
       Auto-negotiation: on
       Supports Wake-on: pumbg
       Wake-on: d
       Current message level: 0x00000033 (51)
                              drv probe ifdown ifup
       Link detected: yes

 

I tested the transfer speeds and i am getting transfer speeds upwards of 100 Mbps. Woo hoo!

 

Much better!! :grin: I am happy now!! :cool:

 

I will list the steps I took to do this when I have time, and also I am very surprised I do not need the console cable after all.

 

This can also work EX490 I presume.

Share this post


Link to post
Share on other sites

Can you write the commands you used to achieve this. It would help noobs like me. Thanks !

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Hi synapse007 and venimK, which HP systems you guys have? I will find some time this weekend to post how I did it.

 

Thanks!

Share this post


Link to post
Share on other sites
Actually i think i spoke too soon. :mrgreen::mrgreen: I got the driver working although I did it via ssh and it knocked my connection out - it seem to run the script in the background and remove the 8169 driver too!! :mrgreen::mrgreen:

 

I noticed when I rebooted and check again just out of curiosity and bam! 1000 mbps was advertised on the Network Interface.

 

Here's the console output as proof:

 

BusyBox v1.16.1 (2015-05-11 02:57:09 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

MyDiskStation> ethtool eth0
Settings for eth0:
       Supported ports: [ TP MII ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: Yes
       Advertised link modes:  10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Advertised pause frame use: Symmetric Receive-only
       Advertised auto-negotiation: Yes
       Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                            100baseT/Half 100baseT/Full
                                            1000baseT/Full
       Link partner advertised pause frame use: Symmetric Receive-only
       Link partner advertised auto-negotiation: Yes
       Speed: 1000Mb/s
       Duplex: Full
       Port: MII
       PHYAD: 0
       Transceiver: internal
       Auto-negotiation: on
       Supports Wake-on: pumbg
       Wake-on: d
       Current message level: 0x00000033 (51)
                              drv probe ifdown ifup
       Link detected: yes

 

I tested the transfer speeds and i am getting transfer speeds upwards of 100 Mbps. Woo hoo!

 

Much better!! :grin: I am happy now!! :cool:

 

I will list the steps I took to do this when I have time, and also I am very surprised I do not need the console cable after all.

 

This can also work EX490 I presume.

 

i own an ex490 and been running this since 2013.. you dont even have to do anything you posted, like a mac it just works.. im able to xfer @ 130 - 160+ MB/s yeah fast as hell so id like to assume MegaBytes is pretty damn fast a second through some cat6 on a green switch

Share this post


Link to post
Share on other sites

So I had a chance write down the steps I took to make the HP EX495 to run on 1000 Mbps instead of 100 Mbps. I am only referring to the HP EX495 headless server (no VGA port)

 

Original problem: Installation of XPenology will default to the R8169 driver instead of R8168 causing the server to use speed of 100 Mbps (too slow)

Solution: Manually install the R8168 driver from manufacturer so it can use the correct driver.

 

Prerequisites:

 

- USB drive (thumb drive) - any size ok.

- Access to your NAS via SSH protocol, normally port 22. Here is how to do it: http://forum.synology.com/wiki/index.php/Enabling_the_Command_Line_Interface

- SSH client like putty http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

- Login to your NAS as “root”.

 

Steps:

 

Place a spare USB drive on your computer and format it using FAT32 file system.

1. Download the 8168 drivers from RealTek Website. Here is the link:http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

2. Scroll down to UNIX (Linux) section and click on the Global link for Version 8.040 (first row).

3. Copy and paste “0002-r8168-8.040.00.tar.bz2” to the USB drive.

4. Remove the USB drive and place it on your XPEpenology NAS

5. SSH to your NAS via IP Address or Host name and port number, default is port 22.

6. Login as root and enter your password.

 

Run the following code at the command shell:

 

Shell> cd /volumeUSB2/usbshare
Shell> tar vjxf r8168-8.aaa.bb.tar.bz2
Shell> cd r8168-8.aa.bb
Shell> ./autorun.sh  

 

Note: Look for your USB drive folder – Normally it would be volumeUSB2 and up not USB1 (boot USB), make sure you have correct one.

 

At this point if you are using remote ssh client it will run the script to Makefile and install the drivers, but it will cause your connection to be lost. Wait about 5 minutes and hard shutdown your EX495 by holding the power button for a few seconds. Then boot up the EX495, in my case I have to remove SATA0 shortly so it can boot from USB for a few seconds then place SATA0 drive back on so it can continue to boot (Headless server, no VGA).

Once the EX495 has booted, go back to ssh console and verify that adapter is now on 1000 Mbps and not 100 Mbps.

 

Run the following code on the shell:

 

Shell>ethtool eth0

 

Scroll down to the line where you see Speed and make sure it reads “1000Mb/s, Duplex Full”.

 

Transfer a large file to your NAS over the wire and monitor the speed :wink:

 

I hope this is useful for some HP EX495 users.

Share this post


Link to post
Share on other sites
Then boot up the EX495, in my case I have to remove SATA0 shortly so it can boot from USB for a few seconds then place SATA0 drive back on so it can continue to boot (Headless server, no VGA).

How are you timing the removal and subsequent replacement of the hard drive for reliable full boot of Xpenology? This is the main thing that has been holding me back from converting my EX495.

Share this post


Link to post
Share on other sites
Then boot up the EX495, in my case I have to remove SATA0 shortly so it can boot from USB for a few seconds then place SATA0 drive back on so it can continue to boot (Headless server, no VGA).

How are you timing the removal and subsequent replacement of the hard drive for reliable full boot of Xpenology? This is the main thing that has been holding me back from converting my EX495.

 

 

Make sure your USB boot up is in the last one from the bottom in the back of the EX495. If you place the usb bootup drive in any other USB port, it will not work.

 

When booting up just make sure SATA-0 is unplugged before turning on. I would give about 7 seconds then plug the hard drive back in. It will continue to boot up from there.

 

I would also suggest if you do not know the IP address to look into your router and see what IP address you get for "DiskStation". To avoid further confusion on IP address, what I did was I made DHCP in my router give it the same IP address all the time from the exclusion list. Your router should be able to do this.

Share this post


Link to post
Share on other sites
So I had a chance write down the steps I took to make the HP EX495 to run on 1000 Mbps instead of 100 Mbps. I am only referring to the HP EX495 headless server (no VGA port)

 

Original problem: Installation of XPenology will default to the R8169 driver instead of R8168 causing the server to use speed of 100 Mbps (too slow)

Solution: Manually install the R8168 driver from manufacturer so it can use the correct driver.

 

Prerequisites:

 

- USB drive (thumb drive) - any size ok.

- Access to your NAS via SSH protocol, normally port 22. Here is how to do it: http://forum.synology.com/wiki/index.php/Enabling_the_Command_Line_Interface

- SSH client like putty http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

- Login to your NAS as “root”.

 

Steps:

 

Place a spare USB drive on your computer and format it using FAT32 file system.

1. Download the 8168 drivers from RealTek Website. Here is the link:http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

2. Scroll down to UNIX (Linux) section and click on the Global link for Version 8.040 (first row).

3. Copy and paste “0002-r8168-8.040.00.tar.bz2” to the USB drive.

4. Remove the USB drive and place it on your XPEpenology NAS

5. SSH to your NAS via IP Address or Host name and port number, default is port 22.

6. Login as root and enter your password.

 

Run the following code at the command shell:

 

Shell> cd /volumeUSB2/usbshare
Shell> tar vjxf r8168-8.aaa.bb.tar.bz2
Shell> cd r8168-8.aa.bb
Shell> ./autorun.sh  

 

Note: Look for your USB drive folder – Normally it would be volumeUSB2 and up not USB1 (boot USB), make sure you have correct one.

 

At this point if you are using remote ssh client it will run the script to Makefile and install the drivers, but it will cause your connection to be lost. Wait about 5 minutes and hard shutdown your EX495 by holding the power button for a few seconds. Then boot up the EX495, in my case I have to remove SATA0 shortly so it can boot from USB for a few seconds then place SATA0 drive back on so it can continue to boot (Headless server, no VGA).

Once the EX495 has booted, go back to ssh console and verify that adapter is now on 1000 Mbps and not 100 Mbps.

 

Run the following code on the shell:

 

Shell>ethtool eth0

 

Scroll down to the line where you see Speed and make sure it reads “1000Mb/s, Duplex Full”.

 

Transfer a large file to your NAS over the wire and monitor the speed :wink:

 

I hope this is useful for some HP EX495 users.

 

Thanks for the tutorial. Worked on my EX495 !

Share this post


Link to post
Share on other sites
Then boot up the EX495, in my case I have to remove SATA0 shortly so it can boot from USB for a few seconds then place SATA0 drive back on so it can continue to boot (Headless server, no VGA).

How are you timing the removal and subsequent replacement of the hard drive for reliable full boot of Xpenology? This is the main thing that has been holding me back from converting my EX495.

 

 

Make sure your USB boot up is in the last one from the bottom in the back of the EX495. If you place the usb bootup drive in any other USB port, it will not work.

 

When booting up just make sure SATA-0 is unplugged before turning on. I would give about 7 seconds then plug the hard drive back in. It will continue to boot up from there.

 

I would also suggest if you do not know the IP address to look into your router and see what IP address you get for "DiskStation". To avoid further confusion on IP address, what I did was I made DHCP in my router give it the same IP address all the time from the exclusion list. Your router should be able to do this.

 

I do the same. Usb in the last slot in the back of EX495. Sata lowest drive tray pulled out. Power the device. You will see the network and activity led turn on and appear green. In a few seconds the network led turns off and then comes on again in green color and simultaneously the activity led starts blinking red and green alternatively. Push the lowest sata drive tray in and you should see the synology assistant pickup your system in a 30 seconds or so.

Share this post


Link to post
Share on other sites