• 0

LSI2008 SAS passthrough doesn't show up in Xpenology running on ESXI


Question

Hi, I managed to get ds3215 installed with DSM 6.2.2 and working fine on ESXI. Problem is, I can't seem to pass through my LSI 2008 so I could access the SAS drives on my vm. In storage manager, it only shows my bootloader and VMware virtual drives, not the physical SAS drives.

 

I tested passing through the same LSI card to Freenas VM and Xubuntu VM and it works just fine. 

 

Yes, the LSI is flashed into IT mode.

 

 

Help please...

2020-10-07 18_59_02-syno - Synology DiskStation.png

Edited by asdfaeeee
Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

1st thing to check would be /var/log/dmesg if the pcie device of the controller shows up and what the driver (mpt2sas) has to say

if the device does not show up in the vm then something with the passthrough is not working

Link to post
Share on other sites
  • 0
On 12/19/2020 at 12:14 AM, IG-88 said:

1st thing to check would be /var/log/dmesg if the pcie device of the controller shows up and what the driver (mpt2sas) has to say

if the device does not show up in the vm then something with the passthrough is not working

checked up...

Spoiler

[Mon Dec 21 16:12:47 2020] megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 2006)
[Mon Dec 21 16:12:47 2020] megaraid: 2.20.5.1 (Release Date: Thu Nov 16 15:32:35 EST 2006)
[Mon Dec 21 16:12:47 2020] Fusion MPT base driver 3.04.20
[Mon Dec 21 16:12:47 2020] Copyright (c) 1999-2008 LSI Corporation
[Mon Dec 21 16:12:47 2020] Fusion MPT SPI Host driver 3.04.20
[Mon Dec 21 16:12:47 2020] Fusion MPT SAS Host driver 3.04.20
[Mon Dec 21 16:12:47 2020] Fusion MPT misc device (ioctl) driver 3.04.20
[Mon Dec 21 16:12:47 2020] mptctl: Registered with Fusion MPT base driver
[Mon Dec 21 16:12:47 2020] mptctl: /dev/mptctl @ (major,minor=10,220)
[Mon Dec 21 16:12:47 2020] megasas: 06.506.00.00-rc1 Sat. Feb. 9 17:00:00 PDT 2013
[Mon Dec 21 16:12:47 2020] mpt2sas version 20.00.00.00 loaded
[Mon Dec 21 16:12:47 2020] scsi2 : Fusion MPT SAS Host
[Mon Dec 21 16:12:47 2020] mpt2sas0: 32 BIT PCI BUS DMA ADDRESSING SUPPORTED, total mem (2056024 kB)
[Mon Dec 21 16:12:49 2020] usb 1-1: new full-speed USB device number 2 using xhci_hcd
[Mon Dec 21 16:12:49 2020] Got empty serial number. Generate serial number from product.
[Mon Dec 21 16:12:50 2020] usb 1-3: new full-speed USB device number 3 using xhci_hcd
[Mon Dec 21 16:12:50 2020] Got empty serial number. Generate serial number from product.
[Mon Dec 21 16:12:50 2020] usb 1-3: ep 0x81 - rounding interval to 1024 microframes, ep desc says 2040 microframes
[Mon Dec 21 16:12:50 2020] hub 1-3:1.0: USB hub found
[Mon Dec 21 16:12:50 2020] hub 1-3:1.0: 7 ports detected
[Mon Dec 21 16:12:51 2020] usb 1-4: new high-speed USB device number 4 using xhci_hcd
[Mon Dec 21 16:12:51 2020] Got empty serial number. Generate serial number from product.
[Mon Dec 21 16:12:51 2020] drivers/usb/core/hub.c (2696) Same device found. Change serial to ffffffd6ffffffa3ffffffebffffffc0
[Mon Dec 21 16:12:51 2020] hub 1-4:1.0: USB hub found
[Mon Dec 21 16:12:51 2020] hub 1-4:1.0: 7 ports detected
[Mon Dec 21 16:12:53 2020] mpt2sas0: _base_wait_for_doorbell_int: failed due to timeout count(10000), int_status(c0000000)!
[Mon Dec 21 16:12:53 2020] mpt2sas0: doorbell handshake int failed (line=1801)
[Mon Dec 21 16:12:53 2020] mpt2sas0: _base_get_ioc_facts: handshake failed (r=-14)
[Mon Dec 21 16:12:53 2020] mpt2sas0: mpt2sas_base_unmap_resources
[Mon Dec 21 16:12:53 2020] mpt2sas0: Controller resources are already freed
[Mon Dec 21 16:12:53 2020] mpt2sas0: failure at //source/lsi-mpt2sas/mpt2sas_scsih.c:11762/_scsih_probe()!
[Mon Dec 21 16:12:53 2020] mpt3sas version 22.00.02.00 loaded
[Mon Dec 21 16:12:47 2020] megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 2006)
[Mon Dec 21 16:12:47 2020] megaraid: 2.20.5.1 (Release Date: Thu Nov 16 15:32:35 EST 2006)
[Mon Dec 21 16:12:47 2020] Fusion MPT base driver 3.04.20
[Mon Dec 21 16:12:47 2020] Copyright (c) 1999-2008 LSI Corporation
[Mon Dec 21 16:12:47 2020] Fusion MPT SPI Host driver 3.04.20
[Mon Dec 21 16:12:47 2020] Fusion MPT SAS Host driver 3.04.20
[Mon Dec 21 16:12:47 2020] Fusion MPT misc device (ioctl) driver 3.04.20
[Mon Dec 21 16:12:47 2020] mptctl: Registered with Fusion MPT base driver
[Mon Dec 21 16:12:47 2020] mptctl: /dev/mptctl @ (major,minor=10,220)
[Mon Dec 21 16:12:47 2020] megasas: 06.506.00.00-rc1 Sat. Feb. 9 17:00:00 PDT 2013
[Mon Dec 21 16:12:47 2020] mpt2sas version 20.00.00.00 loaded
[Mon Dec 21 16:12:47 2020] scsi2 : Fusion MPT SAS Host
[Mon Dec 21 16:12:47 2020] mpt2sas0: 32 BIT PCI BUS DMA ADDRESSING SUPPORTED, total mem (2056024 kB)
[Mon Dec 21 16:12:49 2020] usb 1-1: new full-speed USB device number 2 using xhci_hcd
[Mon Dec 21 16:12:49 2020] Got empty serial number. Generate serial number from product.
[Mon Dec 21 16:12:50 2020] usb 1-3: new full-speed USB device number 3 using xhci_hcd
[Mon Dec 21 16:12:50 2020] Got empty serial number. Generate serial number from product.
[Mon Dec 21 16:12:50 2020] usb 1-3: ep 0x81 - rounding interval to 1024 microframes, ep desc says 2040 microframes
[Mon Dec 21 16:12:50 2020] hub 1-3:1.0: USB hub found
[Mon Dec 21 16:12:50 2020] hub 1-3:1.0: 7 ports detected
[Mon Dec 21 16:12:51 2020] usb 1-4: new high-speed USB device number 4 using xhci_hcd
[Mon Dec 21 16:12:51 2020] Got empty serial number. Generate serial number from product.
[Mon Dec 21 16:12:51 2020] drivers/usb/core/hub.c (2696) Same device found. Change serial to ffffffd6ffffffa3ffffffebffffffc0
[Mon Dec 21 16:12:51 2020] hub 1-4:1.0: USB hub found
[Mon Dec 21 16:12:51 2020] hub 1-4:1.0: 7 ports detected
[Mon Dec 21 16:12:53 2020] mpt2sas0: _base_wait_for_doorbell_int: failed due to timeout count(10000), int_status(c0000000)!
[Mon Dec 21 16:12:53 2020] mpt2sas0: doorbell handshake int failed (line=1801)
[Mon Dec 21 16:12:53 2020] mpt2sas0: _base_get_ioc_facts: handshake failed (r=-14)
[Mon Dec 21 16:12:53 2020] mpt2sas0: mpt2sas_base_unmap_resources
[Mon Dec 21 16:12:53 2020] mpt2sas0: Controller resources are already freed
[Mon Dec 21 16:12:53 2020] mpt2sas0: failure at //source/lsi-mpt2sas/mpt2sas_scsih.c:11762/_scsih_probe()!
[Mon Dec 21 16:12:53 2020] mpt3sas version 22.00.02.00 loaded

any suggestion?

 

Thank you !

Daniele

Edited by daromeo76
Link to post
Share on other sites
  • 0
22 minutes ago, daromeo76 said:

any suggestion?

at least there is a pcie device present or the driver would not start

is the card working in baremetal with dsm or with a normal linux (lboot a live linux instead of dsm)

either the card is not working properly or the paththrough

Link to post
Share on other sites
  • 0

 

On 12/18/2020 at 6:11 AM, daromeo76 said:

same problem Here

Esxi 6.5

Xpe 3617xs

Dsm 6.2.3 25426

lsi 2008 passed through vm

 

 

I upgrade mine to the latest U3 yesterday and now I am running into the same issue. I am running on Esxi 6.7 and the rest are are exact as yours. After reading a few posts from this forum, here is my observation. Hopefully some smart genius could figure out a solution for us:

 

Since the new update messed up the drive mapping, there are 2 issues:

1. the 50MB vmdk is now showing as unused drive and taking the drive slot #1.
13443175_StorageManager-HDD.thumb.png.5f90947653b8cb755e250e51c025102a.png

1025012125_StorageManager-overview.thumb.png.287f853af96664549fbec3a2dddfd9fb.png

2. The last drive is mapped to slot #17 while the DS3617xs should only have 16 slots. (for up to 16 drives). So I always get the warning to repair the system partition after reboot.

 

Before the upgrade, my pass through drives are numbered as 1, 4, 5, 6 and 7. Not sure why it is showing 33, 34, 37, 38 and 39 now? Is there any way we could manually mapping it to some other numbers? At least move the last drive to any free slot from 2 to 12?

 

On 10/7/2020 at 8:59 PM, asdfaeeee said:

Hi, I managed to get ds3215 installed with DSM 6.2.2 and working fine on ESXI. Problem is, I can't seem to pass through my LSI 2008 so I could access the SAS drives on my vm. In storage manager, it only shows my bootloader and VMware virtual drives, not the physical SAS drives.

 

I tested passing through the same LSI card to Freenas VM and Xubuntu VM and it works just fine. 

 

Yes, the LSI is flashed into IT mode.

 

 

Help please...

2020-10-07 18_59_02-syno - Synology DiskStation.png

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.