ssiril

How to install xpenology on an old Netgear RNDU 4000

Recommended Posts

After a long time I did turn my ReadyNASPRO6 on, so I need some help here, please ...

 

I have instaled:

 

- syno-i686-bootstrap_1.2-7_i686.xsh

- chmod +x syno-i686-bootstrap_1.2-7_i686.xsh

- sh syno-i686-bootstrap_1.2-7_i686.xsh

- ipkg update

- ipkg upgrade

 

edit file .profile in /root (add # before this two lines)

 

#PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin

#export PATH

 

save on exit

reboot

 

 

- ipkg install mktemp

- ipkg install lm-sensors

 

SYNOLOGY3> sensors
coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +46.0°C  (high = +76.0°C, crit = +100.0°C)
Core 1:       +36.0°C  (high = +76.0°C, crit = +100.0°C)

 

pwmconfig (comand not working ???)

 

Can you install perl ?

pwmconfig is a perl script :smile:

Share this post


Link to post
Share on other sites

- ipkg install perl

Package perl (5.10.0-6) installed in root is up to date.

Nothing to be done

Successfully terminated.

 

- sensors

coretemp-isa-0000

Adapter: ISA adapter

Core 0: +46.0°C (high = +76.0°C, crit = +100.0°C)

Core 1: +36.0°C (high = +76.0°C, crit = +100.0°C)

 

- pwmconfig

-ash: pwmconfig: not found

Share this post


Link to post
Share on other sites
- ipkg install perl

Package perl (5.10.0-6) installed in root is up to date.

Nothing to be done

Successfully terminated.

 

- sensors

coretemp-isa-0000

Adapter: ISA adapter

Core 0: +46.0°C (high = +76.0°C, crit = +100.0°C)

Core 1: +36.0°C (high = +76.0°C, crit = +100.0°C)

 

- pwmconfig

-ash: pwmconfig: not found

 

Can you read my post?? :

"..script don't work under ash shell only bash and your netgear boot with default shell. You must install bash and edit . profile file for switch default shell to installed bash..."

Share this post


Link to post
Share on other sites

edit . profile file for switch default shell to installed bash...

 

what do i have to write in ???

 

umask 022

#PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin
#export PATH

#This fixes the backspace when telnetting in.
#if [ "$TERM" != "linux" ]; then
#        stty erase
#fi

HOME=/root
export HOME

TERM=${TERM:-cons25}
export TERM

PAGER=more
export PAGER

PS1="`hostname`> "

alias dir="ls -al"
alias ll="ls -la"

Share this post


Link to post
Share on other sites

You add this on ending .profile file:

 

if [[ -x /opt/bin/bash ]]; then

exec /opt/bin/bash

fi

 

and reboot.

Share this post


Link to post
Share on other sites

I start from begining ...

 

NAS: RNDP6000

img: NanoBoot-5.0.3.1-fat.img

pat: DSM_DS3612xs_4493.pat

 

I did this:

- mkdir /volume1/@tmp

- cd /volume1/@tmp

- wget http://ipkg.nslu2-linux.org/feeds/optwa ... 7_i686.xsh

- chmod +x syno-i686-bootstrap_1.2-7_i686.xsh

- sh syno-i686-bootstrap_1.2-7_i686.xsh

- ipkg update

- ipkg upgrade

- ipkg install perl

- ipkg install bash

- ipkg install mktemp

- ipkg install lm-sensors

 

edit file root/.profile (PATH=/opt/bin:/opt/sbin:), switch default shell to installed bash

 

umask 022

PATH=/opt/bin:/opt/sbin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin
export PATH

#This fixes the backspace when telnetting in.
#if [ "$TERM" != "linux" ]; then
#        stty erase
#fi

HOME=/root
export HOME

TERM=${TERM:-cons25}
export TERM

PAGER=more
export PAGER

PS1="`hostname`> "

alias dir="ls -al"
alias ll="ls -la"

if [[ -x /opt/bin/bash ]]; then
exec /opt/bin/bash
fi

 

I create file S99fancontrol.sh in /usr/syno/etc/rc.d/

 

#!/opt/bin/sh

#and this same head in fancotrol script

#
# S99fancontrol.sh - startup script for fancontrol
#
# This goes in /usr/syno/etc/rc.d and gets run at boot-time.

FANCONTROL=/opt/sbin/fancontrol


case "$1" in

start)
       if [ -x "$FANCONTROL" ] ; then
               echo "start fancontrol"
               $FANCONTROL &
       fi
       ;;

stop)
       echo "stop fancontrol"
       kill -TERM `cat /var/run/fancontrol.pid` > /dev/null 2>&1
       logger -p daemon.error "$0 stop fancontrol"
       sleep 1
       ;;

*)
       echo "usage: $0 { start | stop }" >&2
       exit 1
       ;;

esac

 

- chmod 755 /usr/syno/etc/rc.d/S99fancontrol.sh

 

reboot

 

I log in via putty ...

 

- sensors

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +46.0°C  (high = +76.0°C, crit = +100.0°C)
Core 1:       +36.0°C  (high = +76.0°C, crit = +100.0°C)

 

- pwmconfig

bash: /opt/sbin/pwmconfig: /bin/bash: bad interpreter: No such file or directory

 

- fancontrol

bash: /opt/sbin/fancontrol: /bin/bash: bad interpreter: No such file or directory

 

I cant find what is wrong ... my linux knowledge is somehow limited :smile:

Share this post


Link to post
Share on other sites

My header of S99fancontrol.sh:

 

#!/bin/sh

 

and fancontrol and pwmconfig:

 

#!/opt/sbin/bash

 

and for me is work's all well :smile:

 

BTW, my console name is bash-3.2 :smile:

Share this post


Link to post
Share on other sites
My header of S99fancontrol.sh:

 

#!/bin/sh

 

and fancontrol and pwmconfig:

 

#!/opt/sbin/bash

 

Still the same :

 

bash-3.2# pwmconfig
bash: /opt/sbin/pwmconfig: /opt/sbin/bash: bad interpreter: No such file or directory
bash-3.2# fancontrol
bash: /opt/sbin/fancontrol: /opt/sbin/bash: bad interpreter: No such file or directory

Share this post


Link to post
Share on other sites

Sorry I don't know why is not working :sad:

It seems is problem with bash shell.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I also have a Pro 6.. Only I've fitted a Q6600, so I get 2 temps extra:

 

NASSYN> sensors
coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +34.0°C  (high = +84.0°C, crit = +100.0°C)
Core 1:       +36.0°C  (high = +84.0°C, crit = +100.0°C)
Core 2:       +36.0°C  (high = +84.0°C, crit = +100.0°C)
Core 3:       +32.0°C  (high = +84.0°C, crit = +100.0°C)

NASSYN> 

 

 

I get stuck on the same thing as you do.

Share this post


Link to post
Share on other sites

Hi,

 

I'm new, and a real Linux noob, but after reading the complete thread carefully and trying over and over again i have found the correct way to control the fans on boot. I have tested it more than once on my "spare" ReadyNAS Pro 4.

 

Make sure you have setup your NAS and that it is working. After that enable SSH and login with ie Putty. Issue the following commands in the correct order

 

mkdir /volume1/@tmp
cd /volume1/@tmp
wget http://ipkg.nslu2-linux.org/feeds/optware/syno-i686/cross/unstable/syno-i686-bootstrap_1.2-7_i686.xsh
chmod +x syno-i686-bootstrap_1.2-7_i686.xsh
sh syno-i686-bootstrap_1.2-7_i686.xsh
ipkg update
ipkg upgrade
ipkg install perl
ipkg install bash
ipkg install mktemp
ipkg install lm-sensors

 

Than edit the file .profile located in /root as shown below (PATH is extended and at the bottom a code is added to boot into bash)

 

umask 022

PATH=/opt/bin:/opt/sbin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin
export PATH

#This fixes the backspace when telnetting in.
#if [ "$TERM" != "linux" ]; then
#        stty erase
#fi

HOME=/root
export HOME

TERM=${TERM:-cons25}
export TERM

PAGER=more
export PAGER

PS1="`hostname`> "

alias dir="ls -al"
alias ll="ls -la"

if [[ -x /opt/bin/bash ]]; then
exec /opt/bin/bash
fi

 

Now create a startup script S99fancontrol.sh in /usr/syno/etc/rc.d/ containing the following code

 

#!/opt/bin/bash

# Use the same head in fancontrol script
#
# S99fancontrol.sh - startup script for fancontrol
#
# This goes in /usr/syno/etc/rc.d and gets run at boot-time.

FANCONTROL=/opt/sbin/fancontrol


case "$1" in

start)
       if [ -x "$FANCONTROL" ] ; then
               echo "start fancontrol"
               $FANCONTROL &
       fi
       ;;

stop)
       echo "stop fancontrol"
       kill -TERM `cat /var/run/fancontrol.pid` > /dev/null 2>&1
       logger -p daemon.error "$0 stop fancontrol"
       sleep 1
       ;;

*)
       echo "usage: $0 { start | stop }" >&2
       exit 1
       ;;

esac

 

Set permissions to 755 with

 

chmod 755 /usr/syno/etc/rc.d/S99fancontrol.sh

 

Now test your sensors with

 

sensors

 

It will give an output similar to the code below

 

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +37.0°C  (crit = +100.0°C)

it8721-isa-0a10
Adapter: ISA adapter
in0:          +3.06 V  (min =  +2.20 V, max =  +3.06 V)  ALARM
in1:          +2.86 V  (min =  +0.00 V, max =  +2.08 V)  ALARM
in2:          +2.22 V  (min =  +2.12 V, max =  +1.42 V)  ALARM
+3.3V:        +3.34 V  (min =  +2.69 V, max =  +4.01 V)
in4:          +2.76 V  (min =  +2.05 V, max =  +1.91 V)  ALARM
in5:          +1.16 V  (min =  +1.46 V, max =  +1.40 V)  ALARM
in6:          +2.80 V  (min =  +0.08 V, max =  +1.52 V)  ALARM
3VSB:         +3.29 V  (min =  +5.93 V, max =  +6.05 V)  ALARM
Vbat:         +3.31 V
fan1:        2033 RPM  (min =   10 RPM)
fan2:           0 RPM  (min =   14 RPM)  ALARM
temp1:        +49.0°C  (low  = +112.0°C, high =  -5.0°C)  ALARM  sensor = thermal diode
temp2:        +33.0°C  (low  = -53.0°C, high = +61.0°C)  sensor = thermal diode
temp3:       -128.0°C  (low  = +79.0°C, high =  -7.0°C)  sensor = disabled
intrusion0:  ALARM

 

If everything is ok we have to build the default config files

 

sensors -s

 

Now we are ready to build /etc/fancontrol

 

bash pwmconfig

 

Follow the steps, but in general you can use the following as a guide

 

  • Select 1) hwmon/device/pwm1
  • Select 4) hwmon/device/temp2_input
  • Low temperature is default at 20
  • High temperature is default at 60
  • Minimum PWM value is 8 (check this, it is tested before)
  • Minimum PWM value when fan starts spinning is 8 (30 are added)
  • PWM value when below low temperature = 8
  • PWM value when over the high temperature limit = 165 (check this, it is tested before ans should be about 3000/3100 rpm)

 

After you saved it, it will create a config file /etc/fancontrol and it will look like this:

 

# Configuration file generated by pwmconfig, changes will be lost
INTERVAL=2
DEVPATH=hwmon0= hwmon1=
DEVNAME=hwmon0=coretemp hwmon1=it8721
FCTEMPS=hwmon1/device/pwm1=hwmon0/device/temp2_input
FCFANS= hwmon1/device/pwm1=hwmon1/device/fan1_input
MINTEMP=hwmon1/device/pwm1=20
MAXTEMP=hwmon1/device/pwm1=60
MINSTART=hwmon1/device/pwm1=38
MINSTOP=hwmon1/device/pwm1=8
MINPWM=hwmon1/device/pwm1=8
MAXPWM=hwmon1/device/pwm1=165

 

Now you can test your setup

 

bash fancontrol

 

If things are right the fans should spin-down immediately. Exit with ctrl-c and fans will spin-up again.

 

We have to edit /opt/sbin/fancontrol change the header to

 

#!/opt/bin/bash

 

Time to shutdown and restart your ReadyNAS

 

shutdown -h now

 

When your NAS is really off, power it on again. If all is fine, the fan will spin-down after the boot sequence is completed.

 

If you still boot from an USB stick, maybe it is time to replace the original Netgear bootcode.

 

First make a backup and copy it to a save place

 

dd if=/dev/sdu of=/dev/backup_netgear

 

Copy your image to ie /dev, after that unmount your USB volumes (if your USB stick is still present it is safe to unmount that also)

 

umount /dev/sdu1

 

Your USB is probably sdu2

 

umount /dev/sdu2

 

Now write the bootcode to sdu1

 

dd if=/dev/insert_the_name_of_your_image_here.img of=/dev/sdu

 

Reboot!

 

Hope this helps those who had problems before.... Now find a way to control the LCD!!!

Share this post


Link to post
Share on other sites

Hello gwd 1963

 

Great job, running on Readynas Ultra 2. Only thing I can't get fixed is going down at 23:00 and up at 09:00. Nas is gowing down at 23:00 allright but not starting at 09:00. When I tried that on an old PC it is working alright. Any ideas on that? Maybe something in the bios of the Ultra 2?

Share this post


Link to post
Share on other sites
Hello gwd 1963

 

Great job, running on Readynas Ultra 2. Only thing I can't get fixed is going down at 23:00 and up at 09:00. Nas is gowing down at 23:00 allright but not starting at 09:00. When I tried that on an old PC it is working alright. Any ideas on that? Maybe something in the bios of the Ultra 2?

 

I did not try the timer function, my guess is that it does not go into a sleep mode but really shuts down. I will look into it, because I also want this (or WOL) because I will be using the Netgear as a backup NAS.

 

Regards... Gerwin

now you have a name, instead off some characters... :wink:

Share this post


Link to post
Share on other sites

by command sensors, I only get this:

 

 

bash-3.2# sensors

coretemp-isa-0000

Adapter: ISA adapter

Core 0: +46.0°C (high = +76.0°C, crit = +100.0°C)

Core 1: +36.0°C (high = +76.0°C, crit = +100.0°C)

 

bash-3.2#

 

I don`t see any oher stuff ???

 

gdw1963 - which ver. do U have on you NAS ???

Share this post


Link to post
Share on other sites

Strange, this is my output

 

coretemp-isa-0000
Adapter: ISA adapter
Core 0:        +7.0°C  (crit = +100.0°C)
Core 1:        +8.0°C  (crit = +100.0°C)

it8721-isa-0a10
Adapter: ISA adapter
in0:          +3.06 V  (min =  +0.48 V, max =  +1.52 V)  ALARM
in1:          +2.78 V  (min =  +2.63 V, max =  +0.07 V)  ALARM
in2:          +2.22 V  (min =  +0.50 V, max =  +0.58 V)  ALARM
+3.3V:        +3.31 V  (min =  +4.20 V, max =  +2.21 V)  ALARM
in4:          +2.76 V  (min =  +0.96 V, max =  +1.45 V)  ALARM
in5:          +1.07 V  (min =  +1.90 V, max =  +1.33 V)  ALARM
in6:          +2.76 V  (min =  +1.28 V, max =  +2.63 V)  ALARM
3VSB:         +3.29 V  (min =  +2.81 V, max =  +3.72 V)
Vbat:         +3.29 V
fan1:         314 RPM  (min =   15 RPM)  ALARM
fan2:           0 RPM  (min =   39 RPM)  ALARM
temp1:        +42.0°C  (low  = +78.0°C, high = +60.0°C)  sensor = thermal diode
temp2:        +22.0°C  (low  = +60.0°C, high = +26.0°C)  sensor = thermal diode
temp3:       -128.0°C  (low  =  +8.0°C, high = +84.0°C)  sensor = disabled
intrusion0:  ALARM

 

Currently running on DSM 5.0-4493

Share this post


Link to post
Share on other sites

I have a Pro 6 as well only showing the CPUs in the sensors. Did anyone get around this or find a fix? I have seem some kernal setting for enforce_acpi... = lax not sure if that is the issue or not.

Share this post


Link to post
Share on other sites
I have a Pro 6 as well only showing the CPUs in the sensors. Did anyone get around this or find a fix? I have seem some kernal setting for enforce_acpi... = lax not sure if that is the issue or not.

 

Hi,

any news on that?

I'm a total noob with a Readynas Pro 6 and would like to learn how to install Xpenology.

But before i start it would be nice to know if fancontrol is possible or not :smile:

Share this post


Link to post
Share on other sites

I managed to enter the Bios of my ReadyNAS Pro 6.

Right there i can choose the boot order and also change the fans to "Thermal control".

 

Xpenology starts out of the box without hassle and installing 5.1 Update 2 was no prob at all.

 

But....this damn CMOS reset.... :mad: when trying to do a scheduled power on :twisted:

 

Running XPenology on ReadyNAS was a great experience, but no scheduled power on/off is a no go (for me!). So i gave up :sad:

Share this post


Link to post
Share on other sites

Hey

i have Netgear RND 4000 with firmware 4.1.14 and im not able to boot from the usb gnoboot-alpha10.4-vfat.img it always boots to the netgear OS. what im i missing do i need to upgrade to readynas OS 6.1.6 if so where can i find the ver for RND 4000 thank you

Share this post


Link to post
Share on other sites

hey interested my nethear RND 4000 does not have the pins for the vga but i did load the root add-on and that was it

Share this post


Link to post
Share on other sites

I have a huge problem...

 

I tried to follow your guide but unfortunately i didn't manage to success..

 

The problem that i have now is that i login via ssh and instead of "" it has "bash-3.2#". How can i revert back to my machine?

Share this post


Link to post
Share on other sites

Finally i managed to get out of bash.

 

Firstly in bash i execute "source profile" and that helped me to get out of bash and then from my machine i execute ipkg remove bash and that's it. After that everything is back!!

Share this post


Link to post
Share on other sites

Hello,

 

Need some help. I have managed to create a USB deive to boot my ReadyNAS RNDP6000 with Synology DSM.

 

When I run the dd command I am not able to boot the NAS into Synology.

 

I get the BOOT MENU on the nas screen with the options -

1. debug

2. Install

3. XPEnology

 

Not sure what went wrong.

 

Please advise.

Share this post


Link to post
Share on other sites