luchuma

Tutorial: Install DSM 6.2 on ESXi 6.7

Recommended Posts

you dont need to install another lan device

OK, and do you know why I don't have Internet on my Windows virtuals machines, please?

 

Share this post


Link to post
Share on other sites
37 минут назад, pepetops сказал:

OK, and do you know why I don't have Internet on my Windows virtuals machines, please?

ESXI-DSM-VMM-Windows virtual machine? Or ESXI-Windows virtual machine?

Share this post


Link to post
Share on other sites



ESXI-DSM-VMM-Windows virtual machine? Or ESXI-Windows virtual machine?


It was ESXi imported to vmware WorkStation. So like ESXI-DSM-VMM-Windows virtual machine

Share this post


Link to post
Share on other sites
On 3/14/2019 at 7:31 PM, pepetops said:

 

 

 

Hm, strange, I can't get rid of quoting. I didn't want to quote anybody.

Anyway. I've got a DS3615 VM running on VMWare ESX 6.7 (host is an old Fujitsu Siemens 1U machine).

Attached to that is a supermicro SAS-shelf (via hostbus-adapter) with 45 disks to play with.

I can easily passthrough SAS-drives to a FreeNAS-VM via scsi-controlers.

Doing the same to the virtual DSM is way more tricky.

What I managed to do consistently is attach a total of 22 disks (11 disks per SATA-controler). I can build one or two storage pools, make volumes, it creates everything very fastly (building two 18TB volumes was done overnight). But as soon as I reboot, everything is lost and I get to the standard :5000 page that tells me to reinstall DSM.

Passing through a smaller amount of disks with only one additional controler is quite persistent with e.g. 3 disks.

Serial out-errors are (only copying error-lines):

 

- linuxrc.syno failed on 2

- /etc/rc: /etc/rc: line 108: line 108: /usr/syno/bin/synodiskpathparse: not foundawk: not found

- rc: Failed to parse partition sdag2

- :: Loading module r8168 ... [FAILED]

- :: Loading module jme ... [FAILED]

- :: Loading module cnic ... [FAILED]
- :: Loading module r8168 ... [FAILED]
- :: Loading module r8169 ... [FAILED]

- Can not detect ADT device, Retry: 1...

- Can not detect ADT device, Retry: 2...

- Can not detect ADT device, Retry: 3...

 

 

I've also tried convincing it that 12 drives per controller is not the upper limit (

) but that left me with a constantly recovering VM.

 

 

All this mucking about takes so much time as ever time I try again, I have to passthrough the drives to the FreeNAS-VM to delete them. If I leave that out, the Syno-VM will always try to recover because the disks had been formatted through DSM.

 

 

What I actually want to achieve is using the storage shelf in some way to hyperbackup to it.

I would buy an actual small synology if I could achieve that through mounting storage (let's say hosted through FreeNAS) through NFS (which won't work, Hyperbackup Vault can't use that as destination) or iSCSI (which is also difficult to achieve as the Synos are not meant to be on the receiving end of iSCSI).

 

I'm about to give up and try Hyperbackup through rSync-compatible, but that needs to be encrypted and so far, I've not been able to make that work.

Share this post


Link to post
Share on other sites

 

The Installer always want to format my xpnology loader (SATA:0-1).

If i says yes the Loader still boots but has no network-connectivity. 

Any Ideas?

 

IcTdnXQ.png

 

XVPnskA.png

Share this post


Link to post
Share on other sites

Thumbs up for the write up. FWIW i didn't do the grub piece and have it running with no issues. Thank you.

Share this post


Link to post
Share on other sites

Great thanks to author!
Successfully upgraded 36177xs DSM 6.1.2 in ESXi 6.5 on HP Microserver Gen8 to DSM 6.2.2-24922 in 10 min.

Some key points:
- was not necessary to edit grub.cfg in my case - since 5.x version it works with '"defaults" (MAC/serial as in original loader archive files)

- uploaded vmdk and new 1.03b loader in new folder on storage

- removed all disks from VM

- added new exiting disk SATA0:0 at SATA controller 0 from loader vmdk file
at this stage my xpenology booted succesfully  (accessible with Synology assistant, but without no hard disk attached)

- added new SATA controller 1 (!) and new disk SATA1:0 from existing DATA vmdk
at this stage DSM upgrade process starte successfully: DSM_DS3617xs_23648.pat not installed as old unsupported, but DSM_DS3617xs_24922.pat installed. After upgrade and restart my XPEnology was unacessible over network since I've
- changed network adapter type from old VMNET3 to E1000e.

Thats all, folks.
Now ti works without any problems.
Upgrade to ESXi 6.7 suspended due to performance problems (i've tried it after 6.7 release, even with manual storage driver downgrade but not satisfied)

 

 

Share this post


Link to post
Share on other sites
On 3/19/2019 at 4:27 AM, FranzK said:

 

The Installer always want to format my xpnology loader (SATA:0-1).

If i says yes the Loader still boots but has no network-connectivity. 

Any Ideas?

 

Put synoboot.vmdk on the *second* SATA controller (so it is SATA1:0) and the storage disks on the first (so they are SATA0:1, etc).

Go into the BIOS and set SATA1:0 as the top boot device.

This worked for me on ESXi6.5 with "Jun's Loader v1.03b DS3615xs" and DSM_DS3615xs_24922.

 

Share this post


Link to post
Share on other sites

Hey there to all

 

If i do all what is listen in the Tutorial

And I want to set up the VM, I can not read the hard drive. I have uploaded the * .vmdk file but can not see it when configuring the VM. Can someone help me?

Share this post


Link to post
Share on other sites

Uploaded vmdk is only for bootloader.
You need to add New virtual hdd or make rdm

Wysłane z mojego SM-G970F przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Sure i know

 

But if i want to creat the virtual hdd with the vmdk i have uploaded i cant see the file 

 

if i look with the explorer i can see all file's

Share this post


Link to post
Share on other sites

sry 

 

so i heave found the problem, i have convert the *.img file to *.iso

 

if i upload the *.img and the *.vmdk it works thanks and good evening

Share this post


Link to post
Share on other sites
On 4/5/2019 at 8:04 AM, Daniel O said:

Put synoboot.vmdk on the *second* SATA controller (so it is SATA1:0) and the storage disks on the first (so they are SATA0:1, etc).

Go into the BIOS and set SATA1:0 as the top boot device.

This worked for me on ESXi6.5 with "Jun's Loader v1.03b DS3615xs" and DSM_DS3615xs_24922.

 

Thanks for the tipp, but this don't work for me. 

Still asks me to format two disks

Share this post


Link to post
Share on other sites

Did anyone get any SCSI Controller to work? I would like to use RDMs.

 

Edit: Forget it. Just noticed that I can attach RDM to SATA controller. Great, really👍

Edited by fafner

Share this post


Link to post
Share on other sites
On 4/6/2019 at 8:10 PM, jarhead said:

Sure i know

 

But if i want to creat the virtual hdd with the vmdk i have uploaded i cant see the file 

 

if i look with the explorer i can see all file's

This is be cause u created the wrong vmdk files! It has to have both files to show in vmware

Share this post


Link to post
Share on other sites

 

On 2/2/2019 at 12:16 PM, swords80 said:

@kachunkachunk I'm having a look at modifying the 1.04B loader to see if I can do a couple of things:

  1. Support older CPUs, I can't see anything that Braswell has but isn't available on Sandy Bridge as an example, I've asked Jun too, but no reply yet. Trying to play with DSDT.
  2. Support setting MaxDisks, SataPortMap, Sas/DiskIdxMap and sata_remap as OVF properties (asked during import/changeable from UI later).
  3. Support an auto value for the args above (script that figures them out and reboots on change).
  4. Integrate VMware Tools in boot loader (needed to be able to do #2/#3/make it easier to find DHCP address).

Another thing I'm thinking about is a SPK with a UI to change/update the boot loader. I'm able to mount it, so I could overwrite it too.

 

 

Dp you have any news ? :)

i love your work

Share this post


Link to post
Share on other sites
13 hours ago, neolead said:

Okay...

Synology 24922 esxi 
Clear installed on esxi 6.7

https://mega.nz/#!eWokUSiS!6_vFRKsBzHFB2DPIUTK39azLcWPA8sl58aF9otD0Gbc
admin:synology2019$$$
mac1=0011322CA785
 

 

Thanks Pal,

 

You don't realise how much time I have spent trying to get this to work. IMO, this should be placed in the downloads section or somewhere.

 

Out of interest, any work being done to get this working in Azure.. I tried on an earlier release, but the console didn't show up any network adaptors. I'm thinking of replication into Azure.

 

Tom

Share this post


Link to post
Share on other sites

Hi,

 

How did you manage to get the latest DSM working on esx?

 

Thanks for the image, this works, but I want to know how you did this as I want to try myself.. I have some bigger plans to get this working on hyper-v since I want to attempt to install this in azure. I got so far last time, but the network adaptors wouldn't show in azure. Maybe if I can understand how you got it working in vmware, this could help me figure out the rest.

 

When I remove and re-create the second disk, you get the 'migrate or install' option. I got to this part before, but regardless of the pat file I uploaded, it said I needed a newer version (I was using the latest version)

 

Thanks


Tom

Share this post


Link to post
Share on other sites

Thanks dude ! what is the IP address ?

Edited by Polanskiman
Reinstated deleted reply to allow coherence with subsequent answers.

Share this post


Link to post
Share on other sites

 

19 minutes ago, repulse said:

 

Thanks dude ! what is the IP address ?

You can use the synology assistant as it gets IP from DHCP

 

Also I did manage to install using the original instructions in the end, albeit, I didn’t need to change the MAC addresses in the Config, it didn’t seem to make much difference the MAC address it seems to use is the one on the VMware adaptor set to automatic.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.