luchuma

Tutorial: Install DSM 6.2 on ESXi 6.7

Recommended Posts

As for networking in ESXi: It all depends on how complex your network environment is. I'll just assume you have a single simple subnet (/24), then ESX makes a virtual switch and virtually connects your VMs to it. The IP-Addresses still come from your router, as if you'd connect a physical device to your network. Ideally, you'd create a DHCP-reservation for the MAC-address of the VM on the router so the virtual DSM always gets the same IP and also gets the IP you'd like it to have, without having to fiddle with it in the networking section of the DSM

Share this post


Link to post
Share on other sites

Ok, thanks @iLab! :)

So the unique mac is passed through to the router and dhcp’s for an IP address? I indeed use static mapping, so that would be perfect. Thanks a lot!

Edited by JJJL

Share this post


Link to post
Share on other sites
Posted (edited)

Hey guys, I succesfully installed VMware-ESXi-6.0.0-Update3-9313334-HPE-preGen9-600.9.8.5.4-Sep2018 over iLO 2 on my old HP ML350 G5, yay!

 

Edit:

Made it working successfully with DSM_DS3615xs_23739, but after intallation of DSM_DS3615xs_23824.pat it will not show up on the network.

 

NIC is E1000 - as I don't see option for E1000e in my ESXi 6.

 

Any ideas why I can't update it?
 

 

01.PNG

Edited by drogi

Share this post


Link to post
Share on other sites

I think 6.5 is the latest possible for this old server (tried 6.7 in the begining and this CPU was refused).

Version 6.0.0  update 3 is the latest custom HPE image and I think I will stick with this one.

DSM 6.2 running smooth, all packages are latest, so this will be good enough for maybe another 2 years.

 

Thank you guys for help and most importantly for amazing tutorials.

Share this post


Link to post
Share on other sites

 Guys need some help,

 

I installed and everything went perfectly, but a small issues, I added 4 drives but only 2 shoes up in drive manager. All drives works in freenas.

 

Loder 1.03b

Diajstation 6.2

VMware 6.5

RDM Drives

 

Any help would be much appreciated

Share this post


Link to post
Share on other sites

did you try to chceck rdms in other virtual machine?

 

rdms are in in sata 1:0, 1:1, 1:2, 1:3? and loader in sata 0:0 ?

Share this post


Link to post
Share on other sites

Yes, if works in the freenas vm, also I tried in another VMware exsi  server same result! When I add 4 drives 2 dk t get detected, only first 2 appears!

Share this post


Link to post
Share on other sites

please provide screens of disks configuration in vm and in dsm

 

did you change sata port map in grub.cfg?

Edited by luchuma
  • Thanks 1

Share this post


Link to post
Share on other sites

Hey Guys,

 

I figured it out!

 

I have to set all drive to be taken as sata, when it is scsi it only takes the first two drives!

Share this post


Link to post
Share on other sites
23 hours ago, luchuma said:

did you try to chceck rdms in other virtual machine?

 

rdms are in in sata 1:0, 1:1, 1:2, 1:3? and loader in sata 0:0 ?

 

yes i asked you

Share this post


Link to post
Share on other sites

Following OP instruction I successfully installed DS-3615XS(DSM 6.2.1-23824 Update 4) on ESXi 6.7. 

 

I tried to load 3617XS but failed. Not sure what was wrong.  Which file you used when you load 3617XS?  I am using 1.03b loader and DSM_DS3617xs_23739.pat. But after update to 23824 it seems lost network.

 

Share this post


Link to post
Share on other sites

6.2.1 needs intel nic 

 

try e1000 or e1000e

Edited by luchuma

Share this post


Link to post
Share on other sites

e1000e is required, e1000 currently is not working as a primary network interface on Jun 1.03b, DS3615/17 and 6.2.1

Edited by flyride

Share this post


Link to post
Share on other sites

I am pretty sure  I use e1000e in my all past installation. I just tried again and this time I re-downloaded all the file and I use 23824 pat file directerlly and now everything works. Still not sure what went wrong before.

 

Thanks for all of your help.

Share this post


Link to post
Share on other sites
16 hours ago, luchuma said:

please provide screens of disks configuration in vm and in dsm

 

did you change sata port map in grub.cfg?

Hey thanks, i changed it in vmware device sections! much appreciate your info! i honestly was reading in the mobile so i didnt see, thx so much mate!

Share this post


Link to post
Share on other sites

Hey guys I'm seeking help. I too am only getting the option to recover once installation is complete. What I've tried so far:

 

synoboot.img with custom serial number

synoboot.img with default serial number

esxi 6.7 hardware

esxi 6.5 hardware

23648.pat

23824.pat

 

I have 3 physical drives in my server.

 

Tried loading syno.vmdk from 1st drive (datastore) and saving my storage drive to the 3rd drive (datastore)

Tried loading all from same datastore

 

Any advice is greatly appreciated.

Share this post


Link to post
Share on other sites

Okay I figured out the issue above. Of course it was user error 🙄. I have just setup a physical xpenology and reused files. Made the modifications to grub like I was supposed to but still, my bad.

 

So onto a new issue. I have a disk which is 1.8 TB dedicated to xpenology. After copying around 20 gigs the disk shows full. All 1.8 TB used. I don't even know where to start with this issue. The VM locks up and I must power it off and restore a snapshot to get it back up and running. It happened once so I rebuilt and now it is happening again.

 

UPDATE: It doesn;t matter what file operation I do, the result is the same. I restored a snapshot and setup storage again. After copying one file which was 1.13 GB the VM locks up and shows the drive as full. Even ESXI shows the drive as full.

Edited by mevrane

Share this post


Link to post
Share on other sites

Good evening! Still having the issue above. No matter what configuration I try my drive becomes completely full after transferring the first file. Whether its a kilobyte, a meg or a gig it reports my 1.8 TB "data" drive in xpenology as full

Share this post


Link to post
Share on other sites

show disks config from esxi and dsm

Edited by luchuma

Share this post


Link to post
Share on other sites
1 hour ago, luchuma said:

show disks config from esxi and dsm

 

 

I've found this guide to pass physical as RDM. I've created the RDM but when I try to add in xpenology VM i get the error "Incompatible device backing for device (device#)"

 

https://gist.github.com/Hengjie/1520114890bebe8f805d337af4b3a064

 

I've tried the guide with hardware version 6.7, 6.5 and 5.5.

 

Thank you for any help!

 

disk1config.PNG

diskconfig2.PNG

diskconfig3.PNG

Share this post


Link to post
Share on other sites

It may be too soon but I think I've fixed the issue. I've now created a few files and am now copying a large amount of data with no issues so far.

 

I had to set the second disk to Independent - Persistent.

Share this post


Link to post
Share on other sites
5 hours ago, luchuma said:

last screen 1.8 tb but only 18gb available on datastore

 

I see that now but it was unrelated. I quickly set that back up to get a screenshot for you and that goes away after clicking okay and letting the screen refresh.

 

Thank you helping though! Setting the second disk mode to Persistent - Independent fixed the issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.