BIOS Checksum bad


Recommended Posts

I have already asked the same question in the German section.

I want to install the DSM on a fujitsu pc with Phoenix BIOS.

everything works. But after a reboot, the BIOS will always reset.

I tried it on two computers. The problem occurs with both.

After rebooting I get the message "BIOS Checksum bad" and "use default settings".

Other operating systems like Windows or Linux Live CD work fine.

There is no problem with the bios battery.

 

Maybe someone has an idea?

 

thanks

Tom

Link to post
Share on other sites
  • 3 months later...

This is because of the DSM will reset hardware clock during booting, for auto power on and schedule task using.

The ways to fix this issue maybe are any one as below:

 

1.patch DMS some files.

2.change BIOS vendor.

3.setup CMOS to read only.

Link to post
Share on other sites
  • 2 weeks later...

Some Gigabyte boards do the same, but they will boot of the last known good BIOS config.

Have you tried to flash newer BIOS? is there a write protect jumper on board or BIOS setting?

Link to post
Share on other sites

i have seen the real problem

at the first when we reboot the syno i put an different date into system date

i had a problem with hwclock so someting don't work, but now i'ts okay i can use hwclock to put system date from hardware or either. (have to make a symlink between /dev/rtc0 and /dev/misc/rtc), without hwclock don't work.

 

but when i restart the syno put always 2 hours to his system date, and the bios don't reconize, so he tell me put F1 or DEL to enter bios, and i can boot with the default bios cause he dont boot on my usb...

 

i don't know why this fucking firmware always want to put 2 hour more at the system date, (i have previously correctly configure the date, and at each reboot / stop, the system change to +2h...)

 

i don't know how to fix this ... but it just a config problem i think

Link to post
Share on other sites

I am interested in this too, DSM always fucks up my BIOS and my motherboard does not have a CMOS write-only jumper unfortunately (I do not think that they put that on the new motherboards, last time I've seen it was with an old P3).

 

I also don't want DSM fiddling with my BIOS settings, I can do finetuning myself!

Link to post
Share on other sites

Mac OSX does the same thing on some PC's, but that's due to power management/sleep. Wonder if it's linked somehow too, might be worth looking on hackintosh forums. Maybe there is a kernel switch or grub command you can use.

Link to post
Share on other sites
  • 4 months later...
  • 2 weeks later...
  • 5 months later...
  • 1 month later...

I had the same problem with my n54l and xpneology. I had auto shutdown\powerup configured and every time the system starts the date and other settings for achpi settings were getting overwritten. I was trying few things together but seems like the issue is resolved after that. Not exactly sure which one of the below action resolved the issue.

 

1. I deleted the power options for shutdown\powerup.

2. Made changes to .conf file for WOL.

3. Made changes to the conf files for eSata changes.

4. Made bios password protected.

 

Now i dont have the bios reset issue :smile:. trying to fix couple of other issues and i am done :geek:

 

1. WOL works within my home network but not from outside the network.

2. eSata got identified after the conf file changes but it made my sata hdd connected (volume2) not recognize even though the hdd is detected in bios and all settings are proper. xpneology was not detecting the hdd connected to the sata port. So i had to revert the esata conf changes for hdd to detect in xpneology.

 

Jay

Link to post
Share on other sites