xpenfan

XPEnoboot Install - Blank Screen

Recommended Posts

Howdy,

 

I had this posted in the very long 5.2-5592.2 thread, but seeing that it's not specific to that version I wanted to post in a separate thread to hopefully get some help. I'd really like to get the latest version of XPEnology running and I'm hoping that others who have encountered this issue were able to resolve it.

 

When attempting to install a XPEnoboot boot image (5.1 or 5.2), I get to the initial selection screen, select install/upgrade, and then I see the "zlimage ... ok" message and then my screen goes blank and nothing happens. I've tried all XPEnoboot versions and this occurs. I've also tried various flash drives.

 

I can install the Nanoboot DSM-5.0-4528 DS3612xs image and accompanying PAT without issue. This version is currently running on my system.

 

Any ideas why the XPEnoboot versions will not install? Are there any tests I can run to find out why or tweaks I can make to get it going.

 

Thanks.

Share this post


Link to post
Share on other sites

I had the same issue, can't runing on bare metal. (Gigabyte 965P-DS4, CORE2 E6700, 4G RAM, Intel gigabit CT desktop adapter)

now, I run XPEnoboot at ESXi and it's OK.

Share this post


Link to post
Share on other sites

What kind of graphic card have you ?

 

@xpenfan : Give us more informations about your setup (mainboard, graphic card...)

Share this post


Link to post
Share on other sites

I had same problem with XPEnoboot 5.2 . (Gigabyte EP45-DS3, CORE2 quad Q6600, 2G RAM,MSI GT610 1Go DDR3 LP)

No worries with XPEnoboot 5.1.

Share this post


Link to post
Share on other sites

Gigabyte GA-X99-UD4 ATX LGA2011-3 Motherboard

Intel Core i7-5930K 3.5GHz 6-Core Processor

EVGA GeForce 8400 GS 1GB Video Card

Share this post


Link to post
Share on other sites
What kind of graphic card have you ?

 

@xpenfan : Give us more informations about your setup (mainboard, graphic card...)

 

 

My graphic card : GeForce 605 512M

Share this post


Link to post
Share on other sites

I had this issue when using an external graphics card. So long as you are using the onboard, it should be fine. On a bare-metal install, once you've selected the "upgrade/install" option, you should see a whole mess of command lines pop up, and then stop at "Disk Station Login" at which point you should be able to use the Synology assistant to detect the device and install through your PC's web browser.

Share this post


Link to post
Share on other sites

I don't have onboard graphics that's why I have the external card. I see the code with the nanoboot images so I know what you're referring to. Noboot images do not work.

 

Do folks install/run monitor-less?

 

I'm curious as to what causes this issue.

Share this post


Link to post
Share on other sites

No luck with a monitor-less install attempt. Nothing is being found with Synology assistant. I'm pretty sure I've got my keyboard timing's right without the monitor (after some practice). So even with my video card removed, I can't install.

Share this post


Link to post
Share on other sites

try resetting the bios to 'safe defaults' (or whatever the option is for that)

 

also, try

disabling all unnecessary peripherals (serial/parallel ports, audio etc)

set the HDD emulation to IDE

various USB settings for emulate HDD/legacy etc

disable the internal NIC and try an add in card (intel?) if you have one

 

look at your DHCP server to see if its giving an IP address to the NIC (internal or not)

Share this post


Link to post
Share on other sites

Tried everything I could in the BIOS, still no luck.

 

Could the onboard NIC really be the issue (I don't have an external lying around)? Again, nanoboot images work without a problem and I can get DSM 5.0 installed.

Share this post


Link to post
Share on other sites

internal nic suggestion was just in case it was upsetting boot process

 

try booting with a cd?

 

also try running XPE as an iso on a bootable yumi usb drive

Share this post


Link to post
Share on other sites

Thanks for all the suggestions sbv3000.

 

I think I've attempted everything without success.

 

Ultimately, it looks like the process just stops after selecting install/upgrade.

 

I think it's time to move to another O/S which is unfortunate. Something in the noboot image is preventing the installation.

 

I did successfully install 5.2 with ESXI but I do not want to take that route as the free version of ESXI is limiting my CPU.

Share this post


Link to post
Share on other sites

To sum up external graphics = blank screen and onboard graphic = good ?

 

If so It seems to me that the kernel is missing some part for display support.

Share this post


Link to post
Share on other sites

So seeing that I'm not a fan of a couple other O/Ses I've given this another try.

 

After cleaning/repartioning my USB drives, I was able to install with the 5.1 xpenoboot image with my external graphics card (no onboard graphics).

 

But not any 5.2 images.

 

So there's that. :smile:

Share this post


Link to post
Share on other sites
To sum up external graphics = blank screen and onboard graphic = good ?

 

If so It seems to me that the kernel is missing some part for display support.

 

Is there anything I could try/do with the img/iso to make 5.2 work?

Share this post


Link to post
Share on other sites
To sum up external graphics = blank screen and onboard graphic = good ?

 

If so It seems to me that the kernel is missing some part for display support.

 

Is there anything I could try/do with the img/iso to make 5.2 work?

 

Unfortunately no. The dev team have recompil kernel with more graphics support.

Share this post


Link to post
Share on other sites

Does that mean an updated image is upcoming?

 

Also, seeing that 5.1 does work for me, does it ultimately mean that whatever was included in 5.1, was removed in 5.2?

 

Thanks Trantor.

Share this post


Link to post
Share on other sites
Does that mean an updated image is upcoming?

 

Also, seeing that 5.1 does work for me, does it ultimately mean that whatever was included in 5.1, was removed in 5.2?

 

Thanks Trantor.

 

When Synology release DSM 5.2 they update the linux kernel to 3.10.35 so every parameters have to be set again and kernel have to be patched and recompiled.

I plan to make a thread with a todo list so the dev team know what to fix/update.

I hope this will help this project to go forward :smile:

No idea about an upcoming release.

Share this post


Link to post
Share on other sites

I can confirm the problem.

 

Gigabyte Ga-965P-DS3

Core2Duo E6700

Nvidia GT610

Sandisk Cruser blade

 

Boots with XPEnoboot_DS3615xs_5.1-5055.1.img, will not boot with anything 5.2 based

Share this post


Link to post
Share on other sites

I just tried an old computer with an asus a8n-e and nvidia 8400gs.

No blank screen issue.

Did you tried to boot in debug mode ?

 

In DSM 5.1 use lspci -qk command to show informations about pci.

If lspci command is not present boot a linux livecd like ubuntu and use lspci -qk

 

In 5.2 with the 8400GS I have:

DiskStation> lspci -qk
01:00.0 VGA compatible controller: NVIDIA Corporation G86 [GeForce 8400 GS] (rev a1)
       Subsystem: Gigabyte Technology Co., Ltd Device 3463

Share this post


Link to post
Share on other sites

In 5.1 with the lspci -qk command I get the following:

03:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] (rev a2)

Subsystem: eVga.com. Corp. Device 1302

 

I can't debug in 5.2 as I still get a blank screen.

Share this post


Link to post
Share on other sites

Did you try to add nomodeset parameter to grub ?

 

When booting press tab to edit the boot command line:

edit : APPEND root=/dev/md0 ihd_num=0 netif_num=4 syno_hw_version=DS3615xs sn=B3J4N01003 vid=0x0EA0 pid=0x2168 loglevel=0 vga=0x305

to : APPEND root=/dev/md0 ihd_num=0 netif_num=4 syno_hw_version=DS3615xs sn=B3J4N01003 vid=0x0EA0 pid=0x2168 loglevel=0 nomodeset

 

You can also edit syslinux.cfg

Share this post


Link to post
Share on other sites

With nomodeset I now get:

 

Loading /zImage... ok
early console in dcompress_kernel

Decompressing Linux... Parsing ELF... done.
Booting the kernel.

 

And it stops there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.