4TB Drives are being displayed as 2TB each


Recommended Posts

Hi Xpenologist,

I bought 2x4TB WD Red NAS drives for and added them in my DS3615xs (HP Z800 :P) but as I am using MBR version of loader System is telling me each drive is 2TB only.
 

 

did a little search on this and found that its due to MBR and max size is 2TB only.

 

Any way/workaround to fix this? 

 

Thanks and Regards

 

Link to post
Share on other sites

the z800 seem so have a intergated sas controller and from what i found and your symptoms its LSI SAS 1068E that has a hardware limit of 2.4TB for a disk, nothing you can do about it then using another controller like lsi sas 9211-8i and its clones (in IT mode) or a ahci sata controller (a two lane 88se9230 or a jmb585 would be working too, as its presumably only pcie 2.0 a one labe controller like 89se9215 would not be that good as it would only have max. 500MB/s on the one pcie lane)

9211-8i can have 8 sata ports and 8 pcie lanes and might be a good choice it its planned to be extended beyond sata 4 ports

(edit: if there are normal sata onboard from the chipset you could use them instead the sas ports and you might not need anything additional for you two disks)

Edited by IG-88
  • Like 1
Link to post
Share on other sites

I used removed to drives from SAS ports and plugged them in SATA port I can see the these are 3.67TB capacity drives but now DSM is not letting me create the volume.

System failed to create [Storage Pool 2](Device Type is [RAID 1]) with disk [Drive 2, Drive 3].

 

I tried to create storage pool with just one drive still the same 

 

System failed to create [Storage Pool 2](Device Type is [Basic]) with disk [Drive 2].

Edited by AbuMoosa
Link to post
Share on other sites

OK got everything working.
I noticed when I rebooted my HP Z800 I could see Non Raid Disk against my both new 4TB drives.


I setup raid by going into BIOS RAID admin utility (ctrl + I). Booted into DSM could configure drives in Raid 1 without any issue. :)

  

Link to post
Share on other sites
  • 2 weeks later...
Posted (edited)
5 minutes ago, bearcat said:

@AbuMoosa You should not be using HW Raid, but leave it up to DSM to make a software Raid.

In your BIOS, the drives *should* be configured as single drives, AHCI mode.

I know but DSM wouldn't let me configure these drives in raid config or was not even letting me use them standalone, see my post above.
I had to go this way as my HP Z800 was displaying these two as non raid drives (while booting). As soon as I configured them in raid in BIOS everything worked like a charm and DSM happily let me put those drives in a raid 1 config which was what I wanted :) 

Edited by AbuMoosa
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.