Автозагрузка Xpeno не раб или кривойБиос


Recommended Posts

Почему-то не получается сделать автостарт флешки с XPEnology на моей материнке.

Подробности:

DH67CF- плата MINIITX

Установил сборку DSM_DS3617xs_24922.pat + synoboot_3617 - Jun’s Loader v1.03b DS3617xs по этой инструкции: https://admincorner.ru/os/how-to-install-xpenology/.

Работает в режиме Биос Legacy , видно в сети но нет автозапуска со стартом ПК. Почему-то  биос не поддерживает автозагрузку этой UEFI-флешки-приходится выбирать принудительно старт с этого устройства с помощью клавы.

В режиме же UEFI  NAS в сети не видно. В режиме Legacy NAS видно .

Обновляял БИОС, еле нашёл прошивку поновее, но ситуация не изменилась.

DH67CF_ProductGuide.pdf

Link to post
Share on other sites

Привет.

Полностью аналогичная ситуация на inel nuc5ppyh.

На самом деле образ загрузчика универсальный - BIOS-UEFI. Видимо особенность(косяк) биос интел в режиме загрузки legacy не стартовать загрузку с таких флешек автоматически. С флешки чисто под биос стартует автоматически.

Я немного покопал тему и нашел топорное решение. Из образа нужно удалить каталог /EFI/boot/bootx64.efi. После этого биос перестает видеть флешку как загрузочную uefi и стартует автоматически в legacy.

 

По-хорошему нужно разбираться почему не запускается система в режиме EFI, legacy это костыль.

 

  • Like 1
Link to post
Share on other sites

Как видно, что запускается? По логам с com-порта?

Уточню, надпись на экране "Happy hacking", значит, что стартовал загрузчик, но не система.

Link to post
Share on other sites
В 21.09.2020 в 01:02, lukey сказал:

Как видно, что запускается? По логам с com-порта?

Уточню, надпись на экране "Happy hacking", значит, что стартовал загрузчик, но не система.

Даже так? не встречал такой инфы- только от вас. Ткните на инструкцию по диагностике запуска системы. Тоже показалось странным, что так быстро система загрузилась- оказывается загрузчик.

 

Link to post
Share on other sites
В 21.09.2020 в 01:02, lukey сказал:

Как видно, что запускается? По логам с com-порта?

Уточню, надпись на экране "Happy hacking", значит, что стартовал загрузчик, но не система.

Даже так? не встречал такой инфы- только от вас. Ткните на инструкцию по диагностике запуска системы. Тоже показалось странным, что так быстро система загрузилась- оказывается загрузчик. А в чем преимущества загрузки в режиме UEFI?

p.s. Всё получилось загрузить, удалив этот файл из образа. 

 

Link to post
Share on other sites

Надо подключаться к компорту и смотреть что идет в логе загрузки - 2 компа соединить по Com и через putty подключиться и смотреть

У меня были проблемы и с x79 чипсетом и с z87 - в UEFI не появлялся в сети.

Но при выборе Legacy загрузки все работает отлично. Еще надо проверить чтобы всякие fastboot  были отключены.

Скорее всего в UEFI для хренологии не проходит инициализацию сетевые устройства и из за этого не грузиться система.

 

 

  • Like 1
Link to post
Share on other sites

Поиск по форуму не дал ответа на вопрос- почему NAS не видит интернет и не подключается к службам synology, выдавая ошибку подключения?

Link to post
Share on other sites
23 часа назад, poroleo сказал:

Поиск по форуму не дал ответа на вопрос- почему NAS не видит интернет и не подключается к службам synology, выдавая ошибку подключения?

1. пробовал переключить загрузку в режим legacy ?

 

Link to post
Share on other sites
2 часа назад, -iliya- сказал:

1. пробовал переключить загрузку в режим legacy ?

 

Так сейчас только в легаси и может работать, в УЕФИ не видно НАС в сети. Почему то сам DSM не может подключиться к своим службам типа  Квик-коннект и т.п.

Link to post
Share on other sites
1 hour ago, poroleo said:

Так сейчас только в легаси и может работать, в УЕФИ не видно НАС в сети. Почему то сам DSM не может подключиться к своим службам типа  Квик-коннект и т.п.

Эти службы доступны только для оригинальных зарегистрированных серверов Сино в качестве дополнительных сервисов.

Link to post
Share on other sites
8 часов назад, XPEH сказал:

Эти службы доступны только для оригинальных зарегистрированных серверов Сино в качестве дополнительных сервисов.

Да, знаю и спасибо за напоминание. У меня есть ключ и мак от оригинала и не могу подцепиться из DSM к инету, хотя пакеты он закачал как-то и резервирование работает внутри локалки.. Сейчас больше в этом вопрос.

Link to post
Share on other sites
15 часов назад, poroleo сказал:

Почему то сам DSM не может подключиться к своим службам типа  Квик-коннект и т.п.

 

5 часов назад, poroleo сказал:

У меня есть ключ и мак от оригинала и не могу подцепиться из DSM к инету

У меня три валидных комплекта Серийник + МАк, но не один не виден работающим в Синолоджи Аккаунт. По сути, работает почти всё и так, кроме QuickConnect, да и в нём особой нужды нет

Link to post
Share on other sites

Я не могу подключиться из инета к NAS через роутер. Думал .что Коннект поможет, но он, значит, тоже не всесильный. Провайдер, наверно серыми ип играется поэтому сервис NO-IP толком не работает. За  белый нет желания платить из-за разовых подключений.

Link to post
Share on other sites
2 часа назад, poroleo сказал:

Думал .что Коннект поможет

Ну так есть заменители..... Тот же домен подключить, тот же DDNS. На форуме описаны решения

Вот одно из них

 

Link to post
Share on other sites
Только что, poroleo сказал:

Не получилось DDNS сделать, чтоб работало. По поводу фирменной подключалки- у многих так? 

image.png

Quick Connect не будет работать, никакая валидная пара уже не помогает.

2 часа назад, i926 сказал:

Ну так есть заменители..... Тот же домен подключить, тот же DDNS. На форуме описаны решения

При сером IP эти методы не помогут - так как выходит двойной NAT и соответственно провайдер даже если выдает один и тот же серый IP то не станет для вас пробрасывать порты.

DDNS работает только если вам выдают белый динамический IP.

Белый статический IP стоит то всего 150-170р в месяц.

 

  • Like 1
Link to post
Share on other sites
3 часа назад, poroleo сказал:

По поводу фирменной подключалки- у многих так?

Да.... Как раз так и выглядит Валидная пара не прошедшая регу на Синолоджи. У меня три таких

Link to post
Share on other sites
В 30.09.2020 в 20:38, -iliya- сказал:

Quick Connect не будет работать, никакая валидная пара уже не помогает

Почему? У меня работает.

В 24.09.2020 в 13:49, -iliya- сказал:

Но при выборе Legacy загрузки все работает отлично. Еще надо проверить чтобы всякие fastboot  были отключены.

Скорее всего в UEFI для хренологии не проходит инициализацию сетевые устройства и из за этого не грузиться система.

Стоит ли биться с UEFI, если с Legacy все работает?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.