Domske

Frage zum Update auf DSM 6.2x

Recommended Posts

Hallo zusammen,

 

ich besitze folgendes System:

 

MB: Intel DQ67SW

CPU: Intel i5-2500

RAM: 4x2 GB DDR3 RAM

keine zusätzliche Netzwerkkarte

HDD: 4x1 TB 

 

Auf diesem System konnte ich DSM 6.1.7 (DS3617XS) erfolgreich mit dem Loader 1.02b als Bare Metal installieren.

Nun möchte ich auf die DSM 6.2.x updaten und habe hierfür einen neuen USB-Stick mit dem Loader 1.03b erstellt. 

 

Beim Booten über BIOS erscheint nur ein blinkender Cursor, über UEFI ist das NAS ebenfalls nicht im Netzwerk erreichbar. Die Extra.lzma habe ich bereits im Loader (zweite Partition) ausgetauscht, ebenso die beiden anderen Dateien.

 

Ist es überhaupt möglich DSM 6.2.x auf meinem System zu installieren?

 

Für Rückfragen stehe ich gerne zur Verfügung.

Share this post


Link to post
Share on other sites
2 hours ago, Domske said:

Ist es überhaupt möglich DSM 6.2.x auf meinem System zu installieren?

sehe kein grund warum nicht, außer das es im bios den legacy modus geben muss (was bei dem alter sicher der fall ist) und das man beim booten auch das legacy usb device wählen muss

ansonsten fährst du im moment mit loader 1.03b und der mitgelieferten extra.lzma wohl besser und zum installieren nimmt man dann das neue dsm 6.2.3 das (im gegensatz zu 6.2.2) wieder kompatible mit den ursprünglichen treibern auf dem loader ist

 

Share this post


Link to post
Share on other sites

vielen Dank für Deine Rückmeldung.

 

Ich konnte mittlerweile das neue DSM 6.2.3 installieren. Allerdings musste ich hierfür den Loader 1.03b with MBR für ds3615xs nehmen. Eine Version für ds3617xs with MBR habe ich nicht gefunden. Gibt es hierfür auch einen Loader?

 

Das BIOS steht auf Legacy bzw UEFI Boot ist disabled + USB Stick als 1st device (keine Auswahl möglich ob legacy bzw. EFI) Beim ursprünglich verwendeten Loader 1.03b hatte ich über Legacy Boot nur den blinkenden Cursor, über UEFI sah ich wenigstens das Bootmenü (jedoch konnte das Gerät dann nicht im Netzwerk gefunden werden)

Share this post


Link to post
Share on other sites
Posted (edited)

Habe ein ähnliches Problem. Hardware mit B75 Intel Chipsatz und einem i3-2100 im 1155 Sockel. Netzwerkarte Intel Pro/1000 PT. Interne Realtek NICs wurden im Bios abgeschlatet.

 

6.1.7 mit Loader 1.02b läuft perfekt. Aber mit loader 1.03b ist das Gerät im Netzwerk nicht zu finden. Im Bios steht alles auf "legacy". Habe nun drei verschiedenen Sticks ausprobiert, laufen alle mit 1.02 aber kein Netzwerk mit 1.03. Habe 3615 und 3617 ausprobiert, macht keinen unterschied. Mit 1.02 im Netz sichtbar, mit 1.03 nicht.

 

Der Loader startet normal, sieht bei beiden Bootvorgängen (1.02 und 1.03) gleich aus am Monitor.

 

Woher bekomme ich bitte den Bootloader 1.03b with MBR für DS3615XS? Man findet Ihn hier im Forum: 

DSM 6.2 Loader (with MBR partition Table)

By Big_11

 

Vielen Dank

Edited by hgb_

Share this post


Link to post
Share on other sites
51 minutes ago, hgb_ said:

Woher bekomme ich bitte den Bootloader 1.03b with MBR für DS3615XS? Man findet Ihn hier im Forum: 

DSM 6.2 Loader (with MBR partition Table)

By Big_11

in der sektion "Member Tweaked Loaders" gibts einen thread

https://xpenology.com/forum/topic/20270-dsm-62-loader-with-mbr-partition-table/

 

und da drin ist im ersten post ein link zu dem loader

außerdem meine ich mich zu erinnern das mal jemand eine anleitung gepostet hat wie man den loader zu mbr wandelt

Share this post


Link to post
Share on other sites

Hallo IG-88,

 

den link habe ich gefunden, aber das war wohl leider nicht die Lösung.

 

mit dem Loader 1.03b MBR bootet er leider gar nicht. Es kommt die Fehlermeldung:

disk "gpt1" not found

entering rescue mode

grub rescue

 

Hat noch jemand einen Hinweis, wie man das alte Board auf DSM 6.2 bringen kann?

Share this post


Link to post
Share on other sites
42 minutes ago, hgb_ said:

mit dem Loader 1.03b MBR bootet er leider gar nicht. Es kommt die Fehlermeldung:

disk "gpt1" not found

entering rescue mode

grub rescue

 

Hat noch jemand einen Hinweis, wie man das alte Board auf DSM 6.2 bringen kann?

also wenn der 1.02b ohne mbr geht dann brauchts das imho auch nicht für 1.03b

bleibt also als unterschied das bei 1.03b kein uefi unterstützt wird, als noch mal biso wegen csm checken und sicher stellen das auch vom csm/legacy usb boot device gestartet wird, man kann bei vilen systemen csm aktiv haben und dann doch mit dem uefi boot device im uefi modus starten, dsm ist da nur eine option die nur greift wenn man auch vom csm/legacy device bootet

 

Share this post


Link to post
Share on other sites
Posted (edited)

Danke IG-88

 

ich habe nun zwei Tage am Bios rum geschraubt, und nun alles auf Legacy und den USB-Stick als First Boot Device, alle übrigen Boot devices deaktiviert. Ich denke der Trick war, den USB Stick auch im Gerät zu haben, vorher konnte ich ihn nicht sehen und daher auch nicht auswählen. CSM taucht in meinem Bios (Gigabyte GA-75N) als Begriff nicht auf.

 

Nun finde ich das NAS im Netzwerk und kann die Migration anstoßen. Mal sehen wie das geht. Gehe nach Deinem Hinweis direkt auf 6.2.3

Läuft soweit, mir fiel bisher nur auf, das in DSM 6.2.3. nun der Boot-USB Stick als externes Gerät angezeigt wird.

 

Edited by hgb_

Share this post


Link to post
Share on other sites
2 hours ago, hgb_ said:

nun der Boot-USB Stick als externes Gerät angezeigt wird.

sollte er eigentlich nicht, aber stört erst mal nicht, wenn man sich die grub.conf kopiert und weiß welche dsm version man hatte kann an den usb jederzeit neu erzeugen (falls man ihn versehentlich löscht), oder man macht sich einfach eine kopie mit "Win32DiskImager 1.0"

Share this post


Link to post
Share on other sites

ja, das war das Problem. Hatte den Loader auf einen anderen Stick kopiert, ohne die VID und PID in der Grub.cfg zu ändern. Mit der Angabe der korrekten VID und PID ist der Mount verschwunden und es läuft jetzt fast alles.

 

Mir ist noch aufgefallen, das der Power off task, den ich für 18 Uhr eingerichtet habe, nicht funktioniert in 6.2.3. Herunterfahren über das Menü funktioniert, nicht aber über den task. Darum muss ich mich morgen kümmern und ist hier auch der falsche Fred.

Share this post


Link to post
Share on other sites

Hast Du jetzt den Loader mit MBR verwendet?

 

Bei mir funktioniert das Hochfahren bzw. Herunterfahren ohne Probleme.

Share this post


Link to post
Share on other sites
1 hour ago, Domske said:

Hast Du jetzt den Loader mit MBR verwendet?

 

Bei mir funktioniert das Hochfahren bzw. Herunterfahren ohne Probleme.

 

Nein, bei mir läuft nun der normale 1.03b loader. Hoch- und runterfahren funktioniert auch, per Schalter oder im Menü (oben rechts in DSM).  Ich habe aber einen Energie-Zeitplan erstellt, der den Server nachts runter fährt und der hat nun nicht mehr funktioniert. Mal sehen, ob er morgen früh wieder hoch fährt.

Share this post


Link to post
Share on other sites
1 hour ago, hgb_ said:

Nein, bei mir läuft nun der normale 1.03b loader. Hoch- und runterfahren funktioniert auch, per Schalter oder im Menü (oben rechts in DSM).  Ich habe aber einen Energie-Zeitplan erstellt, der den Server nachts runter fährt und der hat nun nicht mehr funktioniert. Mal sehen, ob er morgen früh wieder hoch fährt.

evtl. mal im bios schauen ob es da was mit wake up und acpi gibt

Share this post


Link to post
Share on other sites

unwahrscheinlich IG-88, unter 6.1.7 lief es ja mit der gleichen Hardware und dem gleichen Bios. Ich denke aber, dass vielleicht noch ein anderer Task lief, der das Runterfahren zum Energiesparen verhindert hat. Wenn z.B. die Dateisystem Überprüfung oder Defragmentierung läuft, dann kann das doch das Herunterfahren blockieren. Teste ich morgen. Danke für Deine Hilfe.

Share this post


Link to post
Share on other sites

Hallo in die Runde!

 

Hab ähnliche Hardware und auch 6.1.7 am laufen. Wollte Fragen ob das Update auf 6.2.x bzw. die Migration ohne Datenverlust möglich war? Bzw. gibt genau dazu ein Tutorial?

 

Danke

Share this post


Link to post
Share on other sites
On 5/10/2020 at 10:25 AM, CharlieB said:

Wollte Fragen ob das Update auf 6.2.x bzw. die Migration ohne Datenverlust möglich war?

Ja, nach dem ich 1.03 zum booten gebracht habe, mit den entsprechenden bios Einstellungen (kein uefi), findet man den Synology Server im Netz und kann eine Migration anstossen. Dabei bleibt alles erhalten. Aber der Wechsel von Bootloader 1.02 zu 1.03 und die Einstellungen im Bios sind Pflicht, damit es soweit kommt. Hat aber alles reibungslos funktioniert. Bei mir war es aber auch nur der Server für das Backup. Also bitte vor der Umstellung ein Backup z.B. auf erxterne Platten machen.

Share this post


Link to post
Share on other sites
Posted (edited)

So nun kommt der Hautpserver dran und hier funktioniert das booten nur manuell. Aber vielleich hat noch jemand einen Vorschlag.

 

Intel S1200KP ITX Server Mainboard mit E3 1225 CPU und 8GB RAM.

Boote ich mit uefi eingeschaltet im Bios, bekomme ich keine Netzwerkadresse und kann das Gerät nicht sehen im heim. Netz. Das war zu erwarten. Also uefi deakitivert und USB boot auf enable und USB first boot device auf enable. Dann noch die Bootreihenfolge geändert und den usb Stick ganz nach oben. Muss ein Buck im Bios sein, denn beim Booten kommt dann die Fehlermeldung: No boot device. Man kann während des Boot Vorgangs F10 drücken, dann springt man ins Boot Menü. Der USB Stick ist der letzte in der Reihe, wähle ich diesen manuell aus, läuft alles durch. Aber bei jedem weiteren Bootvorgang kommt: No boot device, es sei denn ich wähle den Stick als Boot device manuell aus. Da ich den Server nachts schlafen lege um Energie und Lärm zu sparen, ist das eine nervige Angelegenheit. Aber von den Einstellungen sieht alles perfekt aus, nur versucht er immer von den Platten zu booten.

Hier scheint niemand das gleiche Board zu haben, das letzte BIOS ist bereits installiert. Die Einstellungen sehen auch gut aus (uefi disabled, usb boot enabled, usb first boot enabled, es gibnt keine CSM Einstellung in dem Bios)

 

Das MBR Image 1.03 (siehe oben) habe ich auch ausprobiert, das funzt aber nicht (was zu erwarten war). Noch einen Vorschlag, bevor ich ein neues Board kaufe?

 

Vorab Danke

 

Edited by hgb_

Share this post


Link to post
Share on other sites

anderen usb stick probieren (z.b. den vom backup system, das dann aber wegen mac dopplung nicht am netz sein sollte), mit usb stick ins beios gehen einstellungen speichern, reboot und wieder ins bios, usb als ersten boot festlegen, erneut versuchen ob er von usb bootet

gibts mehere usb geräte in der liste? gibts usb typ wie hdd, floppy usw.?

ich habe kein handbuch gesehen das diese punkte des bios genau zeigrt so das es schwer ist die einstellungen zu überprüfen oder vorschläge zu machen, do kanm es je nach bios erhebliche unterschiede geben

Share this post


Link to post
Share on other sites
Posted (edited)

Handbuch habe ich, gibts auch online. Aber es gibt nur ein USB device und drei Festplatten in der Bootliste, die ich manuell aufrufen kann. Und ja, es gibt auch removable (Floppy) , Optical (CD-Rom) und Network im BIOS Bootmenü, die ich alle disabled habe. Auch wenn ich diese enable ändert sich nichts an obiger Situation. Der Stick ist es nicht, habe zwei ausprobiert, wenn ich beim Bootvorgang per F10 interveniere, bootet er tadellos vom Stick und ist im Netz erreichbar und bereit für die Migration auf neues DSM. Mit dem nachweislich funktionierenden Stick aus dem Backup-System das gleiche Ergebnis. Ausgewählt als Bootorder first, aber bootet nur wenn ich manuel interveniere (F10 beim Bootvorgang) .Ferner habe nun auch einen Hinweis bekommen auf ein Hybrid MBR Stick, mit gdisk, was ich auch noch ausprobieren werde. Bios Batterie habe ich getestet, hat 3V und wenn ich Sie entferne gibt es beom Booten einen Time Error. Das war es also auch nicht.

IMG_20200524_153410klein.jpg

IMG_20200524_153822klein.jpg

Edited by hgb_

Share this post


Link to post
Share on other sites

was gibts aucher "normal" bei boot menu type?

was wird sichtbar wenn man revovable media einscahltet, nur enabled oder gibts auswahl

versuch mal hardddrive auf disable und nur removable media aktiv

Share this post


Link to post
Share on other sites

Versuch mal, ob Du unter „Boot Drive Order“ alles bis auf den Stick deaktivieren kannst. Also bspw. auf „P0...“ gehen und nachsehen, ob „Disabled“ gewählt werden kann.

Share this post


Link to post
Share on other sites
Posted (edited)

ausser normal gibt es advanced. Bei advanced kann man die Reihenfolge festlegen, bei normal nur die Art des Mediums. Da aber alle Medienarten ausser USB abgeschlatet sind (removable, optical und network) sind die beiden gleich. wenn ich advanced auswähle dann sind keine optical oder removable zu entdecken, egal ob enabled oder disabled. Auch kann ich leider nur die Bootreihenfolge ändern, nicht aber P0 oder P1 disablen. Wenn ich USB boot abschalte, taucht der stick natürlich gar nicht mehr auf. Boot USB first macht keinen Unterschied.

 

Danke für Eure Hilfe, habe nun bis auf "gdisk" alles ausprobiert, er bootet den 1.02 stick, nicht aber den 1.03 stick. DSM 6.1.7 ist ja auch schön, für das was ich mit dem NAS mache.

IMG_20200524_175112klein.jpg

Edited by hgb_

Share this post


Link to post
Share on other sites
On 5/23/2020 at 1:10 PM, hgb_ said:

Ja, nach dem ich 1.03 zum booten gebracht habe, mit den entsprechenden bios Einstellungen (kein uefi), findet man den Synology Server im Netz und kann eine Migration anstossen. Dabei bleibt alles erhalten. Aber der Wechsel von Bootloader 1.02 zu 1.03 und die Einstellungen im Bios sind Pflicht, damit es soweit kommt. Hat aber alles reibungslos funktioniert. Bei mir war es aber auch nur der Server für das Backup. Also bitte vor der Umstellung ein Backup z.B. auf erxterne Platten machen.

 

Danke! Lief problemlos ...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.