pippopluto9393

Wake on Lan - Accendere synology fa cellulare

Recommended Posts

Ciao a tutti.

Scrivo anche nella sezione italiana perché su quella internazionale nessun suggerimento mi ha risolto il problema.

 

Sto cercando da tanto tempo di utilizzare la funzione Wake On Lan.

 

Ho abilitato Wake On Lan sulla mia motherboard : http://www.asrock.com/mb/AMD/AM1H-ITX/

Ho provato il seguente tutorial : http://www.xpenology.nl/wake-on-lan/

Utilizzo Nanoboot (5.0.3.2) DSM 5.0-4528 Update 2.

 

Ma tutte le prove sono fallite.

 

Qualcuno è riuscito?

 

Grazie

Share this post


Link to post
Share on other sites

Ciao Pippopluto anche io sarei interessato al WAL sul mio HP N54L! Purtroppo la guida non l'ho ancora provata (ho paura di sbagliare alcuni passaggi per via del mio inglese non perfetto). Se riesci a trovare un metodo più semplice e magari con istruzioni in italiano te ne sarei davvero grato! Buone feste a tutti e grazie di cuore a chi ha aperto questa sezione italiana!! :smile:

Share this post


Link to post
Share on other sites

Dunque, andiamo con ordine, il Wol funziona SOLO su una rete cablata ed in rete locale in quanto manda uno specifico pacchetto dati chiamato magic packet, ad un specifico mac-address ossia quello della synology, in sintesi lavora a livello 2 della pila ISO/OSI

 

http://it.wikipedia.org/wiki/Open_Systems_Interconnection

 

Al link sopra trovate una spiegazione della pila e i vari livelli di astrazione.

 

Per abilitare il wol sulla synology occorre che l'hardware sia configurato, non ricordo se i vari serverini HP hanno questa possibilita', le nuove mobo credo di si.

Share this post


Link to post
Share on other sites

sono abbastanza pratico di WAL allora il microserver HP N54L ha la scheda idonea ed ho attivato il servizio da bios, il problema è come attivarlo per farlo funzionare sul sistema xpenology poichè, da quanto ho capito leggendo i vari forum in inglese, bisogna modificare alcuni file di configurazione del sistema operativo che rimandano ad un mac address fittizzio e non il reale della scheda di rete...ulteriori info sono ben accette! (ps ho abilitato le varie porte sul router per poter trasmettere e ricevere il c.d. magic packet) :wink:

Share this post


Link to post
Share on other sites

Veramente io ho letto che ci va' messo il VERO mac-address e non uno fittizio.

Share this post


Link to post
Share on other sites
:grin: Si hai ragione mi sono espresso male io...volevo dire?che xpenology assegna un mac addresse fittizzio e?che quindi bisogna modificarlo con quello reale. È li il punto, la procedura non riesco a comprenderla :shock:

Share this post


Link to post
Share on other sites

vediamo di scrivere la procedura per abilitare il WOL

Prerequisiti

Una synology funzionante, la chiavetta usb con cui fate il boot, conoscenze minime di unix ( editing di testo) un client ssh con sui collegarsi alla synology e che ci servira' per copiare un file nella synology stessa, se non sapete come copiare i file con il clien putty, cercate in rete, e' pieno di esempi :grin:

 

Per prima cosa assicuriamoci che il WOL sia abilitato da bios, per fare cio', fate riferimento al manuale della vostra piastra madre.

Una volta abilitato il WOL a livello bios dobbiamo fare qualche operazione sulla synology

Connettiamo la chiavetta di boot al nostro pc, dentro la stessa troverete un file che si puo' chiamare o ‘syslinux.cfg‘ o ‘menu_nano.lst‘ apritelo con un editor di testi, il contenuto e' identico per entrambi i file ed e' una cosa simile a questa

 kernel /zImage ihd_num=0 netif_num=4 syno_hw_version=DS3612xs sn=B3J4N01003 vid=0x0EA0 pid=0x2168 loglevel=0 vga=0x305

la parte dove inserire il mac-address e' la seguente

kernel /zImage ihd_num=0 netif_num=4 syno_hw_version=DS3612xs sn=B3J4N01003 mac1:xxxxxxxxxxxx vid=0x0EA0 pid=0x2168 loglevel=0 vga=0x305

Come potete vedere subito dopo il serial number c'e' mac1:xxxxxxxxxxxx ecco al posto delle x ci va' messo il mac-address VERO della scheda di rete con la quale la synology si collega alla vostra rete, salvate il file, sfilate la chiavette, rimettetela nella synology accendetela e aspettate che abbia fatto il boot.

A questo punto scaricatevi questo file https://drive.google.com/file/d/0B8bHHUWAxe2kaGU4UktXalFvajA/edit?usp=sharing, scompattatelo , otterre un file dal nome

S99ZZZ_Shutdown.sh

Questo file andra' copiato nella synology dentro la cartella

/usr/syno/etc/rc.d

per copiarlo con putty il comando e'

 pscp  S99ZZZ_Shutdown.sh root@ip.della.synology:/usr/syno/etc/rc.d

Il comando dice sostanzialmente copia il file S99ZZZ_Shutdown.sh nella cartella /usr/syno/etc/rc.d/ nella synology all indirizzo ip ip.della.synology, una volta dato invio vi chiedera' la password di root che e' la stessa di admin.

Copiato il file dobbiamo cambiargli i permessi

collegatevi via putty alla synology, una volta entrati digitati questo comando

 chmod 755 /usr/syno/etc/rc.d/S99ZZZ_Shutdown.sh

questo comando cambia i permessi del file S99ZZZ_Shutdown.sh in modo che sia eseguibile.

Modifichiamo il file di configurazione della synology in modo da abilitare il wol sulla scheda di rete.

vi /etc/synoinfo.conf

cercate queste righe

wol_enabled_options="" 
eth0_wol_options=""

e modificatele cosi'

wol_enabled_options="g" 
eth0_wol_options="g"

Come potete notare c'e' la lettera "g" tra i doppi apici, salvate il file e riavviate la synology

Ora dovete usare l'assistente per abilitare la synology, quindi aspettate che abbia terminato il boot, lanciate l'assistente e accertatevi che la synology sia correttamente individuata.

dovreste avere una schermata simile a questa

https://www.dropbox.com/s/iwg8fdlegj6h0uq/wol2.png?dl=0

Cliccate col tasto destro sulla synology e vedrete apparire un menu' tra cui trovate l'opzione WOL, andateci sopra col mouse e avrete 3 opzioni Attivazione, impostazione, rimuovi.

Andiamo su impostazione, vi si apre una maschera nella quale dovrete inserire il mac address nel formato: 1a:2b:3c:4d:5e:6f che deve essere il mac address che lo stesso assystant vi rileva, fatto questo, di nuovo tasto destro, WOL e andate su Attivazione, a questo punto se il WOL e' attivo dovreste avere un pallino rosso sotto "Stato WOL" , per sicurezza riavviate la NAS se tutto e' andato bene dovreste poter spengere e avviare la nas usando il magic packet.

 

Se c'e' qualcosa che non capite, fatemelo notare, ho volutamente tralasciato la parte di editing dei file su linux e l'uso di pscp per copiare sulla synology, mi aspetto che sappiate come si fa.

Good Hacking :mrgreen:

Share this post


Link to post
Share on other sites

Grandissimo Aigor mi hai aperto un mondo! Un ultimo consiglio senza rientrare nel bios del mio hp n54l c'è un modo che tu sappia per vedere il mac addresse della scheda? Magari un comando particolare...grazie di cuore

Share this post


Link to post
Share on other sites

In ssh sulla synology digita ifconfig tra i parametri che ti mostra vedi anche il Mac,oppure usa l assistente

 

send from my Zopo with topatalk

Share this post


Link to post
Share on other sites

Allora Aigor vediamo se riesci ancora ad aiutarmi...ho effettuato tutti i passaggi perfettamente sino alla copia del file S99ZZZ_Shutdown.sh nella cartella /usr/syno/etc/rc.d/, ho modificato i permessi come descritto (per sicurezza ho controllato i permessi e sono giusti) poi quando vado a modificare il file /etc/synoinfo.conf mi accorgo di una cosa strana ovvero non trovo tutte e due le voci da te indicate per modificarle...a titolo di cronaca ti posto il txt del mio file synoinfo da cui vedrai che mi manca la voce eth0_wol_option

 

wol_enabled_options="g"

usbportcfg="0xf00000"

internalportcfg="0xfff"

support_write_cache="yes"

support_webinstall="yes"

max_iscsiluns="512"

support_ssd_cache="yes"

max_iscsitrgs="64"

support_glusterfs="yes"

eth0_wol_options="d"

surveillance_camera_max="50"

s2s_task_max="16"

support_iscsi_plugin="yes"

audio_support_eq="yes"

supportsystempwarning="yes"

support_trim="yes"

eunitseq="sdm,sdq"

max_volumes="1024"

display_ssd_compatibility="yes"

max_ha_spacecount="64"

cache_support_skip_seq_io="yes"

support_wol="yes"

max_lunbkp_srv="16"

netif_seq="0 2 1 3"

sysctl_kernel.sem="250 32000 32 256"

eth7_mtu="1500"

eth6_mtu="1500"

eth5_mtu="1500"

eth4_mtu="1500"

eth3_mtu="1500"

eth2_mtu="1500"

eth1_mtu="1500"

eth0_mtu="1500"

maxlanport="8"

 

# Fixed items

eventtest="off"

runapple="yes"

codepage_apple="1850"

sftpPort="22"

support_net_topology="no"

usb_standbytimer="0"

runsurveillance="no"

join_user_data_collect="no"

net_topology="client"

custom_login_title="Orso NAS"

weather_info="display"

login_style="dark"

login_logo_customize="no"

login_background_customize="yes"

login_only_bgcolor="no"

WebDavPort="5005"

portcheck="yes"

upgrade_pkg_dsm_notification="yes"

upgrade_pkg_email_notification="no"

service_fw_target_interface="all"

forget_password_enable="no"

strong_password_enable="no"

enable_homeshare_recyclebin="yes"

userHomeEnable="yes"

 

# Fixed items

runphoto="no"

arp_ignore="no"

runnatpmpportmapping="no"

runupnpportmapping="no"

runHTTPS="yes"

redirectHTTPS="yes"

login_background_color="#FFFFFF"

login_background_position="center"

login_background_type="default"

login_background_ext=".jpg"

login_background_seq="3"

enable_pkg_autoupdate_all="yes"

pkg_def_intall_vol="/volume3"

showpooltab="yes"

autoblock_attempts="5"

autoblock_attempt_min="5"

 

# Fixed items

 

# Fixed items

supportphoto="yes"

supportphotopersonal="yes"

configured="yes"

pkg_autoupdate_all="no"

 

# Fixed items

 

# Fixed items

runmediaservice="no"

 

# Fixed items

support_audio="yes"

support_transcode_mp3="yes"

runaudiostation="no"

 

# Fixed items

support_download="yes"

FB_SHARING_HTML_SETTING="true"

FB_SHARING_GOFILE_PROTOCOL="http"

FB_SHARING_SETTING="all_user"

Edited by Guest

Share this post


Link to post
Share on other sites

Cerchi male :mrgreen:

th3_wol_options="d"
support_generic_ssd="yes"
eth2_wol_options="d"
support_zram="yes"
supportraid="yes"
eth1_wol_options="d"
wol_enabled_options="g"
usbportcfg="0xf00000"
internalportcfg="0xfff"
support_write_cache="yes"
support_webinstall="yes"
max_iscsiluns="512"
support_ssd_cache="yes"
max_iscsitrgs="64"
support_glusterfs="yes"
eth0_wol_options="d"

 

Un consiglio, quando devi postare righe come queste, usa l'opzione "Code" dal menu' completo per rispondere si legge meglio

Share this post


Link to post
Share on other sites

Amico mio se passi in calabria il caffè come minimo è pagato!!!! Finalmente dopo mesi e mesi sono riuscito a far partire il WOL sul mio HP N54L. Appena finito di testare dal telefono sia su stessa reta wifi sia dall'esterno con connessione dati 3g...che dire SPETTACOLO!!!! Finalmente potrò smettere di programmare le accensioni ad ore prestabilite solo per sporadiche connessione al server!!! Ti STIMO!!! :razz::razz::razz::grin::grin:

Ora aspetto che passi un pò di tempo affinchè la versione 5.1 sia testata a dovere ed aggiorno :mrgreen:

Share this post


Link to post
Share on other sites

:mrgreen: Ti ringrazio, se interessa domani posto un'altra guida per abilitare lo spegnimento da pulsante, ossia premendo il pulsante fa' uno shutdown pulito.

Non e' farina del mio sacco, mi sono limitato a leggere nel forum inglese come si fa, l'ho sperimentato sulla mia nas e funziona.

Tieni presente che se aggiorni devi rifare l'intera pappardella per far funzionare il WOL, in generale, qualunque modifica fai "a mano" sul sistema, la devi rifare se cambi release di DSM

Io invece sono riuscito a far andare l'Ata Over Ethernet sulla synology, ma ho dovuto compilare della robina a mano, sarebbe una buona cosa se si riuscisse a fare un package in modo da dare la possibilita' a tutti di usarlo, ma personalmente non saprei da che parte iniziare visto che sono completamente a digiuno di roba php e html.

In sintesi, l'AOE e' come l'iscsi ma funziona su rete ethernet locale, questo fa parte del mio "progettoo" per fare della NAS sia un boot server che un eventuale "storage" per macchine fisiche non dotate di disco, in sintesi una ipotetica macchina potrebbe fare il boot da rete installare il sistema operativo su un disco di rete, e funzionare con quel disco di rete senza che sia necessario un disco fisico.

Share this post


Link to post
Share on other sites

Ho cantato vittoria troppo presto :sad: ovvero ha funzionato perfettamente ma stamattina alla riaccensione non funge più nulla.....nooooooooooooooooo hai idee ?

Share this post


Link to post
Share on other sites

Credo di aver risolto! (almeno ora ho provato varie volte e va) in pratica avevo modificato le impostazioni di rete della synology disattivando il dhcp e dandogli IP interno statico, ora ho rimesso tutto come prima!

Ogni tanto mi vengono strane idee heheheheh avevo già impostato sul router la reservation per l'IP della synology e l'apertura delle porte per quella reservation ed ovviamente disattivando il DHCP non instradava correttamente i magic packet!!

PS: Volevo chiederti in merito al tuo esperimento di Ata Over Ethernet dovendo tenere disponibili interi fylesistem per bootare le eventuali macchine che hai linea dedicata per il notevole flusso dati? :mrgreen:

Edited by Guest

Share this post


Link to post
Share on other sites

certo perchè forse avrai fatto altre configurazioni nelle regole del router per le porte!

Share this post


Link to post
Share on other sites

a parte le solite, ho solo forwardato la porta 9 udp sull indirizzo synology sempre sulla porta 9

Share this post


Link to post
Share on other sites

Ciao Aigor, grazie per la guida sull'attivazione del WOL.

 

Mi chiedevo se avevi poi scritto qualcosa per abilitare il pulsante di accensione/spegnimento...... è qualcosa di "universale" o solo per N54 ?

Io ho una mb Gigabyte.

 

Sarebbe interessante avere un tasto fisico come sulla Syno vera.

 

:mrgreen: Ti ringrazio, se interessa domani posto un'altra guida per abilitare lo spegnimento da pulsante, ossia premendo il pulsante fa' uno shutdown pulito.

Non e' farina del mio sacco, mi sono limitato a leggere nel forum inglese come si fa, l'ho sperimentato sulla mia nas e funziona.

Share this post


Link to post
Share on other sites

Ciao Aigor, grazie per la guida sull'attivazione del WOL.

 

Mi chiedevo se avevi poi scritto qualcosa per abilitare il pulsante di accensione/spegnimento...... è qualcosa di "universale" o solo per N54 ?

Io ho una mb Gigabyte.

 

Sarebbe interessante avere un tasto fisico come sulla Syno vera.

 

:mrgreen: Ti ringrazio, se interessa domani posto un'altra guida per abilitare lo spegnimento da pulsante, ossia premendo il pulsante fa' uno shutdown pulito.

Non e' farina del mio sacco, mi sono limitato a leggere nel forum inglese come si fa, l'ho sperimentato sulla mia nas e funziona.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now