0zzy

info mac address

Recommended Posts

Hi all, i'm following this site to install DSM on my desktop machine, i have one very very noob question, but reading this forum i have read some answer that confuse me:

 

in grub, i have  to write the mac address of my pc nic (i suppose), is it right?

becouse i also read that i have to use instead an original synology mac address  matching the serial number i had specified in my grub.

 

Is it right or i'm wrong?

 

Share this post


Link to post
Share on other sites

if just want to test you dont need to set the mac, onöy if you want to use wake on lan then the real mac is needed in grub.cfg

in some cases (hardware transcoding?, some plugins like surveillance station) you need a valid serial number an a matching mac address

things like mac and serial can be changed later if needed

just install with vid/pid of you usb in grub.cfg and find out what you want to do with dsm

Edited by IG-88

Share this post


Link to post
Share on other sites

HI @IG-88, so if i can't find my desktop with mysynology is not becouse a wrong mac address, but my nic is not supported, is it right?

I have tried also extra ramdisk but unsuccessfully, i can't see my desktop on the netwrork.

I have found an Intel pcie card in the attic, i'll retry with this nic.

Share this post


Link to post
Share on other sites
1 hour ago, 0zzy said:

so if i can't find my desktop with mysynology is not becouse a wrong mac address, but my nic is not supported, is it right?

yes, but also check your cables and dhcp server

also try the synology assistant (program you can download from synology) to find your system in network

what the systemboard and processor? what loader did you try

you might start with 1.02b loader for testing, that has been used a lot so its reliable for testing too (also the additional extra.lzma has been tested more)

 

edit: for finding it in network you even dont need to change the vid/pid, that is checked when installing the *.pat file to disk, so for just trying out loader and extra.lzma you can throw on the unmodded imgae to usb

 

Edited by IG-88

Share this post


Link to post
Share on other sites

I have tried synology assistant but with the same results.

My network infrastrucure is ok i have other pc connected by the same dhcp. I have booted this machine with a win10 live cd and all nics are up and working.


My desktop is composed by:

- Intel i3-2100 CPU @ 3.10GHz (4 cores)
- mobo MSI h61m p23 (b3) chipset VIA® VT1708S and 4GB ram
- integrated nic Qualcomm Atheros AR8151
- pcie nic  tplink tg3468(un)
- pcie nic  intel pro 1000 pt
- 8x1TB  2.5" drive, 4 connected on integrated sata port and 4 on sata3 pcie adapter (startech pexsat34rh)

 

I have tried loader 1.02 also with extra.lzma, and with intel pro1000 nic but  i can't still find my desktop on the network

 

I have a a serial port, so i can use it for debug, is it right? I'll take a serial/usb cable at work tomorrow and i'll try again before testing all loaders (v1.02-v1.03-v1.04) without changing them.

Share this post


Link to post
Share on other sites
3 hours ago, 0zzy said:

Intel i3-2100 CPU @ 3.10GHz (4 cores)

so 916+ or 918+ (loader 1.04b) will not work, no need to test (4th gen intel aka haswell is minimum)

 

3 hours ago, 0zzy said:

Qualcomm Atheros AR8151

atl1c.ko

 

3 hours ago, 0zzy said:

pcie nic  tplink tg3468(un)

realtek 8168e chip -> r8168.ko

 

3 hours ago, 0zzy said:

pcie nic  intel pro 1000 pt

Intel 82571GB -> e1000e.ko

 

the e1000e is part of dsm's native driver set for 3615/17 and the atheros and realtek are part og jun's default driver set

all 3 should work

 

3 hours ago, 0zzy said:

4 on sata3 pcie adapter (startech pexsat34rh)

Marvell - 88SE9230, AHCI, no problems to expect

 

3 hours ago, 0zzy said:

I'll take a serial/usb cable at work tomorrow

nullmodem cable and on the terminal side you can use a usb2serial adapter if there is no serial

that way you should see whats going on

 

Share this post


Link to post
Share on other sites

I'm trying to use teraterm or putty, but which configuration have i to use? boud rate ecc..?

 

 

---- a few mins later----

 

 

 

ok, i can't connect by serial port, but i have successfully installed DS3615xs 6.1 Jun's Mod V1.02b

How long does it take to go online? This time i went to dinner, and after that, i have run synlology assistant..and tadaaa..surprise!

 

I want to try all other version now, but i have some other question for you:

- i can use any synology DSM accorging to the right loader? or better: if i have 8 drive, can i use a DSM that natively works with only 4 drive? for ex: ds916 is 4 bay nas, can i install it even if i have 8 drive in my pc?

 

- i have used loader DS3615xs 6.1 Jun's Mod V1.02b, i don't have changed anything, no PID/VID, but i have installed DSM in any case, so when i have to change pid/vid? 

Edited by 0zzy

Share this post


Link to post
Share on other sites

hi @IG-88, i 'm tring loader 1.03b for dsm 3615 but when system reboot,  after the installation of dsm (using web interface), the contowrn is still running, i can ping it,  but i can't access and complete the installation/setup. How can i check what's wrong?

Edited by 0zzy

Share this post


Link to post
Share on other sites

if you install with 1.03b then you have to use 6.2 (0)

https://archive.synology.com/download/DSM/release/6.2/23739/DSM_DS3615xs_23739.pat

if you update to 6.2 or use web install then at least atheros and realtek driver will fail

so try 23739 and for later version wait for the new driver package that is compatible with 6.2.2 (24922)

Share this post


Link to post
Share on other sites
22 hours ago, IG-88 said:

if you install with 1.03b then you have to use 6.2 (0)

https://archive.synology.com/download/DSM/release/6.2/23739/DSM_DS3615xs_23739.pat

if you update to 6.2 or use web install then at least atheros and realtek driver will fail

so try 23739 and for later version wait for the new driver package that is compatible with 6.2.2 (24922)

 

it is strange, becouse, i have used DSM_DS3615xs_23739 as you suggested, and my nic during this test is an Intel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.