• 0
Sign in to follow this  
Maksyuha

Ошибка при загрузке без клавиатуры

Question

Приветствую уважаемое сообщество! Досталась мне по случаю материнская плата SUPERMICRO X7SPA-H с процессором Atom D510 на борту и 2 гига оперативной памяти. Решил попробовать установить Xpenology, давно хотел. Установил, все заработало, мне понравилось! Загрузчик использовал 1.03b от DS3615. Имеется проблема, когда отключаю USB клавиатуру, загрузка вываливается с ошибкой. Насколько понимаю, нужно править grub.cfg, но что править, не знаю. Пролистал всю ветку, ничего похожего не нашел с моей проблемой, возможно пропустил. Нужна помощь. Как решить проблему? С чего начать? Смог сделать только фотографии с ошибкой! Заранее спасибо!IMG_6072.thumb.jpg.9af2b7c6b54ef585db97f5328852bf2d.jpgIMG_6073.thumb.jpg.cf4d5d56e6add0fa4d81348051d5b529.jpg

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
9 минут назад, i926 сказал:

Было бы неплохо, этот параметр озвучить

Без проблем! Переключение количества активных портов USB с 12 на 10.

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Maksyuha сказал:

нужно править grub.cfg

А вы вообще его правили как нибудь ? Отредактировали под себя VID и PID, Mac, серийник ?

Судя по скрину, у вас ошибка чтения сектора. Имеет смысл проверить ваш Хард

Edited by i926

Share this post


Link to post
Share on other sites
  • 0
7 часов назад, i926 сказал:

А вы вообще его правили как нибудь ? Отредактировали под себя VID и PID, Mac, серийник ?

Судя по скрину, у вас ошибка чтения сектора. Имеет смысл проверить ваш Хард

Конечно-же я правил grub.cfg, VID и PID под свою флешку, SN, два mac, SATA. При подключённой клавиатуре загрузка происходит в штатном режиме, как только отключаю клавиатуру, получаю то, что на скрине выше. Я тоже обратил внимание, что ошибка связана с hd0, но вопрос почему только тогда когда отключаю клавиатуру? Такое ощущение , что grub ждёт ввода с клавиатуры и не видя ее вываливает ошибку.

Share this post


Link to post
Share on other sites
  • 0

Хм.... В загрузчике есть выбор из трёх пунктов загрузки, но если не выбрать, то автоматом запускается первый пункт. Запускается обычная загрузка и без клавиатуры. Вы должны сами это видеть на мониторе.

Запуск без клавиатуры пробовали ? Если не успеваете прочесть выбор пунктов загрузчика, то надо отредактировать в grub.cfg пункт: "settimeout" , выставить больше чем "1" значение

 

Share this post


Link to post
Share on other sites
  • 0

А что за железо? Давно на буржуйском форуме у чела без подключенной клавы, сеть не поднималась...

Share this post


Link to post
Share on other sites
  • 0
7 часов назад, i926 сказал:

Запуск без клавиатуры пробовали ?

Да, конечно же пробовал, я об этом писал выше. С клавиатурой загружается все штатно, я вижу 3 пункта на выбор, ровно 1 секунду, менял в конфигуратор на 5 секунд, после этого видел 3 пункта на выбор уже 5 секунд и т.д. Без подключённой клавиатуры этих 3-х пунктов не появляется.

Один из форумчан с ником Adic, любезно подсказал, что нужно шаманить в биосе, он с таким сталкивался на этих матерях, приеду вечером домой буду пробовать.

Share this post


Link to post
Share on other sites
  • 0

Ну тут только одно и есть, что БИОС копать.

41 минуту назад, Maksyuha сказал:

я вижу 3 пункта на выбор

По сути, первый пункт загружается автоматом. Видеть его не обязательно, как и выбирать клавой

Share this post


Link to post
Share on other sites
  • 0
9 часов назад, i926 сказал:

Запуск без клавиатуры пробовали ?

Да, конечно же пробовал, я об этом писал выше. С клавиатурой загружается все штатно, я вижу 3 пункта на выбор, ровно 1 секунду, менял в конфигуратор на 5 секунд, после этого видел 3 пункта на выбор уже 5 секунд и т.д. Без подключённой клавиатуры этих 3-х пунктов не появляется.

 

Share this post


Link to post
Share on other sites
  • 0

Всем спасибо, вопрос закрыт! Особая благодарность Adic! Проблема была в одном из параметров Bios, причём никакого отношения не имевшего к вываливаемой ошибке.

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Maksyuha сказал:

Проблема была в одном из параметров Bios

Было бы неплохо, этот параметр озвучить. Думаю, рано или поздно кто то ещё столкнётся со схожей проблемой и решение не помешает.

Share this post


Link to post
Share on other sites
  • 0
Вопрос в этой ветке был отвечен и решение найдено. Ветка закрыта. Если есть дополнительные вопросы, пожалуйста откройте новую ветку.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this