haze

5.2->6.2 Jun Loader 1.03b = No Network Connection

Recommended Posts

ASRock Q1900-ITX

DS3617xs

DSM 6.2-23739

 

I upgraded from 5.2 to 6.2 using Jun's loader 1.03b. I logged in and all looked good until .... I noticed an alert on Control Panel.  It checked for an update, but said "Connection failed. Please check your Internet connection." I Googled the error and it said to check network settings under Control Panel. It shows that I have no network connection. Yet ... I am able to connect from my MacBook Pro. I was even able to update/install packages. I had to manually run File Station after update, but now I see my files. 

 

However, I have to click on run File Station all of the time for it to actually run. Same with other packages like Plex, Transmission, etc. They don't just run automatically and if I logout and log back in they are no longer running. I can't get download station to run. It says "Failed to run the package service."

Also, I can't turn on AFP/SMB to actually access them on the network and the DSM thinks there is no network connection.

 

Long story short I upgraded, I can login, System Health says good, I can install packages, etc. But ... I can't actually access my files, use some services like download station, and services won't stay running after I update/download/run the package.


 

Screen Shot 2018-08-10 at 12.48.53 PM.png

Screen Shot 2018-08-10 at 12.49.12 PM.png

Screen Shot 2018-08-10 at 12.49.30 PM.png

Share this post


Link to post
Share on other sites

Hi haze,

 

I have the same issue after upgrading my N54L.

We did something wrong. Anyone have a hint where we can look?

Share this post


Link to post
Share on other sites

Hi haze,

 

just delete the .xpenoboot folder located in the root folder. Reboot. Enjoy.

Share this post


Link to post
Share on other sites
12 hours ago, pacemaker said:

Hi haze,

 

just delete the .xpenoboot folder located in the root folder. Reboot. Enjoy.

thx... worked for me

Share this post


Link to post
Share on other sites
6 hours ago, haze said:

@pacemaker 

 

Thanks. Pardon my ignorance ... But ... how exactly do I do that? 

 

Hi haze,

 

try these steps:

  1. Activate the SSH service in DSM
  2. Connect to your Synology with an SSH client (e.g. putty)
  3. Enter your credentials (user: admin)
  4. Change folder to root (cd /)
  5. Delete the folder (sudo rm -r .xpenoboot)

If the SSH service keeps stopping, you have to be quick.

  • Like 1

Share this post


Link to post
Share on other sites

Awesome dude. You are a genius. That worked great. I had been down for over two weeks with no solution.

Share this post


Link to post
Share on other sites
On ‎8‎/‎12‎/‎2018 at 9:01 AM, pacemaker said:

Hi haze,

 

just delete the .xpenoboot folder located in the root folder. Reboot. Enjoy.

Any idea why this works?

Share this post


Link to post
Share on other sites

Afaik this is a remnant from an old bootloader. Not the one from jun but an earlier version. I have my Syno running for a long time (years) now without wiping it.

Share this post


Link to post
Share on other sites
Posted (edited)

Just want to add my two cents ...

 

I just updated my Q1900 (DS3617xs) -- baremetal, Jun 1.03b loader -- from 6.1 to 6.2.  The upgrade was smooth EXCEPT, on reboot, my network "Lan 1" disappeared.

I know there's nothing wrong with the onboard NIC as I can access the DSM web GUI.

Not having the "network interface" enabled, I couldn't download "Update 2" nor could I run my packages (ie. Plex, Download Station).

 

Following the advise on this this thread, I deleted the ".xenpoboot" and on reboot, the "Lan 1" returned and everything is working OK now.

Edited by dh22r

Share this post


Link to post
Share on other sites

Hi ...thank you for the advise  i tried to do this from root@Jettlee etc i get a message saying

 

Rm: cannot remove    .xpenoboot : no such file or directory

 

Having the issue as others with no network after 6.2 update

Share this post


Link to post
Share on other sites
Posted (edited)
On 10/7/2018 at 3:37 PM, ajs1544 said:

Hi ...thank you for the advise  i tried to do this from root@Jettlee etc i get a message saying

 

Rm: cannot remove    .xpenoboot : no such file or directory

 

Having the issue as others with no network after 6.2 update

There is a gnoboot folder ....could that be causing the issue and need deleting..?

Edited by ajs1544

Share this post


Link to post
Share on other sites
On 10/9/2018 at 8:08 AM, ajs1544 said:

There is a gnoboot folder ....could that be causing the issue and need deleting..?

Edited Tuesday at 08:08 AM by ajs1544

I cant find .xpenoboot folder.

I use the ubuntu live cd and mdadm tutorial to see the files.

Any help?

Share this post


Link to post
Share on other sites

Had same issue with nic now all working clean install. Am I now safe to goto 6.2.1

mb is gigabyte h67 with i3 nic Realtek 8111f

thanks

Edited by gsxr

Share this post


Link to post
Share on other sites

you guys should be using this command

sudo rm -rf /.xpenoboot

or if you want to just see it, run this:

ls -la /
drwxr-xr-x  16 root root  4096 Oct 29 08:19 volume1
drwxr-xr-x   4 root root  4096 Oct  4  2016 .xpenoboot

 

Edited by ideasman69

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now