sbv3000

Phantom drive ports

Recommended Posts

Hi All

This has got me scratching my head so any thoughts would be useful.

 

I'm upgrading an ASUS mobo from 5.2 to 6.1 that has 6 on board sata (5 internal and 1 esata) plus a Supermicro (Marvell) 8 port sas/sata controller.

In 5.2 the onboard were set to IDE (and only 4 channels enabled) and with the Marvell I had 12 drives - all good.

 

With 6.1 I've swapped on board to AHCI mode, the 6 sata appear as drives 1-6 in DSM - all ok for the test.

 

Then the fun.

The Marvell controller is working ok, but its channels start at drive 8 and upwards in DSM, so I have a 'phantom' drive slot at 7 and had to adjust the synoinfo.conf to see beyond 12 drives, all ok

 

What has me confused is this phantom drive slot at position 7, there are no other controllers on the system, I've tried various sataport settings with no change.

The other weird thing is that with the on board totally disabled, DSM still sees slots 1-4 (empty) and the 8 port starts from channel 5.

 

I think other people are seeing similar situations with some installs and so any ideas where to look or how to diagnose would be useful

 

Share this post


Link to post
Share on other sites

what asus mobo exactly?

with all 6 internal to ahci and the other controller in try what

lspci -k

gives back for loaded modules

also the log should give a hint as the numbering of ports should be seen there

Share this post


Link to post
Share on other sites
9 hours ago, IG-88 said:

what asus mobo exactly?

with all 6 internal to ahci and the other controller in try what


lspci -k

gives back for loaded modules

also the log should give a hint as the numbering of ports should be seen there

Thanks @IG-88, its an old E35M1-M PRO with an embedded dual core amd. Currently used just as a backup target on 5.2 and was testing the 6.x options. I did check the pci devices but will drill deeper with that command and feed back

 

Share this post


Link to post
Share on other sites

after having a look to the manual a wild guess would be the firewire port, so try to disable it in bios

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now