Cesuhl

Chelsio T420 NIC Drivers

Recommended Posts

Hi,

 

I've successfully installed the latest DSM 6 running Jun's 1.02b DS916+ loader and Polanskiman's awesome guide, however i've got a dual 10Gb NIC i want to use in this system that doesn't seem to be recognised so far. The onboard NIC's on my motherboard get recognised which is how i have been able to get it installed, just wondering if anyone has had any luck with a Chelsio 10Gb card in the latest release?

 

I guess i don't really know what i am doing but I did try compiling the Chelsio drivers using this guide https://xpenology.club/compile-drivers-xpenology-with-windows-10-and-build-in-bash/ using https://sourceforge.net/projects/dsgpl/files/DSM 6.1 Tool Chains/Intel x86 Linux 3.10.102 (Braswell)/ and https://sourceforge.net/projects/dsgpl/files/Synology NAS GPL Source/15152branch/braswell-source/linux-3.10.x.txz/download in place of what was in the guide but i didn't have much success with it.  

 

I did also notice that Polanskiman's guide did mention a custom ramdisk, which might be what i want? i found a copy of the custom ramdisk extra.lzma and it appears that there are Chelsio drivers in it however this appears to have only been for the DS3615sx and it also appears that there may be issues with it with the 1.02b loader as there is a comment on the guide that says it is "temporarily offline".

 

Any help would be greatly appreciated :)

 

 

Share this post


Link to post
Share on other sites
10 hours ago, Cesuhl said:

Hi,

 

I've successfully installed the latest DSM 6 running Jun's 1.02b DS916+ loader and Polanskiman's awesome guide, however i've got a dual 10Gb NIC i want to use in this system that doesn't seem to be recognised so far. The onboard NIC's on my motherboard get recognised which is how i have been able to get it installed, just wondering if anyone has had any luck with a Chelsio 10Gb card in the latest release?

 

I guess i don't really know what i am doing but I did try compiling the Chelsio drivers using this guide https://xpenology.club/compile-drivers-xpenology-with-windows-10-and-build-in-bash/ using https://sourceforge.net/projects/dsgpl/files/DSM 6.1 Tool Chains/Intel x86 Linux 3.10.102 (Braswell)/ and https://sourceforge.net/projects/dsgpl/files/Synology NAS GPL Source/15152branch/braswell-source/linux-3.10.x.txz/download in place of what was in the guide but i didn't have much success with it.  

 

I did also notice that Polanskiman's guide did mention a custom ramdisk, which might be what i want? i found a copy of the custom ramdisk extra.lzma and it appears that there are Chelsio drivers in it however this appears to have only been for the DS3615sx and it also appears that there may be issues with it with the 1.02b loader as there is a comment on the guide that says it is "temporarily offline".

 

Any help would be greatly appreciated :)

 

 

Try the 1.02b loader for DS3615 and @IG-88 v3.2 extra.lzma from the link in this post

or you could try the loader I assembled for 6.1.3 with v3.2 included

 

 

Share this post


Link to post
Share on other sites

the drivers for Chelsio would be cxgb, cxgb3 or cxgb4 atm they are not in the 3.2 package for 3615 (no one asked for them, nerver heard the name and thouht they are exotic and left them to add later)

 

yesterday i started compiling drivers for 3615 (as base for doing the same for 3617 and 916+)

as they are in the kernel i can easyly add them to the lsit of drivers to compile, they seem to need firmware, have to look for the files then

 

i can do 916+ next (before 3617) so maybe in a few hours i will have the extra.lzma with your drivers for 916+ (3615 was finished and i already started adding them as i want all 3 packages to be the same)

i will send you a pm with the link, would be nice if someone tested it with real hardware, i only do vm testing for 3617/916+)

the "official" release will be with a new driver list and for all 3 supported loaders in the next days

  • Like 1

Share this post


Link to post
Share on other sites

oh wow! awesome, thanks so much. I'll wait patiently for now :) i'm still waiting for a couple of HBA cards in the mail anyway, so can't complete my build just yet until they arrive. Was just doing some testing to make sure i can get the software up and running.

Share this post


Link to post
Share on other sites

Just thought i would update my experience with the new 4.0 extra.lzma file from IG-88 posted here: 

 I've tried both the DS3615 and DS3617 with my Chelsio T420 10Gb NIC and both versions have successfully recognised the card and displaying the additional network interfaces within the Synology OS. i have not bothered testing with DS916+ at this point as IG-88 has pointed out that the Chelsio drivers at this point are not in the extra.lzma package. I am currently running version DSM 6.1.4-15217 Update 2.

 

I did have issues with the initial installation of both versions using the 4.0 extra.lzma though. after successfully booting jun 1.02b loader with the 4.0 extra.lzma the Synology Assistant was not able to locate the device, i needed to rollback to the original extra.lzma and complete the installation then reboot one last time with the 4.0 extra.lzma before it worked correctly. I am not sure if this is normal or not but wasn't a big issue.

 

Thanks IG-88 for the updated 4.0 extra.lzma 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now