eratome51

[Tuto] DSM 6.0 sur Hyper-V

Recommended Posts

Salut à tous,

 

Ici je vais vous expliquez comment faire tourner le DSM 6 Xpenology sur Hyper-V.

 

Téléchargez les VHDX (uploadés par moi même) prévues à cet effet : https://1drv.ms/u/s!Anih4xuqH7tysAOHkDHOqgim2CZ_

 

Créer une nouvelle machine virtuelle en respectant scrupuleusement les mêmes paramètres que ce screenshot :

 

364522dsmhyperv.png

 

Appliquez les paramètres comme l'image ci-dessus.

 

N'ajoutez pas votre VHDX de données tout de suite.

 

Démarrez la machine virtuelle attendez 3 à 5 minutes le temps quelle démarre, et configurez là via http://find.synology.com/

 

Une fois quelle est démarrée et que tout est OK, éteignez-là et ajoutez votre disque VHDX de données :

 

360190dsm6hypervdata.png

 

Démarrez de nouveau la machine virtuelle, est vous pouvez allez commencer à créer votre volume dans le Gestionnaire de disque.

 

N'appliquez pas les mises à jour du DSM !

 

Enjoy !

  • Like 4

Share this post


Link to post
Share on other sites

Bonjour Eratom et merci pour ce tuto et tout ce travail !!

 

J'allais finir par investir dans un Syno, mais ce tuto serait peut être une issue, je dis peut être car dans ton tuto je ne peux ajouter seulement 2 processeur virtuel, et non 4 :-/

Est-ce problématique ? En tout cas je suis en train de tester avec 2 proco virtuel, je vous tiens au courant.

Share this post


Link to post
Share on other sites
On 29/05/2017 at 11:30 AM, Hiraclis said:

Bonjour Eratom et merci pour ce tuto et tout ce travail !!

 

J'allais finir par investir dans un Syno, mais ce tuto serait peut être une issue, je dis peut être car dans ton tuto je ne peux ajouter seulement 2 processeur virtuel, et non 4 :-/

Est-ce problématique ? En tout cas je suis en train de tester avec 2 proco virtuel, je vous tiens au courant.

 

Alors ça donne quoi avec plus de vCPU en plus ?

Share this post


Link to post
Share on other sites

Bonjour @eratome51 et merci pour ce travail,

 

En configurant ma VM avec 4 proc, j'ai une erreur, elle ne démarre pas.

Avec 2 proc ça passe, mais par contre après la décompression de Linux le démarrage reste bloquer sur "Booting the kernel".

Une idée de résolution du problème ? Merci.

Share this post


Link to post
Share on other sites

Salut @eratome51 et merci pour ce tuto

Question bête, j'ai actuellement un DSM 5.2 qui tourne sur HyperV également avec 3 VHDX de 1TB.

Je vais pouvoir les raccrocher au DSM 6 à ton avis (sans perte de données évidemment :)) ?

 

D'avance merci

Share this post


Link to post
Share on other sites
On 31/07/2017 at 6:58 AM, Gery said:

Bonjour @eratome51 et merci pour ce travail,

 

En configurant ma VM avec 4 proc, j'ai une erreur, elle ne démarre pas.

Avec 2 proc ça passe, mais par contre après la décompression de Linux le démarrage reste bloquer sur "Booting the kernel".

Une idée de résolution du problème ? Merci.

 

Salut, 

 

Si tu es Booting the Kernel, il te suffit d'attendre 3 à 5 minutes le temps quelle démarre, et configure là via http://find.synology.com/

 

On 08/09/2017 at 9:48 AM, CrazyVolnay said:

Salut @eratome51 et merci pour ce tuto

Question bête, j'ai actuellement un DSM 5.2 qui tourne sur HyperV également avec 3 VHDX de 1TB.

Je vais pouvoir les raccrocher au DSM 6 à ton avis (sans perte de données évidemment :)) ?

 

D'avance merci

 

Le mieux étant de refaire une nouvelle machine DSM 6 et de synchroniser les données entre les deux et d'éteindre le 5.2 une fois cela fait.

Share this post


Link to post
Share on other sites

Salut eratome51,

 

Merci pour ta réponse !

Tu as raison, c'est plus sage. Mais cela nécessite d'avoir le double de stockage temporairement, durant la resynchro.

 

J'essaie de faire l'opération dans les prochains jours et je tâcherai de faire un retour, si ça peut en aider d'autres ...

 

Share this post


Link to post
Share on other sites

Re !

 

Bon, je n'ai vraiment pas d'espace disque libre pour appliquer ton conseil, aussi sage soit-il :)

J'ai un MicroServer G8 avec 4x2TB SAS. Et mon Syno actuel m'en prends déjà 6TB (3 VHDx de 2TB ...)

Bon, j'ai tenté la chose suivante :

- Création de 2 nouveaux VHDx de 1TB en volume dynamique (oui, surprise, à ma connaissance, ça ne fonctionnait pas en 5.2 ...)

- Attachement de ces 2 VHDx à mon Syno 5.2

- Création d'un nouveau volume sur le Syno 5.2 basé sur les 2 précédents volumes en format JBOD + ext4

- Création d'un partage et copie d'un fichier mkv

- Arrêt du Syno 5.2

- Détachement des 2 VHDx du Syno 5.2

- Attachement des 2 VHDx sur le Syno 6.0

- Démarrage du Syno 6.0

- Sur la GUI après le login, j'ai un warning m'indiquant qu'un volume doit être réparé :o

- Je répare ... :roll:

- Dans Disk Station, le partage est visible 8-) Par contre, il faut remapper les droits ...

- Bingo le MKV est accessible est lisible !

 

On peut donc migrer sans trop de problème un volume créé sous 5.2 et l'attacher sur un 6.0 facilement.

 

J'ai donc franchi le pas (en serrant des fesses, je ne vous le cache pas ...) et appliqué la même procédure pour migrer mon volume de 6 TB sur le Syno 6.0. Même constat, tout est fonctionnel !

 

En espérant que ça puisse rassurer ceux qui, comme moi, n'ont pas de quoi doubler leur capacité de stockage pour une migration de 5.x vers 6.x.

 

Evidemment, cela a fonctionné dans mon cas, mais je ne pourrai garantir que cela s'applique pour vos configurations

  • Thanks 1

Share this post


Link to post
Share on other sites

Bonjour eratome51 et tout le monde)

désolé pour mon mauvais français)

Est-il quelqu'un de dépistage ou qui sait quels paramètres pour VM besoin d'exécuter DSM sur MS Hyper-V?  Et puis dans le premier post, les captures d'écran ne sont pas affichés) :12_slight_smile:

Share this post


Link to post
Share on other sites
On 25/04/2018 at 1:49 PM, stfeinen said:

Bonjour
Est-ce qu'il existe déjà une version pour le DSM 6.1?

 

Merci

 

Salut, je travail actuellement dessus.

 

On 17/05/2018 at 3:53 PM, Alex_White said:

Bonjour eratome51 et tout le monde)

désolé pour mon mauvais français)

Est-il quelqu'un de dépistage ou qui sait quels paramètres pour VM besoin d'exécuter DSM sur MS Hyper-V?  Et puis dans le premier post, les captures d'écran ne sont pas affichés) :12_slight_smile:

 

Je vois bien les captures d'écran chez moi. Désactives bloqueurs de pub etc.. sur ton navigateur.

Share this post


Link to post
Share on other sites
34 минуты назад, eratome51 сказал:

Je vois bien les captures d'écran chez moi. Désactives bloqueurs de pub etc.. sur ton navigateur.

déjà compris, merci

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour,

je relance pour savoir s'il n'y a pas de version 6.1 disponible et aussi pour les images du premier POST, j'ai le même soucis d'images qui ne s'affichent pas.

J'ai testé sur un autre navigateur et désactivé adblock mais idem.

Serait il possible de mettre les screens sur le onedrive comme le vhdx?

Merci

Edited by wimaxx

Share this post


Link to post
Share on other sites
Posted (edited)

364522dsmhyperv.png

 

364522dsmhyperv.thumb.png.262b70b9723ade21a5a2513b29202815.png

 

60190dsm6hypervdata.png

 

360190dsm6hypervdata.png

Edited by alexsh

Share this post


Link to post
Share on other sites

Re bonjour,

je viens d'appliquer comme indiqué et j'ai un soucis lors de la création du volume, le status est en panne, j'ai bien rajouté un disque VHDX, j'ai meme essayé d'en rajouter 2 pour utiliser le mode RAID SYNO mais pareil...

Un conseil?

(je suis sous HYPERV 2016 et la VM en Gen 1)

Share this post


Link to post
Share on other sites
2 hours ago, wimaxx said:

Re bonjour,

je viens d'appliquer comme indiqué et j'ai un soucis lors de la création du volume, le status est en panne, j'ai bien rajouté un disque VHDX, j'ai meme essayé d'en rajouter 2 pour utiliser le mode RAID SYNO mais pareil...

Un conseil?

(je suis sous HYPERV 2016 et la VM en Gen 1)

 

Salut

 

N'ajoutez pas votre VHDX de données tout de suite.

 

Démarrez la machine virtuelle attendez 3 à 5 minutes le temps quelle démarre, et configurez là via http://find.synology.com/

 

Une fois quelle est démarrée et que tout est OK, éteignez-là et ajoutez votre disque VHDX de données.

Share this post


Link to post
Share on other sites
Posted (edited)
54 minutes ago, eratome51 said:

 

Salut

 

N'ajoutez pas votre VHDX de données tout de suite.

 

Démarrez la machine virtuelle attendez 3 à 5 minutes le temps quelle démarre, et configurez là via http://find.synology.com/

 

Une fois quelle est démarrée et que tout est OK, éteignez-là et ajoutez votre disque VHDX de données.

 

Salut,

c'est ce que j'ai fait, j'ai utilisé l'assistant, configuré l'ip etc... éteind la VM, ajouté le disque et j'ai quand même le soucis.

Le disque peut etre en dynamique?

j'ai testé les 2 en VHD et VHDX mais idem

 

je vais réessayer de zéro je pense.

Merci pour les réponses.

 

EDIT : je viens de tout refaire idem.

2018-07-24_2204.png

Edited by wimaxx

Share this post


Link to post
Share on other sites
Posted (edited)

@eratome51 Merci pour ton travail ! As-tu pensé à faire une mise a jour des VHD vers un DSM plus recent ?

Edited by Thesaw

Share this post


Link to post
Share on other sites
On 7/24/2018 at 9:18 PM, wimaxx said:

 

Salut,

c'est ce que j'ai fait, j'ai utilisé l'assistant, configuré l'ip etc... éteind la VM, ajouté le disque et j'ai quand même le soucis.

Le disque peut etre en dynamique?

j'ai testé les 2 en VHD et VHDX mais idem

 

je vais réessayer de zéro je pense.

Merci pour les réponses.

 

EDIT : je viens de tout refaire idem.

2018-07-24_2204.png

 

Cela me semble bon, si il est reconnu c'est que tu es sur la bonne voie. En réparant le volume ça ne fonctionne toujours pas ?

 

2 hours ago, Thesaw said:

@eratome51 Merci pour ton travail ! As-tu pensé à faire une mise a jour des VHD vers un DSM plus recent ?

 

J'y travail ;-)

Share this post


Link to post
Share on other sites
17 minutes ago, eratome51 said:

 

Cela me semble bon, si il est reconnu c'est que tu es sur la bonne voie. En réparant le volume ça ne fonctionne toujours pas ?

 

 

J'y travail ;-)

 

Malheureusement après la réparation le volume reste en panne. Tant pis, pour le moment j'insiste pas, en espérant qu'à la rentrée il y ai une nouvelle version ;)

 

 

Share this post


Link to post
Share on other sites

Bonjour @eratome51

Quel est le fichier .pat que tu utilise pour l'installation de la DSM ? 

Merci de me donner le lien de téléchargement si possible

Merci d'avance et bien joué pour le tuto :)

Edited by aliger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now