Sign in to follow this  
YukonKnights

[SOLVED] Trouble with WOL on a Dell T20

Recommended Posts

I am having trouble getting WOL to work using Jun's loader. I am using a Dell T20 and WOL is enabled in the BIOS. In grub.cfg I have set the MAC address to the physical address of my NIC, I have enabled WOL on eth0 under Control Panel/Hardware and Power/Power Recovery in DSM, and if I SSH into my machine and run 'ethtool eth0' the output shows:

 

Supports Wake-on: pumbg

Wake-on: g

 

which as far as I understand means that the machine is capable of running WOL. Unfortunately if I now turn the machine off from within DSM, then a WOL command issued from a number of different Android Apps cannot wake the computer. If I interrupt the machine booting, enter the BIOS, and then turn the machine off again, WOL does work, so it sounds like something in DSM is stopping WOL from working. Does anyone have any suggestions?

Thanks!

Share this post


Link to post
Share on other sites

Anyone got any thoughts??

 

From further experimenting it seems that when DSM is shutdown from the web GUI it completely turns off my NIC (no lights are blinking), so it is not able to respond to the WOL magic package. Does anyone know how I can prevent DSM from completely shutting down the NIC?

Share this post


Link to post
Share on other sites

I don't know much about the T20 but this looks to me like a BIOS config issue. Check the power state in which the bios leaves the machine once it is shutdown and try all available options.

Share this post


Link to post
Share on other sites

in the dsm control panel under hardware & power there are point "WOL an LAN1..." check that they are enabled

Share this post


Link to post
Share on other sites
I don't know much about the T20 but this looks to me like a BIOS config issue. Check the power state in which the bios leaves the machine once it is shutdown and try all available options.

 

You're right! I was sure I had gone through every BIOS setting one-by-one, but I must have missed something. I shorted the BIOS jumpers to reset to the default settings and it is working fine now. Thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this