windaube21

bug interface reseau

Recommended Posts

bonjour

 

j'ai un nas xpenology DS3615xs en version DSM 5.2-5644

 

j'ai un port rj45 en 100mega que j'utilise pas et qui est sur la carte mere

j'ai rajouter 2 carte Ethernet gigabit en pci

 

les 3 cartes sont reconnu en lan 1 2 et 3 ( lan 1 et 2 se sont les cartes gigabit et le lan 3 est la carte en 100mega non utiliser )

 

le branche mes deux carte sur le switch, elle sont les 2 en dhcp donc le nas chope deux adresse différente et je peux acceder a mon nas sur ces deux ip ( les cartes fonctionne )

 

jusque la tout va bien .....

 

je veux pour essayer faire du load balancing pour avoir deux lien gigabit qui vont sur le nas ( pour la vitesse )

 

je vais donc dans les interfaces reseau et je fait "crée" > "bond"

et je choisi adaptive load balancing, ensuite je choisi les interfaces lan 1 lan 2

je lui met une ip fixe avec un masque et tout qui va bien

 

quant je fait appliquer il y a une barre de chargement et je me retrouve avec un bug a se moment

 

au lieu de me fair un "bond" avec lan 1 et lan 2 dedans il me fait un bond avec lan 1 dedans et a coter j'ai lan 2 avec le dhcp desactiver et sans ip et surtout il n'est pas inclut dans le bond .....

 

j'avais fait cette manip il y a un mois sur la meme machine avec le meme matos et sa avait fonctionner sans souci

 

j'ai ré installer dms complet sans suces

 

help :cry:

Share this post


Link to post
Share on other sites

Bonsoir,

 

Pas testé ce mode (je suis en 802.3ad LACP sur mon NAS) mais personnellement je ne connecterai pas la 2ème interface avant d'avoir fait la configuration.

En principe, en bonding, le module linux associe l'adresse MAC de la carte définie en MASTER à l'interface virtuelle.

Si l'interface est encore configurée en DHCP, et prend l'adresse de la première carte, le serveur va lui redonner l'adresse de la carte 1, ce que le protocole DHCP refusera (test par une requête ARP de la disponibilité de l'adresse sur le réseau).

Je n'ai pas tracé pour regarder, mais je pense que c'est ce qui se passe.

 

Donc, ce que je tenterai c'est :

1) Ne garder que LAN1 de connecté

2) Configurer LAN1 et 2 dans le bonding

3) Attribuer une IP fixe libre à l'interface de bonding (éventuellement en dehors de la plage DHCP de la box)

4) Vérifier que l'interface de bonding passe en service avec l'adresse fixe

5) Connecter l'interface LAN2 et vérifier que le lien fonctionne toujours

6) Déconnecter LAN1 et retester

7) Remettre les 2 interfaces en service

8) Si tout est OK, sauvegarder la configuration

 

A tester donc

Jacques

Share this post


Link to post
Share on other sites

bonjour

 

merci de la reponce

 

enfaite je me suis rendu compt que le débit etait vraiment nul sur une des deux cartes

 

j'ai simplement deplacer d'un port pci une carte et la le bond fonctionne bien, j'ai refait la manip a l'envers et le problème reviens

 

simplement un bug incompatibilité mais bizzare tout de meme car le pci est un bus normalement donc l'emplacement je joue pas

Share this post


Link to post
Share on other sites

Bonjour,

 

Si, l'emplacement sur un bus joue. C'est un lien partagé (un ou plusieurs bus sur la carte mère selon sa "taille"), et selon la position, certaines cartes sont donc isolées sur le bus ou bien se retrouvent avec une autre carte qui peut monopoliser les ressources.

Les cartes réseaux sont gourmandes en ressources (si on veut faire autre chose qu'un ping..).

De plus, selon l'architecture de la carte, pour les bus PCI-E, on ne dispose pas forcément du plein débit.

A priori, tes 2 cartes réseaux étaient sur le même bus. Pour vérifier, il faut regarder dans la doc de la carte mère, éventuellement dans le manuel de maintenance du serveur.

 

Jacques

 

Extrait de Wikipedia (https://fr.wikipedia.org/wiki/PCI_%28informatique%29) :

Dans sa version purement PCI la bande passante est partagée entre tous les éléments connectés sur le bus, contrairement à ce qui se passe pour la version PCI Express où elle est dédiée pour chaque périphérique. Cette dernière est donc préférable si on veut utiliser simultanément des cartes haut débit (carte réseau gigabits, contrôleur de disque, carte graphique…).

Share this post


Link to post
Share on other sites