Jump to content
XPEnology Community

virtualbox: dsm5 using nanoboot - issue with boot


Symbiot78
 Share

Recommended Posts

Hi

 

I setup a VB and want to run xpenology dsm.

 

I am using bootimage: Nanoboot-5.0.3.2 DSM 5.0-4528 X64

 

and using dsm file: DSM 5.0-4528 (Main)

 

both downloaded from : http://www.xpenology.nl/xpenology-software/

 

When I boot with nanoboot and select install/upgrade the image boots but it seems to be stuck..

 

 

image:

 

kdl7hk.png

 

 

I can access the webif via syno assistant but when I try to use the .pat file I get an error...

 

What am I doing wrong?

Edited by Guest
Link to comment
Share on other sites

ok, so nevermind the screenshot.. I just couldn't see the full screen.. so the bootscreen is actually showing "diskstation login"..

 

when I go to synology assistant and rightclick and select "install" it throws an "error 22" when it tries to format the system partition..

 

Ideas?

Link to comment
Share on other sites

First thing you need to make sure is that it isn't trying to install to you nanoboot drive. I suggest removing all drives but nanoboot, boot the VM, go to the webinstall page, go through the motions and see if it still gives you the option to install... usually it will tell you the number of drives it finds. Take note of this info. power off, attach your array disks, virtual disks, ect, repeat the previous process and make sure it is seeing the additional drives.

 

2 thinks could be happening; it could be trying to install to your nanoboot drive, or it might not be seeing the drives you want to build the array with. Doing the above should help you narrow down those 2 variables, or eliminate them both.

 

I'd also try vmware/esxi, since it is the most common of all virtual machine software used for xpenology, and proven to work. I'm not too sure about virtual box, but I tried Citrix Zenserver just playing around, and wasn't able to get it to work with my nic cards. I'm pretty sure people have gotten these alternatives to work, but in the end, it's more work adding/removing/building new kernel modules to get stuff supported.

Link to comment
Share on other sites

Hi guys..

 

thanks for the suggestions...

 

so removing all ide/sata/scsi disks (only cd with nanoboot attached)

gives me an error on the webif... no harddrives found.. so there is a difference..

 

attaching a sata controller & satadisk.. (not ssd)

webif recognizes 1 disk, but during initialization it fails.

 

attaching a disk onto the ide controller where the nanoboot iso is mounted..

error 21..

 

scsi gives me an error 38..

Link to comment
Share on other sites

I may have found my problem..

 

I allocated 4Gb for the syno host disk.. and this seems to have been the problem.

I just tried allocating 200Gb (dynamically assigned) to a second disk and now it is formatting/installing... I don't really want to use 200gb nor do I want the disk to be dynamically resized but...

will update on progress..

Link to comment
Share on other sites

sooo. .. I think I got it working...

Annoyingly I do not know quite how..

What I did was... try multiple versions of nanoboot..

Then I tried the synoboot.img from this site.. still didn't work..

 

Then I deleted all vdi files, vmdk's etc. that I tested..

 

I then booted with nanoboot *4528

and installed version 4528 from xpenology.nl

 

This combo.. which I've tried before.. seems to work.

Harddisk in Vbox is 50 Gb Sata.

Link to comment
Share on other sites

 Share

×
×
  • Create New...