sagos

Не работают дополнительные LAN порты (платы Intel)

Recommended Posts

Знаю, что здесь есть опытные парни. Мужики, помогите пожалуйста.

Недавно переехал путём миграции с 3615 на 918 с заменой материнки. Всё прошло, как по маслу. Работает нормально.

Решил сделать побольше сетевых портов. Поставил сетевую EXPI9301CTBLK.  Всё нормально работало на двух портах (встроенном и дополнительном)

Но ведь мало :-)

Установил четырёхпортовую плату Intel E1G44ET2. Включил и обрадовался. Работают все порты.

Но после перезагрузки система стала видеть всего два порта (из пяти). То есть, два порта на сетевой работаю и всё. Встроенный тоже отрубился.

Естественно, Grub правил.

Больше никакие перезагрузки не помогают.

Причём, в системе порты видны, но написано, что отключены. Никакие перетыкивания кабелей не помогают. Перезагрузки не помогают.

Помогает такой алгоритм.

Выключаю, вытаскиваю сетевую, запускаю на встроенной.

Опять выключаю, вставляю сетевую, запускаю. Опять работают все пять портов. До очередной перезагрузки.

 

Может кто знает, в чём проблема и как запустить все порты?

 

Сразу замечу, что сетевая исправна, т.к. пробовал ещё с другой (E1G44HT ). То же самое.

Share this post


Link to post
Share on other sites

Ставлю двухпортовую карту HP и чуда не происходит. Всё-равно видит только 2 порта (встроенную не видит).

Я так думаю, что это проблема из-за миграции со сменой материнки? Может где-то в файлах можно поправить? У меня старая материнка была с двумя встроенными LAN портами (N3150), а эта с одним (Z170, G4500)

Share this post


Link to post
Share on other sites
В 26.10.2019 в 10:56, sagos сказал:

Может кто знает, в чём проблема и как запустить все порты?

В том, что 918+ по определению умеет только 2 порта, остальные игнорируются. Нужно больше — ставьте 3617.

Share this post


Link to post
Share on other sites

Я нашёл решение. Достаточно поставить "maxlanport="5"  в файле /etc.defaults/synoinfo.conf и видятся все порты. Заодно убавил количество пустых ячеек для дисков.

  • Like 1

Share this post


Link to post
Share on other sites
5 часов назад, sagos сказал:

Я нашёл решение. Достаточно поставить "maxlanport="5"  в файле /etc.defaults/synoinfo.conf и видятся все порты. Заодно убавил количество пустых ячеек для дисков.

Только учтите, что при обновлении версии DSM придется править файл заново.

Share this post


Link to post
Share on other sites

Да, благодарю за предупреждение. Я уже читал где-то, что нужно будет опять исправлять. Но зато работает. Других вариантов я не нашёл. Да и обновляюсь я редко.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.