• 0
TNa681

Error 50 -> when transferring files from Finder to Synology

Question

Hi all,

 

I am struggeling with an "Error 50 ..." message when transferring an bunch of files from Finder to Synology.  I just installed my NAS and are now trying to fill it up with my data but always get initerrupted by this issue.

 

I've set it up to smb as well as afp.

 

Does anybody know how avoid this error?

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Did you use encryption on your NAS volume? Encrypted drives have a restriction in maximum file name length.

 

How do you connect to your share? Wireless or cable? Error 50 means a problem with the communication between your Mac and NAS.

 

You can try to restrict the SMB protocol to V3 only and see if it works better.

Share this post


Link to post
Share on other sites
  • 0

Hi jensmander,

 

as far as I know I don't use encryption for my drives (think it is needed to set a pw and I can remeber that I havn't done that). I am not at home at the momnet and can't check it, sorry.

 

Yes, as the monment I am connected via 5GHz WIFI, but be also able to make connect a cable (just need to buy one which has the right lenght)

 

Alright (need to check the protocol option and what's set right now).

 

Maybe another information which is neccessary to find the root cause:

Some of the files I'd like to transfer to my Diskstation where the "ERROR 50..." message came up are originally coming from ab backup of the Photo Library from an old Diskstation  (DS109+). Some years ago I moved them to an external 4TB HDD, since my 109+ was slow and wasn't fun to use anymore. I found a lot of @eaDir folders as well as Thumbs.db files on it, which I removed completely. But there is still the "ERROR 50..." message coming up each time I am trying to copy several folders with more than 800GB in total.

Share this post


Link to post
Share on other sites
  • 0

So do you copy them to your new photo station folder? In this case it‘s possible that Dsm locks certain files. If you‘ve setup a new photo station I would recommend uploading only pure image/movie files and nothing else.

Share this post


Link to post
Share on other sites
  • 0

No, just copy them to an shared folder I created. I don't want to use the photo station.

Share this post


Link to post
Share on other sites
  • 0

According to my research the problem is not DSM but MAC OS. Here is what I suggest.

 

Open Finder and go to where the directory you want to copy to your NAS is. Then press "Command + Shit + ." (dot). That will show all hidden files within MAC OS finder. Now browse your directory and sub-directories. If you see any .AppleDouble.AppleSingle files or @eaDir directories they will need to be deleted. They normally are the source of the error 50 you are seeing. If you see many of those files and you have loads of sub-directories then you can do this in one go through Terminal, otherwise you can delete them manually. If you use Terminal then you can issue the following commands:

 

Change directory to the directory want to copy:

cd [directory-path]

Now check in which sub-directories the files are. 

find . \( -name ".AppleDouble" -o -name ".AppleSingle" -o -name "@eaDir" \)

If those files are present you will see a list of paths.

 

Now you can delete the files:

find . \( -name ".AppleDouble" -o -name ".AppleSingle" -o -name "@eaDir" \) -exec rm -rf {} \;

Deletion is permanent so be very careful you are on the root of the directory you want to work with otherwise the search will expand to wherever you are.

 

Alternatively you could explicit the full path of your directory:

find \[directory-path] \( -name ".AppleDouble" -o -name ".AppleSingle" -o -name "@eaDir" \)
find \[directory-path] \( -name ".AppleDouble" -o -name ".AppleSingle" -o -name "@eaDir" \) -exec rm -rf {} \;

 

Obviously, replace [directory-path] with the actual path of the directory.

 

To hide hidden files simply press "Command + Shit + ." again.

 

If you are unsure of something it is better to ask first.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thank you very much for your great support, once I am back home I'll try the terminal option!

 

I'll let you know if it was successfull or not.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.