Jump to content
XPEnology Community
  • 0

M2 Volume doesn't work no matter what I try (no Throughput)





I have been trying to enable M2 volume on my NAS following this script for enbabling M2 Storage and this script for updateing the HDD database.


Creating the Storage and Volume always works but the read/write speed of the drive is as slow as a regular HDD. 


Benchmarking the Drive results in "Throughput not supported". I tried different SSDs, different DSM versions and even a totally different system (AMD and Intel).


What am I missing? Any help is really appreciated since this is driving me nuts :4_joy:




Edited by Philebos
Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I am using Automated Redpill Loader (i18n) latest version.


The PC is an AMD Ryzen 5 4500 with an Asrock B550M PG Riptide Mainboard. However, I have also tried it with an Intel System with the same result. I have also tried a different loader. 


The NVMe are detected by the system and I can create a storage pool as well as a volume. The problem is always that the read/write speed is on the level of a regular HDD and not a NVMe (around 130 Mb/s). 


Given all of this I am certain that I am missing something / doing something wrong. However, I cannot find my mistake because whenever I try again the same occurs. No matter what kind of NVMe I use (I tried many different ones just to make sure...)

Link to comment
Share on other sites

  • 0

It's not the loader causing it. I get the same "Throughput Not Supported"  on a real DS1821+ for both internal NVMe drives and NVMe drives in a E10M20-T1.


Interestingly it does different types of tests depending on the location on the NVMe drive.

  • For internal NVMe drives it did a Basic test.
  • For NVMe drives in an adaptor card it did an Extended test.
Edited by 007revad
Link to comment
Share on other sites

  • 0

Today I tried a totally different bootloader (fbelavenuto/arpl) and a later Version of DSM (7.1) with the same result.


Given the fact that this doesn't seem to be a common problem I have to assume that it has something to do with the brand/make of M.2 SSD I am using.


I ordered a Samsung M.2 today to test this hypothesis. Will report back the results.


Link to comment
Share on other sites

  • 0

How is the actual read/write speed of these drives in your case? 


I only did the Benchmark after realizing that the speed of the drives wasn't what it should be.


See the screenshot of the speedtest of my DSM M.2 Storage Volume....


but the drive is correctly recognized




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...