cstout

Drives Out of Order (Numbering)

Recommended Posts

Hello out there,

 

I'm asking this question on behalf of anyone else out there that may have some obsessive compulsive tendencies...

 

Since switching my RAID mode to AHCI (required for DSM 6 bare metal boot) my motherboard SATA and Marvell SATA connections are separated by four blank drive spaces (images below). I've seen the question asked before, but I have not found any threads with an answer or solution. Does anybody know how the drives are numbered in DSM? Is it possible to change the order? In XPE 5.2 I had this exact same issue and disabling eSATA in the BIOS removed the gap and placed all of my drives together in order. Since going to 6 the gap is back and eSATA is still disabled.

 

Drives currently show 1,2,3,4,9,10,11,12 (1-4 Marvell, 9-12 Motherboard).

 

D093DPF.png

 

wtZDbxq.png

Share this post


Link to post
Share on other sites

DSM does some weird interpretation of drive/controller numbers based on (I think) the PCI/IRQ etc channels and controller chips.

From my experience onboard sata 1-4 will always be Storage Manager 1-4, but other drives will appear based on the hardware enumeration. In multi controller builds I've generally given up on the logic and found it simpler to document and label sata ports/lead on the controllers to match what DSM shows.

In your example, DSM has 'decided' that the Marvel controller is 9-12, you dont have another 4 physical ports but as the default config is for 12 bays you get the 4 empty slots shown

I think if you want to tidy this up, then edit the synoinfo.conf file to just have 8 internal drives (something like maxdisks="8" internalportcfg="0x00ff") and the 4 phantom ports should disappear.

Make sure you back up your critical data before you mess around with this as a wrong config could make a drive 'disappear' and it will crash your array - recoverable but painful and risky

Share this post


Link to post
Share on other sites

You might also have eSATA enabled which might be enumerated before an additional controller, worth checking whether you can disable this in the bios.

Share this post


Link to post
Share on other sites